You are not logged in.

#1 2013-05-29 05:44:31

From: Szczecin, Poland
Registered: 2012-08-14
Posts: 149

[SOLVED] fsck.vfat fails to remove dirty bit

I have UEFI partition which is, next to /boot partition, only partition that needs fsck. My root and /var are sub-volumes on btrfs partition while /home is on nilfs2 partition. I had to remove fsck from mkinitcpio.conf's hooks to avoid annoying warnings while upgrading my kernel and while booting (these could be avoided by simply adding 0 pass values to my fstab but I like my system as clean as possible so even the upgrade warnings were annoying for me). I decided to create simple script and run it as systemd service:

umount /boot/efi
umount /boot
fsck.vfat /dev/sda1
fsck.ext4 /dev/sda2
mount /dev/sda2 /boot
mount /dev/sda1 /boot/efi

But it fails on 3rd line:

$ sudo fsck.vfat /dev/sda1
dosfsck 3.0.16, 01 Mar 2013, FAT32, LFN
0x41: Dirty bit is set. Fs was not properly unmounted and some data may be corrupt.
1) Remove dirty bit
2) No action
? 1
Leaving file system unchanged.
/dev/sda1: 3 files, 33/130812 clusters

Why is it leaving the file system "unchanged"? Shouldn't it report something else? It goes that way every time, even if ran one time after another...

Edit: I don't know why but it's just not reading my "1" answer the right way... with -a flag (automatic repair), everything is okay.

Last edited by smsware (2013-05-29 07:24:04)


#2 2015-01-22 10:30:54

Registered: 2012-10-25
Posts: 213

Re: [SOLVED] fsck.vfat fails to remove dirty bit

For some reason I've same problem and "-a" made it work. So I guess it's a bug in fsck.vfat.


Board footer

Powered by FluxBB