You are not logged in.

#1 2013-06-08 22:07:33

madr
Member
From: Norway
Registered: 2013-04-25
Posts: 87

Can't install Dropbox from AUR due to missing dependencies.

I'm posting in the Newbie Corner, since I suspect that this is a newbie issue with a really simple solution..

I've been using Dropbox for Linux directly from Dropbox.com, but I had now decided to convert to the AUR version (easier to update). But it won't install. It won't even build.

==> Manglende avhengigheter:
  -> qt
==> Kontrollerer avhengigheter som trengs under bygging...
==> FEIL: Kunne ikke finne alle avhengigheter.
==> ERROR: Makepkg was unable to build bbox-git.
==> Restart building bbox-git ? [y/N]

Not optimal that this is in norwegian.. But in essence it tells me that there are missing dependencies. Qt to be exact. And because of this makepkg is not able to build bbox-git. Earlier in the process (when the dependencies for bbox-git is listed) it says that qt is not installed and will be buildt from AUR. I've tried to reinstall qt. Please help.

EDIT:
I'm using Yaourt.

Last edited by madr (2013-06-08 22:24:06)

Offline

#2 2013-06-08 22:58:09

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,992
Website

Re: Can't install Dropbox from AUR due to missing dependencies.

You say you've tried to install qt, does that mean you failed to install it?  qt should not be installed from the AUR, it is a package group in [extra].


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#3 2013-06-08 23:00:57

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: Can't install Dropbox from AUR due to missing dependencies.

Run

LC_ALL=C <command>

to get output in English.

Offline

#4 2013-06-08 23:01:45

mcmillan
Member
Registered: 2006-04-06
Posts: 694

Re: Can't install Dropbox from AUR due to missing dependencies.

First, that's not the dropbox package, but something that is like dropbox. If you want the actual dropbox program you want https://aur.archlinux.org/packages/dropbox

If this is the package you actually want, it looks like it hasn't been updated since the qt packaged was renamed qt4, so you'll need to change that in the PKGBUILD file by hand.

Offline

#5 2013-06-08 23:04:56

karol
Archivist
Registered: 2009-05-06
Posts: 25,430

Re: Can't install Dropbox from AUR due to missing dependencies.

I'm not sure if https://aur.archlinux.org/packages/dropbox is easier to update - as you can read in the comments, many users are not happy with the auto-update feature.
Maybe it's too easy to update ;P , but YMMV.

Offline

#6 2013-06-08 23:17:56

madr
Member
From: Norway
Registered: 2013-04-25
Posts: 87

Re: Can't install Dropbox from AUR due to missing dependencies.

Trilby wrote:

You say you've tried to install qt, does that mean you failed to install it?  qt should not be installed from the AUR, it is a package group in [extra].

I've tried to reinstall it. And I've installed it from the official repos of course. The AUR bit is output from Yaourt, not me.

karol wrote:

Run

LC_ALL=C <command>

to get output in English.

I'll post the output of this later (it's getting late here).

mcmillan wrote:

First, that's not the dropbox package, but something that is like dropbox. If you want the actual dropbox program you want https://aur.archlinux.org/packages/dropbox

If this is the package you actually want, it looks like it hasn't been updated since the qt packaged was renamed qt4, so you'll need to change that in the PKGBUILD file by hand.

It is the package you're linking to I'm having trouble installing. Okay, I'll have a look. Later. I'll get back to this thread.

karol wrote:

I'm not sure if https://aur.archlinux.org/packages/dropbox is easier to update - as you can read in the comments, many users are not happy with the auto-update feature.
Maybe it's too easy to update ;P , but YMMV.

Do I ever catch a break in life? Not often at least.

Offline

Board footer

Powered by FluxBB