You are not logged in.

#1 2013-06-10 05:26:08

aqeeliz
Member
Registered: 2007-10-13
Posts: 30

[SOLVED] Can't Change Brightness on Intel VGA

Hey,

I can't change brightness, either from the buttons on laptop or the slider in power management (default KDE applet). When I try it, the OSD shows brightness changing but there is no actual change of brightness.

Some info about my laptop:
It's HP Probook 4540s, which has Intel and ATI Radeo hybrid/dual VGA cards. After reading https://wiki.archlinux.org/index.php/Hybrid_graphics , I disabled my discrete (ATI) graphic card from BIOS, now:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)

Though, I couldn't change the brightness when I hadn't disabled ATI card either. I also have both xf86-video-ati and xf86-video-intel installed.

Any suggestions?

Edit: Updated thread title.

Last edited by aqeeliz (2013-06-10 15:22:00)

Offline

#2 2013-06-10 05:37:15

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't Change Brightness on Intel VGA

I think if you are not using your ATI card at all, you should update your title to reflect that it is an issue with your intel backlight and not Intel/ATI.  I skipped over this thread at first because I know very little about dual video card setups.

In any case, I have the same hardware according to lspci, and I have to use acpi_osi="!Windows 2012" on the kernel command line.  Some people report that using acpi_osi=Linux works as well.  acpi_backlight=vendor somewhat improves the situation, but apparently this is very very strongly discouraged by the acpi people.

If you try the not-windows acpi_osi parameter, you need to make sure you adhere to your bootloader's way of handling double quotes.  If it is grub2, you can simply escape them with backslashes... so it would be acpi_osi=\"!Windows 2012\".  You might also have to escape the ! as well, but I can't remember, as I don't actually use grub2.  The one that is particularly odd is rEFInd though, as it specifies the use of double double-quotes. 

Good luck!

Offline

#3 2013-06-10 08:10:38

aqeeliz
Member
Registered: 2007-10-13
Posts: 30

Re: [SOLVED] Can't Change Brightness on Intel VGA

WonderWoofy wrote:

In any case, I have the same hardware according to lspci, and I have to use acpi_osi="!Windows 2012" on the kernel command line.  Some people report that using acpi_osi=Linux works as well.  acpi_backlight=vendor somewhat improves the situation, but apparently this is very very strongly discouraged by the acpi people.

If you try the not-windows acpi_osi parameter, you need to make sure you adhere to your bootloader's way of handling double quotes.  If it is grub2, you can simply escape them with backslashes... so it would be acpi_osi=\"!Windows 2012\".  You might also have to escape the ! as well, but I can't remember, as I don't actually use grub2.  The one that is particularly odd is rEFInd though, as it specifies the use of double double-quotes.

By kernel command line, I am assuming you mean the 'linux' line in grub boot list.

I tried both acpi_osi=\"!Windows 2012\" and acpi_osi=Linux, neither worked. I added them after ro quiet, and pressed F10 to boot, it should boot with the edited entry, right?

Also, there are lots of repetitions of the following messages in dmesg, not sure if they were present before too, or are just appearing after adding that !Windows:

[ 8427.949528] atkbd serio0: Unknown key pressed (translated set 2, code 0xa7 on isa0060/serio0).
[ 8427.949537] atkbd serio0: Use 'setkeycodes e027 <keycode>' to make it known.

As far as I can figure out, they are for each time I press the Fn+brightness-low/brightnes-high key, or move the brightness slider in applet.

Offline

#4 2013-06-10 13:33:06

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't Change Brightness on Intel VGA

Did you try using acpi_osi=\"\!Windows 2012\" ?   I mentioned above that you might need to escape the ! as well.

Offline

#5 2013-06-10 15:21:44

aqeeliz
Member
Registered: 2007-10-13
Posts: 30

Re: [SOLVED] Can't Change Brightness on Intel VGA

Okay, replaced " with ' and it worked without escaping (I hadn't tried without escaping before). That is

acpi_osi='!Windows 2012'

Thanks for all your help.

Offline

#6 2013-06-10 16:02:59

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Can't Change Brightness on Intel VGA

Hmmm... that is a fantasticlly simple idea.  Way to go.  I don't know why I didn't think to try that, as I just figured that since all examples in the documentation indicated double quotes the kernel command line must be picky.  I guess the other reason I never tried single quotes is because I use gummiboot, which doesn't require escaping and all that mumbo-jumbo... it takes the line exactly as it and appends it to the kernel command line.

I will lodge this single quote solution in the back of my head somewhere for future reference!  Glad you got this solved!

BTW, presumably, at some point we will no longer need this addition to the boot parameters.  I check every so often, but it has been this way (I think) consistently for a couple versions now.

Offline

#7 2013-08-10 10:54:21

qwertypoke
Member
Registered: 2011-09-06
Posts: 21

Re: [SOLVED] Can't Change Brightness on Intel VGA

Some additional help for efibootmgr:
After too many attempts I finally found the correct bash command line format for efibootmgr. Tip use -v to see what the efi command really contains.

# efibootmgr -v -c -L "Arch Linux acpi_osi_not_windows" -l /vmlinuz-linux -u 'root=/dev/sda2 rw initrd=/initramfs-linux.img acpi_osi="!Windows 2012"'

This enables the screen brightness control keys on my Asus X502CA

Offline

#8 2014-01-07 19:46:59

aularon
Member
Registered: 2014-01-07
Posts: 1

Re: [SOLVED] Can't Change Brightness on Intel VGA

I am on ubuntu 12.04 x64. Today I upgraded kernel, xserver to 12.03 LTS enablement stack, also upgraded to the latest catalyst driver(ATI Radeon HD 6370M, HP ProBook 4520s). After restart, backlight keys are working and the slider showing on screen, but the backlight itself is not changing at all.

After a bit of search I came here and tried the `acpi_osi="!Windows 2012"` boot parameter, and it works again now.
So I am here telling my tale with some keywords, for anyone who is facing the same problem with a similar hardware.

Offline

Board footer

Powered by FluxBB