You are not logged in.

#1 2013-06-16 15:48:46

teateawhy
Member
From: GER
Registered: 2012-03-05
Posts: 1,133
Website

[SOLVED]networkmanager segfault with new, secured wlan

Hi,
i did not connect to new wlan routers for a while, and since last time the nm-applet quits with a segmentation fault.
Here is what i do:
$ nm-applet
Choose new network from the list in the applet:

** Message: applet now embedded in the notification area
** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
** Message: Remote error from secret service: org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.secrets was not provided by any .service files
zsh: segmentation fault (core dumped)  nm-applet

I can succesfully connect to my own wlan router, that has a password, without entering it.
Ideally for new wlan routers, nm-applet should ask for the password instead of a segfault.

EDIT: Solved by installing gnome-keyring.

Last edited by teateawhy (2013-06-16 15:53:21)

Offline

#2 2013-07-26 11:47:39

mooattyi
Member
Registered: 2011-01-17
Posts: 24

Re: [SOLVED]networkmanager segfault with new, secured wlan

That was my problem and the solution too. Thanks dude!

Offline

#3 2013-08-02 21:04:00

mmd
Member
Registered: 2013-08-02
Posts: 4

Re: [SOLVED]networkmanager segfault with new, secured wlan

I have been having this problem for a long time and finally I find a solution. Thank you!

Offline

#4 2013-10-20 11:09:47

gunjah292
Member
From: Hamburg
Registered: 2011-05-05
Posts: 183

Re: [SOLVED]networkmanager segfault with new, secured wlan

I have the same problem. But installing gnome-keyring didn't solve it for me.


KDE Plasma, ThinkPad X380 Yoga, Intel Core i7-8550U, Intel UHD Graphics 620, 512GB PCIe-NVMe SSD (OPAL 2.0), 16GB PC4-19200 (2400 MHz)

Offline

#5 2015-04-16 13:48:59

Senselessfull
Member
Registered: 2014-06-03
Posts: 8

Re: [SOLVED]networkmanager segfault with new, secured wlan

gunjah292 wrote:

I have the same problem. But installing gnome-keyring didn't solve it for me.

For anyone still having the same problem: you might still have to enable the gnome-keyring to start.
The wiki has a good part about it.

Offline

Board footer

Powered by FluxBB