You are not logged in.

#1 2013-06-17 23:10:00

rustysail
Member
Registered: 2013-06-17
Posts: 7

VLC and other video programs not working

I have been running arch for a while now, xmonad included.

All of a sudden I am having a problem with VLC that I can't seem to solve.

I have been googling it for a while and keep finding other people with the same problem, but I can't find a solution. The only thing that makes sense is that I started using yaourt recently and I am afraid it messed something up.

I have tried reinstalling multiple times. I also tried just switching to mplayer. It has the same error bassically

If anyone can help me out I would appreciate it. Below is my error message.

No suitable decoder module:
VLC does not support the audio or video format "mp4v". Unfortunately there is no way for you to fix this.

[rusty@thing1 ~]$ vlc
VLC media player 2.0.7 Twoflower (revision 2.0.6-54-g7dd7e4d)
[0x19ec138] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Unable to load library icui18n "Cannot load library icui18n: (icui18n: cannot open shared object file: No such fi
[0x7f7e68c03ff8] main decoder error: no suitable decoder module for fourcc `mp4v'. VLC probably does not support                                      this sound or video format.
[0x7f7e64ea2cf8] access_http access error: error: HTTP/1.1 403 Forbidden
[0x7f7e64ea2cf8] access_http access error: error: HTTP/1.1 403 Forbidden
[0x7f7e64ea2cf8] access_mms access error: error: HTTP/1.1 400 Invalid Request
[0x7f7e64004f18] main demux meta error: no suitable access module for `http://services.tvrage.com/feeds/search.ph                                     p?show=Archer 2009'

Offline

#2 2013-06-17 23:18:56

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: VLC and other video programs not working

Try installing icu package.

Offline

#3 2013-06-18 00:10:51

rustysail
Member
Registered: 2013-06-17
Posts: 7

Re: VLC and other video programs not working

Karol, thanks. That helped. It still does the same thing, but now the error changed slightly. The line that mentioned icu now says.

[0x7f23d4c03ef8] main decoder error: corrupt module: /usr/lib/vlc/plugins/codec/libkate_plugin.so

Tried reinstalling libkate but nothing hapened.

Offline

#4 2013-06-18 00:41:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: VLC and other video programs not working

Is your system up to date?
What's the output of

ldd /usr/lib/vlc/plugins/codec/libkate_plugin.so

Offline

#5 2013-06-18 20:56:19

rustysail
Member
Registered: 2013-06-17
Posts: 7

Re: VLC and other video programs not working

On a different computer now.

I don't know why but everything went to hell last night. I can get into xmonad and open a terminal but that is about it.

VLC still says libkate is corrupt.
Firefox now saying that libxpcom.so has an error and that libicule.so.50 will not open
mplayer says that libx264.so.129 won't open
thunar says that libicu.so.50 won't open

I can't remove any of these libraries and pacman says that are all good.

That ldd command came back with a pretty long list of .so files.

I have no idea what is going on.

Offline

#6 2013-06-18 21:00:14

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,315
Website

Re: VLC and other video programs not working

karol wrote:

Is your system up to date?

This.

Check that your mirror is active and then -Syyu.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#7 2013-06-18 21:52:16

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: VLC and other video programs not working

icu is currently in version 51.2-1 so you should have foo.so.51, not foo.so.50 installed.
I think you run 'pacman -S icu' where you should have run 'pacman -Syu icu' - assuming your mirror is up to date.


Don't worry about the ldd output for now and follow jasonwryan's advice.

Offline

#8 2013-06-18 22:37:56

rustysail
Member
Registered: 2013-06-17
Posts: 7

Re: VLC and other video programs not working

Hey thanks

So both commands try to install/update/remove a ton of packages. It downloads them all and then says

error failed to commit transaction (invalid or corrupted package)

and quits. I tried clearly out all the partial packages in /var/cache/pacman/pkg/ but nothing came of it.

How do I tell if my mirrors are up to date?

Also from reading around, could this have something to do with my clock? I did recently change timezones...

Offline

#9 2013-06-18 22:43:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: VLC and other video programs not working

There are many ways of assuring the mirrors you use are up to date:
* https://www.archlinux.org/mirrorlist/
* https://www.archlinux.org/mirrors/status/
* https://wiki.archlinux.org/index.php/Reflector

Can you post a couple more lines of the error message? What are the lines just before - "checking package integrity"?

Check your time and date settings with 'timedatectl'.

Offline

#10 2013-06-18 23:03:04

rustysail
Member
Registered: 2013-06-17
Posts: 7

Re: VLC and other video programs not working

it says this but the list of packages is much longer. Probably 20 or so. It runs through the whole list very quickly.

sg3_utils-1.36-1-x86_64                               673.0   B   0.00B/s 00:00 [#################################] 100%
webkitgtk2-1.10.2-7-x86_64                         674.0   B   0.00B/s 00:00 [#################################] 100%
(386/386) checking keys fin key ring                                                     [#################################] 100%
(386/386) checking package integrity                                                    [#################################] 100%
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded

Offline

#11 2013-06-18 23:25:37

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: VLC and other video programs not working

Run

find /var/cache/pacman/pkg -name "*.part"

and remove any *.part files it finds.

Offline

#12 2013-06-19 02:02:01

rustysail
Member
Registered: 2013-06-17
Posts: 7

Re: VLC and other video programs not working

I think my mirror list is up to date. It looks good as far as I can tell.

All the part files were already gone too. No change in results.

Offline

#13 2013-06-20 20:06:19

rustysail
Member
Registered: 2013-06-17
Posts: 7

Re: VLC and other video programs not working

I ended up backing up and wiping my hard drive for a fresh install. So I guess this is now solved.

Any advice on how to avoid this problem in the future?

Offline

#14 2013-08-03 15:06:20

mmgomez
Member
From: Argentina
Registered: 2010-06-19
Posts: 3

Re: VLC and other video programs not working

Solution
Look for errors here:

ldd /usr/lib/vlc/plugins/codec/libavcodec_plugin.so

Most likely, you're missing libavcodec.so.53 and libavutil.so.51, which are part of package ffmpeg-compat

I realized that after linking manually (ln -s) the libraries in /usr/lib/ffmpeg-compat to /usr/lib, but maybe you can fix it by reinstalling ffmpeg-compat

sidenote: it was working fine for me until 7/30/2013, when pacman updated both vlc and ffmpeg. now it works again.

Last edited by mmgomez (2013-08-03 15:08:49)


if debugging is the process of removing bugs, then programming must be the process of putting them in.- Dijkstra

Offline

#15 2013-08-03 23:10:37

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: VLC and other video programs not working

Make sure faad2 is installed.

EDITED.

Last edited by David Batson (2013-08-03 23:12:52)

Offline

#16 2013-08-04 02:57:20

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,784

Re: VLC and other video programs not working

mmgomez wrote:

Solution
Look for errors here:

ldd /usr/lib/vlc/plugins/codec/libavcodec_plugin.so

Most likely, you're missing libavcodec.so.53 and libavutil.so.51, which are part of package ffmpeg-compat

I realized that after linking manually (ln -s) the libraries in /usr/lib/ffmpeg-compat to /usr/lib, but maybe you can fix it by reinstalling ffmpeg-compat

sidenote: it was working fine for me until 7/30/2013, when pacman updated both vlc and ffmpeg. now it works again.

Yeah, that is a totally and completely different issue than the one in this month+ old thread.

Plus it's already been fixed.

Last edited by Scimmia (2013-08-04 03:07:50)

Offline

#17 2013-08-04 03:39:58

karol
Archivist
Registered: 2009-05-06
Posts: 25,423

Re: VLC and other video programs not working

The original thread was about a couple issues and 'ldd /usr/lib/vlc/plugins/codec/libavcodec_plugin.so' might have helped in one of them, but in the end it didn't matter.

I agree this thread has nothing to with some of the recent issues with vlc.

Offline

Board footer

Powered by FluxBB