You are not logged in.

#1 2013-06-20 20:01:10

Registered: 2013-06-11
Posts: 2

Flash plays video a fast as it can. Also no sound.

I've been trying to figure this one out for the last 4 hours and my brain is currently fried.  All flash videos play as fast as they can. 

I'm running XFCE desktop.  Firefox is the default browser.  Adobe flashplugin from arch repos.  I have an AMD 5470 mobility radeon with the xf86-video-ati driver.  I did also install and enable the vdpau support according to the directions on the wiki page.  I've tried disabling hardware accel in the flash config file.  I've tried disabling it on the flash check box.  I uninstalled vdpau packages and unset the local variables.  The 'stats for nerds' option always says It's running with software video rendering and software video decoding, so to me it sounds like something isn't configured quite right, but for the life of me I can't find where.

There is also no sound from video's, but I'm not sure that isn't caused from the same misconfiguration elsewhere in the system.

Any help would be greatly appreciated.


#2 2013-07-28 19:40:23

Registered: 2012-05-17
Posts: 32

Re: Flash plays video a fast as it can. Also no sound.

I had this problem and I think it was because of pulseaudio. If you have pulseaudio try any of these:

Restart firefox
Open pavucontrol and see if any of your audio outputs are wrong
restart pulseaudio with

pulseaudio --kill; killall pulseaudio; killall -9 pulseaudio; rm -rf ~/.pulse*; rm -rf /tmp/pulse*; pulseaudio --start


#3 2013-08-16 20:37:38

Registered: 2013-08-16
Posts: 1

Re: Flash plays video a fast as it can. Also no sound.


Yes tnx, this fixed it for me:

stop browsers (ff , chrome)
   - enable my analog device (which was turned of/muted), disable mute stuff i dont need (hdmi sound etc)
start browser

( i also restarted pulseaudio first, before i tried this, but that didn't fix it. Dunno if that influenced it)

Last edited by robinvanleeuwen (2013-08-16 20:38:32)


#4 2013-08-18 13:59:52

Registered: 2013-04-10
Posts: 1,401

Re: Flash plays video a fast as it can. Also no sound.

if this is indeed caused by pulseaudio, one thing you could try is to route all alsa applications (eg. flash player) to pulse.

you need alsa-plugins package installed, and put this in your ~/.asoundrc or /etc/asound.conf

pcm.pulse {
    type pulse
ctl.pulse {
    type pulse
pcm.!default {
    type pulse
ctl.!default {
    type pulse

I had to use this when I was running jackd alongside pulseaudio on another distro (nowadays it's bare alsa+jackd).

Last edited by ooo (2013-08-18 14:00:34)


Board footer

Powered by FluxBB