You are not logged in.

#1 2013-06-24 22:08:03

Registered: 2010-11-28
Posts: 4

MacBook Pro 8,2 - Enabling Intel GPU results in blank screen

I am trying to install Arch on my MacBook Pro 8,2.  I've followed the wiki page, and I should note that I have successfully installed Arch on here before (about 4 months ago) and it worked then.  However, this time I have made several attempts and failed every time.

I installed Arch and put Grub-efi on the EFI system partition.  rEFInd picked it up, it runs fine, but of course X video doesn't work right out of the box because it runs off the AMD discrete graphics initially-- stuck at console only as long as I'm on the discrete.  Problems with the discrete graphics don't matter though, since for battery life, I plan to power off the AMD discrete graphics and just run the Intel graphics-- no vgaswitcheroo or anything, nothing fancy.  This worked on my previous install with no problems, using the outb commands in Grub as noted on the wiki.  But now, as soon as those commands are processed, the screen goes completely blank and just stays that way.  The system is still running in the background and once it boots it can be blindly rebooted.

I have also tried not powering down the graphics immediately, instead using this little program, disable-ati.c, from here (initially meant for fixing resume problems) to allow me to play around and control when exactly I turn the power on.  Anyway... same effect of course since it's just changing when the outb commands are run.  But it allows me to make sure everything else is booted first.  With it, I tried a test: I ran disable-ati and then tried running startx.  Of course I can't see anything, but I rebooted the system and checked Xorg.0.log and found "No devices detected" and "No screens found".  Which is what the outb commands are supposed to solve if the wiki page is to be believed.  There are no errors in the log until then apart from not being able to load failsafe modules like fbdev and vesa (simply because they aren't installed).

To note, apart from defaults, I'm loading the modules ahci, libahci, and i915 through mkinitcpio.conf and have rebuilt the images.
My kernel arguments are: radeon.modeset=0 i915.modeset=1 i915.lvds_channel_mode=2 i915.lvds_use_ssc=0
I have tried many combinations of these, including reordering them or omitting one or more.  No difference no matter what.

So... what's going on here?  This is pretty much documented all over the web to work absolutely fine for MacBook Pro 8,2 users.  Except me, apparently.  Not sure what could be going wrong, considering everything on here is a fresh install.  I reformatted the whole thing yesterday and started completely from scratch following the instructions very exactly.

Fellow MBP8,2 users, your help would be appreciated!

Last edited by MrKsoft (2013-06-24 22:12:22)


#2 2013-07-08 13:32:45

Registered: 2013-02-11
Posts: 2

Re: MacBook Pro 8,2 - Enabling Intel GPU results in blank screen

I'm using a mbp 8,2 and it's working.
What kernel are you using? Mine is 3.9.9-1
I'm using efistub with refind.
I don't use any special boot options, if I boot with nomodeset, i consume way less power, but then the external display and suspend don't work.
what packages do you have installed?
I insalled the ati, intel  and fbdev driver along with mesa


#3 2013-08-19 16:40:07

Registered: 2010-11-06
Posts: 41

Re: MacBook Pro 8,2 - Enabling Intel GPU results in blank screen

Small bump, but I'm experiencing the same issue - there's a bug report about it here:

And one upstream too:


Board footer

Powered by FluxBB