You are not logged in.

#1 2013-07-02 23:16:20

From: Liège, Belgium
Registered: 2013-07-02
Posts: 5

(Solved) [Intel HDA] Headphones not detected

Hi there,

I'm having an annoying issue since I've installed (and re-installed) Arch on my netbook.

Everything's alright (except Gnash, but I'll google that later), the internal speakers work perfectly but when I put my headphones or my speakers (ext.) the internal speakers are "muted-off" (so the jack is detected, right?) but nothing's coming out from my headphones/speakers.

Here's my aplay -l out :

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: CONEXANT Analog [CONEXANT Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: Conexant Digital [Conexant Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

And here is my amixer output:

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 65536
  Front Left: Playback 65536 [100%] [on]
  Front Right: Playback 65536 [100%] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch cswitch-joined
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 65536
  Front Left: Capture 27636 [42%] [off]
  Front Right: Capture 27636 [42%] [off]

and a lspci | grep Audio output:

00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 02)

My headphones are plugged-in since I booted.

Another problem is that when I'm launching alsamixer there's only the master (Card: PulseAudio - Chip: PulseAudio). So, I make F6 > "1 HDA Intel" and I have other channels :
Master (100 & unmuted) - PCM (100 & unmunted) - Mic (0 & muted) - S/PDIF (muted) - S/PDIF Default PCM (unmuted) - Beep (86 & muted) - Internal Mic (0 & muted) -- (Card: HDA Intel - Chip: Conexant CX20549 (Venice))

This is strange because on my former installation of Arch (on the same PC) the "default" alsamixer had exactly the same channels and the "Master only" didn't 'exists'. (But I had the same problems).

I tried a bunch of solutions I found but none worked.

alsa-utils alsa-plugins & alsa-oss are installed (base-devel too if it can help).

I'm using SLiM & Cinnamon and had the same issue with LXDM & LXDE (same computer).

So if somebody could gave me a little bit of his light it'll be much appreciated! smile

Thank you, Flaco

*Edit: Since I've rebooted with the headphones plugged-in the internal speakers don't work neither... but it may be something else; I tried a lot of solutions so maybe there's conflict between some files and/or process...

**Edit: Internal speakers issue solved. I might have touched some stuffs on pavucontrol before... anyway, the headphones are still a problem... hmm

***Edit: I've booted (on a live usb) on Lubuntu to see what's happening and... still no sound. The jack input might be broken; I'll open my computer to see what's happening and to repair (or not) it. smile

Last edited by Flaco (2013-07-04 00:19:57)


#2 2013-07-03 16:33:05

From: Liège, Belgium
Registered: 2013-07-02
Posts: 5

Re: (Solved) [Intel HDA] Headphones not detected

bump :x


Board footer

Powered by FluxBB