You are not logged in.

#1 2005-11-20 13:19:10

florian
Member
Registered: 2005-11-20
Posts: 11

hotplug blacklist stopped working

For several days now (don't know exactly when it started) the pcspkr and intel_agp modules get loaded on boot up although both are listed in /etc/hotplug/blacklist. I can't remember changing anything related to hotplugging so I suppose this is due to a recent Arch update. Does anyone have any hints or ideas what might have caused this and how to revert to the old behaviour? Thanks for any help on this.

Offline

#2 2005-11-20 13:31:06

Clanman
Member
Registered: 2005-02-08
Posts: 35

Re: hotplug blacklist stopped working

I have no solution but I have the same problem. Adding modules under /etc/hotplu/blacklist doesn't prevent them from loading.

//Clanman

Offline

#3 2005-11-20 13:34:09

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: hotplug blacklist stopped working

My guess is that you should turn of the hwdetect script.

Offline

#4 2005-11-20 14:15:03

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,837

Re: hotplug blacklist stopped working

Or else, leave hwdetect on and put the modules in the hwdetect blacklist instead.

Have a look at the latest rc.conf - most likely rc.conf.pacnew on your systems.

Offline

#5 2005-11-20 14:29:26

florian
Member
Registered: 2005-11-20
Posts: 11

Re: hotplug blacklist stopped working

Thx LB06, I guess that was the problem (I haven't yet tried rebooting, though).

Somehow this new option in rc.conf must have slipped in when I updated that file smile

What's the reason for not doing this in a seperate script in /etc/rc.d/ just like hotplug and hwd?

Offline

#6 2005-11-20 15:56:23

LB06
Member
From: The Netherlands
Registered: 2003-10-29
Posts: 435

Re: hotplug blacklist stopped working

florian wrote:

Thx LB06, I guess that was the problem (I haven't yet tried rebooting, though).

Somehow this new option in rc.conf must have slipped in when I updated that file smile

What's the reason for not doing this in a seperate script in /etc/rc.d/ just like hotplug and hwd?

You just might have a point...

Offline

#7 2005-11-20 15:59:52

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: hotplug blacklist stopped working

florian wrote:

Somehow this new option in rc.conf must have slipped in when I updated that file smile

Yeah, I thought the hwdetect thingy was currently for testing only, but it's definitely in the latest script upgrades.  I just happened to catch that it was there, and it does seem to be working perfectly on my boxes.


oz

Offline

#8 2005-11-21 15:34:44

ozar
Member
From: USA
Registered: 2005-02-18
Posts: 1,681

Re: hotplug blacklist stopped working

More info has been posted on the initscript updates:

http://archlinux.org/news.php#188


oz

Offline

Board footer

Powered by FluxBB