You are not logged in.

#1 2013-07-07 03:41:47

Bolt473
Member
From: Knoxville, TN, US
Registered: 2013-03-11
Posts: 10

[SOLVED] Anjuta opens my folders

I'm running GNOME 3.x, and now whenever I open directories from any application other than Nautilus (Chromium 'Open downloads folder' option, Places menu, et cetera) the directory will be opened in Anjuta. This is quite adverse, and I couldn't find any option in gnome-settings or gnome-tweak-tool to change this behaviour. Please help!

Last edited by Bolt473 (2013-07-13 17:50:09)


"There's no problems, only solutions." -John Lennon
Compaq CQ5320F, Gateway 4540GZ
Samsung p3113 (rooted and ROM'd), HP iPAQ hw6945 (Can't find custom ROM)

Offline

#2 2013-07-07 12:03:28

ivoarch
Member
From: the six feet under the ground
Registered: 2011-03-31
Posts: 436

Re: [SOLVED] Anjuta opens my folders

Try $> xdg-mime default nautilus.desktop inode/directory


I love GnuEmacs, GnuScreen, ratpoison, and conkeror.
Github )||( Weblog

Offline

#3 2013-07-13 03:45:43

Bolt473
Member
From: Knoxville, TN, US
Registered: 2013-03-11
Posts: 10

Re: [SOLVED] Anjuta opens my folders

Thanks. That worked, and I'm saving it in case it happens again.


"There's no problems, only solutions." -John Lennon
Compaq CQ5320F, Gateway 4540GZ
Samsung p3113 (rooted and ROM'd), HP iPAQ hw6945 (Can't find custom ROM)

Offline

#4 2013-07-13 08:35:24

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: [SOLVED] Anjuta opens my folders

Rememeber to add [SOLVED] to your topic subject wink
Cheers.


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#5 2013-07-29 10:25:49

jzinedine
Member
Registered: 2013-07-29
Posts: 1

Re: [SOLVED] Anjuta opens my folders

Thanks for providing the solution, saved me tons of hassle.

Last edited by jzinedine (2013-07-29 10:28:29)

Offline

#6 2014-10-23 12:17:48

skinnie
Member
From: Portugal
Registered: 2012-10-17
Posts: 16

Re: [SOLVED] Anjuta opens my folders

ivoarch wrote:

Try $> xdg-mime default nautilus.desktop inode/directory


Sorry to bump this thread.
I am having this same problem.
Just to be sure, I just type this terminal: xdg-mime default nautilus.desktop inode/directory
didn't solved.
Run with sudo and got this output:
touch: cannot touch ‘/root/.local/share/applications/mimeapps.list’: No such file or directory
/usr/bin/xdg-mime: line 820: /root/.local/share/applications/mimeapps.list.new: No such file or directory

problem is not solved, any thoughts?


Lenovo Thinkpad X230/12.5' Flexview IPS/Samsung 830 256Gb SSD/16GB DDR3/Intel HD4000/Intel 6205 Wifi

Offline

#7 2014-10-26 14:23:45

xypista
Member
Registered: 2014-07-31
Posts: 7

Re: [SOLVED] Anjuta opens my folders

I'm having problems with it as well. I enabled the Places menu, and anything in it opens up Anjuta. The command above doesn't seems to work.

Even tried this with no success.

Last edited by xypista (2014-10-26 14:27:57)

Offline

#8 2014-10-26 16:40:42

colegui
Member
From: Castellón de la Plana, Spain.
Registered: 2014-07-20
Posts: 64

Re: [SOLVED] Anjuta opens my folders

Hi xypista, open the terminal and browse to :

~/.local/share/applications/mimeapps.list

.. and put the next:

[Default Applications]
inode/directory=org.gnome.Nautilus.desktop

Link: http://blog.valhue.es/entradas/2014/10/ … E0jv3-3UWM

Best Regards.

Offline

#9 2014-10-27 17:48:16

xypista
Member
Registered: 2014-07-31
Posts: 7

Re: [SOLVED] Anjuta opens my folders

Thanks colegui, that worked.

Based on this information, the command above should be

xdg-mime default org.gnome.Nautilus.desktop inode/directory

for Gnome 3.14.

Offline

#10 2014-10-29 13:19:00

fsckd
Forum Moderator
Registered: 2009-06-15
Posts: 3,514

Re: [SOLVED] Anjuta opens my folders

Closing to prevent further necro-bumps. Please start a new thread if you have similar issues.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

Board footer

Powered by FluxBB