You are not logged in.

#1 2013-07-07 09:54:55

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 325

Kde poor performance with OpenGl Shader (Lenovo S300)

Hi, with my Notebook Lenovo Ideapad S300 i've discovered that Kde isn't so smooth as it should be. I had an Intel HD 3000 and a Cpu Intel Core i3, the exposè effect is not regular, because it hangs when for example i have Chromium, Konsole and Dolphin opened, also changing windows through alt-tab is affected by this issue.
I found the solution by disabling the OpenGl 2 Shader under the OpenGl Otions on Desktop Effects. I don't know why without this option the system becomes smooth, but it works. Another possible solution is to set the use of graphical effects under "low usage of cpu and low resolution" (under Application Appearance, second tab). My Arch system is up to date and i'm using also the SNA acceleration method (i haven't seen any changes using Sna or Uxa).

If someone had the same problem, please tell me. Regards, Marco

Last edited by toketin (2013-07-07 09:55:27)

Offline

#2 2013-07-07 12:04:43

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 446

Re: Kde poor performance with OpenGl Shader (Lenovo S300)

may try to use kwin_gles?


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#3 2013-07-07 21:37:51

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 325

Re: Kde poor performance with OpenGl Shader (Lenovo S300)

I've tried to start it but doing so the plasma effects doesn't work anymore.

Offline

#4 2013-07-08 04:12:37

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 446

Re: Kde poor performance with OpenGl Shader (Lenovo S300)

ALT  SHIFT F12 didn't worked?
For my HD4k on my Thinkpad Edge E530 it works just fine.


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#5 2013-07-08 19:28:25

toketin
Member
From: Belluno (Italy)
Registered: 2007-04-17
Posts: 325

Re: Kde poor performance with OpenGl Shader (Lenovo S300)

[marco@idearcha ~]$ kwin_gles --replace
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
QCoreApplication::sendPostedEvents: Cannot send posted events for objects in another thread
libEGL warning: failed to create a pipe screen for i965
OpenGL vendor string:                   Intel Open Source Technology Center
OpenGL renderer string:                 Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL version string:                  OpenGL ES 3.0 Mesa 9.1.4
OpenGL shading language version string: OpenGL ES GLSL ES 3.0
Driver:                                 Intel
GPU class:                              SandyBridge
OpenGL version:                         3.0
GLSL version:                           3.0
Mesa version:                           9.1.4
X server version:                       1.14.2
Linux kernel version:                   3.9.9
Direct rendering:                       yes
Requires strict binding:                no
GLSL shaders:                           yes
Texture NPOT support:                   yes
Virtual Machine:                        no
kwin(1236): Failed to initialize compositing, compositing disabled 
kwin(1236): Consult http://techbase.kde.org/Projects/KWin/4.0-release-notes#Setting_up

Nothing i can't get the effect working, this is the output.

Offline

Board footer

Powered by FluxBB