You are not logged in.

#1 2013-07-09 01:22:28

CubeGod
Member
Registered: 2013-07-09
Posts: 110

A multitude of iBus issues

So, let's give some backstory, I come from years of debian experience and decided to finally try arch.
Installing it was easy enough and configuring it wasn't troublesome, getting xorg running was easy as pie and installing a DE wasn't problematic, as expected I went for GNOME first.

So, GNOME has iBus included since version 3.6, in all rights it *Should* work out of the box, alas it didn't, I was meaning to ask about this but I won't since I switched to KDE 4 due to GNOME being too unstable.


So, now I am running KDE, At first iBus didn't start with the system (even after following the instructions in https://wiki.archlinux.org/index.php/IBus ), so I started it manually, it kind of worked and I could see the pretty icon (which defaulted to the input method I selected as default), alas it didn't work in any software I had, so I opened up a terminal and was about to type "ibus-setup" and what do I get? Japanese input! Alas it only works in qt applications and the hotkey for enabling and disabling it doesn't work.


Which to sum it up:
iBus does *not* toggle when ctrl-space is pressed, the expected behavior is that it toggles on and off
it does *not* work in GTK applications, the expected behavior is that it should


EDIT: It should be worth noting that I did fix the autostart issue

Last edited by CubeGod (2013-07-09 01:23:20)

Offline

#2 2013-07-13 06:28:53

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

Shameless bump?
I really do need to get this running and I am at loss, I just can't figure out why it won't work. (Oh, I got iBus running on anything from debian to gentoo to LFS but can't get it running in arch, I must assume that arch either has some special way to do it or that the package is broken)

Offline

#3 2013-07-17 08:12:50

Goresome
Member
From: Russia
Registered: 2011-12-06
Posts: 67

Re: A multitude of iBus issues

Did you add required variables to ~/.xprofile (as suggested in the wiki)? When I used iBus in KDE I had the same issue as you but proper .xprofile solved that.
I am now using fcitx and I have to follow the same procedure.

Offline

#4 2013-07-17 22:16:11

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

Yes, I did.
I have tried everything mentioned in the wiki
including ibus-daemon -drx, also tried a bunch of advise obtained from the helpful internet such as ibus-daemon -xim

I can get it to start automatically but I cannot get it to function properly.

When it autostarts it breaks my space key (need to press super-space to use it, which in the terminal adds an s and then a space character (works in other software) and it refuses to listen to any key-combination, I tried damn near every possible combination (meta-i, anyone?) and it randomly starts with my primary input method selected (and the times it doesn't it is sitting there)

The only way to restore proper keyboard functionality is to kill it.

I have tried in GNOME and KDE and finally switched to Xfce (my favorite) due to not getting along with KDE (um.. I never liked KDE), still doesn't work though

Offline

#5 2013-07-18 05:17:29

Goresome
Member
From: Russia
Registered: 2011-12-06
Posts: 67

Re: A multitude of iBus issues

So I decided to give it a try. I uninstalled fcitx and installed:

local/ibus 1.5.2-2
local/ibus-kkc 1.5.16-1
local/ibus-qt 1.3.2-1

Next I put exports in .xprofile. Now if I do ibus-setup it will start daemon and everything will work fine (Qt, GTK2, GTK3). Here comes the trouble: if I start it with .xprofile (I start X via KDM) then GTK2 apps will not be able to use it, and the .bashrc way will start daemon only when I open konsole. Instead I simply created ~/.config/autostart/ibus-daemon.desktop with

[Desktop Entry]
Name=IBus
Exec=ibus-daemon --xim -dr
Terminal=false
Type=Application
Categories=
GenericName=

and now I'm able to use it in every app.
Maybe you might want to browse some dev forums, as I remember what written in a wiki to work for a while and when it broke I switched to fcitx.

Offline

#6 2013-07-19 23:03:02

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

I'll try that, I hope it works ^^;

Offline

#7 2013-07-19 23:05:36

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

Interestingly enough there was one already

[Desktop Entry]
Comment[en_US]=ibus
Comment=ibus
Exec=ibus-daemon --xim
GenericName[en_US]=ibus
GenericName=ibus
Icon=system-run
MimeType=
Name[en_US]=ibus
Name=ibus
Path=
StartupNotify=true
Terminal=false
TerminalOptions=
Type=Application

changing startup options and removing the startup options from .xprofile

It should be worth noting that starting it through .bashrc should work as I log in through command line

Offline

#8 2013-07-21 18:31:54

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

Okay, I tried that extensively and it still does not work at all.
It still ignores any and all input and what I get is still roman letters (it doesn't respond to the ctrl-space key combination either)

What I recall from when I used debian was that I had to use im-switch with these flags

im-switch -s ibus

, I can't recall why I had to but it wouldn't work without it.

Another thing I noticed is that in GNOME and Xfce the right click menu has the entry "input methods" in my previous experience it was System (simple) before im-switch and System (ibus), now it is showing System (simple)

I can technically work around ibus not working by switching to X Input Method, but it is tedious to switch that way when I want to type something in Japanese as ibus still ignores my key combination when I am in that input method (I tried every single input method in the list, X and system are the only two of use to me)

therefore I'll attempt the im-switch method by downloading and installing https://aur.archlinux.org/packages/im-switch/

Offline

#9 2013-07-21 19:09:16

Goresome
Member
From: Russia
Registered: 2011-12-06
Posts: 67

Re: A multitude of iBus issues

How do you start your X? Me thinks you start it up in some unusual way that requires some specific setup: check this (dbus) thread and post output if it will not help (we still haven't seen any logs).
Also what happens with other input methods (fcitx for example)?

EDIT: Please try starting X via DM (KDM, GDM, LightDM) to see what will happen (I'm pretty sure it will work fine).

Last edited by Goresome (2013-07-21 20:04:55)

Offline

#10 2013-07-21 19:53:29

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

Well, I start x using startx,
Oh and I am running xorg 1.12 (it shouldn't matter, anyway I ran 1.14 before but downgraded as to use the propriety radeon legacy driver)

ibus-daemon -v

(ibus-ui-gtk3:2510): IBUS-WARNING **: ibus_bus_call_sync: org.freedesktop.IBus.GetGlobalEngine: GDBus.Error:org.freedesktop.DBus.Error.Failed: No global engine.

Nothing strange there.
Seems the im-switch method didn't work, though I got a few options left to test as I only tested two of the possible combinations of flags so far

And no, I haven't tried any other input methods (I would quite prefer to get ibus working)

Last edited by CubeGod (2013-07-21 19:54:19)

Offline

#11 2013-11-09 01:27:59

kumarasinghe
Member
From: Colombo, Sri Lanka.
Registered: 2013-11-08
Posts: 2

Re: A multitude of iBus issues

I'm experiencing the same problem!
Super Key + Space doesn't change the input method!
I think this problem only appears in the latest version of iBus (1.5) There have been a major change in the lastest iBus.
I posted another thread here before:
https://bbs.archlinux.org/viewtopic.php?id=172605
IS THIS A BUG??

Last edited by kumarasinghe (2013-11-09 01:33:06)


◄███▓▒░░ ARCH LINUX™░░▒▓███►

Offline

#12 2013-11-09 03:35:52

CubeGod
Member
Registered: 2013-07-09
Posts: 110

Re: A multitude of iBus issues

please create a new topic instead of playing necromancer (or to put it simply: don't post in topics that are clearly old)
Oh and don't hijack other people's threads, it is rude. If you have a similar problem then create your own thread (if the solutions in the thread don't work) and link to the thread of interest in your thread to prove that you performed at least some research

Offline

Board footer

Powered by FluxBB