You are not logged in.

#1 2013-07-10 14:39:08

abarahc
Member
Registered: 2010-04-30
Posts: 127

[SOLVED] dwm pertag patch no working properly

Hello everybody! I recently had to redo my system.

Before this change I was using the DWM 6.0 with patches NMaster and pertag.

link to the source code used - https://github.com/abara/config/tree/master/dwm-pertag

But now, after having reinstalled the base system, I realized that the same code that I used before is no longer behaving as it should.

He is working as if there is no patch applied in dwm.c

I wonder what would be the possible reasons.

P.S. will not use sprinkles fork

Last edited by abarahc (2013-07-11 23:14:07)


user@localhost $ grep -rnw "." -e "hacking"

Offline

#2 2013-07-10 15:09:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] dwm pertag patch no working properly

Have you tried the pertag patch from suckless? http://dwm.suckless.org/patches/pertag

BTW, why do you need '--asroot'? https://github.com/abara/config/blob/ma … install.sh

Offline

#3 2013-07-10 17:26:48

ANOKNUSA
Member
Registered: 2010-10-22
Posts: 2,141

Re: [SOLVED] dwm pertag patch no working properly

Try karol's suggestion, and apply the pertag patch without applying NMaster; the NMaster patch is now part of the base code, so applying a patch for it is superfluous.

Offline

#4 2013-07-10 17:30:42

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] dwm pertag patch no working properly

ANOKNUSA wrote:

NMaster patch is now part of the base code, so applying a patch for it is superfluous.

Yeah, that's what I meant ;P http://dwm.suckless.org/patches/nmaster
I'm using dwm with pertag patch and things are working as expected.

Offline

#5 2013-07-11 15:44:31

abarahc
Member
Registered: 2010-04-30
Posts: 127

Re: [SOLVED] dwm pertag patch no working properly

Ok. I've tried a new build from ABS. Patch only the pertag from suckless and its still the same problem .-.


user@localhost $ grep -rnw "." -e "hacking"

Offline

#6 2013-07-11 15:47:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] dwm pertag patch no working properly

Please post your config.h somewhere so I can test it.

Offline

#7 2013-07-11 16:20:10

SolarBoyMatt
Member
From: Columbus, Ohio
Registered: 2012-01-07
Posts: 258
Website

Re: [SOLVED] dwm pertag patch no working properly

Are you sure the patch is applying properly? As in, after building, does your dwm.c reflect the changes? Can you show exactly how you're applying the patch?

Last edited by SolarBoyMatt (2013-07-11 16:20:46)

Offline

#8 2013-07-11 18:06:04

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,070
Website

Re: [SOLVED] dwm pertag patch no working properly

What problem? Your posts contain no errors, your config.h contains no pertag rules, nor the patch you are supposed to have applied.

Please read How To Ask Questions The Smart Way.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#9 2013-07-11 23:13:51

abarahc
Member
Registered: 2010-04-30
Posts: 127

Re: [SOLVED] dwm pertag patch no working properly

ok guys. here is the deal :

I just forget about the "-e" option on the makepkg command after editing/patching the dwm.c file hmm

u_u'

Thanks guys! o/


user@localhost $ grep -rnw "." -e "hacking"

Offline

Board footer

Powered by FluxBB