You are not logged in.

#1 2013-07-16 12:06:48

Registered: 2012-11-13
Posts: 70

netctl-auto fails every second boot

So, since about two oder three days ago, my netctl-auto fails every second boot and I can't even enable a profile manually.

I already found this thread:
But I checked and don't have any failed units and dhcpcd is not running.

I will do some further investigation and post it here. Any ideas for solutions are welcome



#2 2013-07-16 18:56:12

Registered: 2013-07-16
Posts: 1

Re: netctl-auto fails every second boot

I've been having the same problem as well, it boots up just fine then after a reboot netctl-auto fails which had been going on for me for the past 30 minutes without "fixing" itself.

After I added the line:


to my profile then rebooted, it worked. It could be a fluke "fix" but worth a try. I *think* the reason it worked is that the default timeout is 10 seconds which might not be enough to establish a connection for some routers/network cards.

EDIT: I did another boot to see if it was a fluke, and it was. I'm getting a little tired of netctl-auto... I'm going to just disable it and manually do a "netctl start <profile>" after I boot up.

Last edited by DukeH (2013-07-16 19:07:58)


Board footer

Powered by FluxBB