You are not logged in.

#1 2013-07-18 21:32:39

jnhieber
Member
Registered: 2011-02-01
Posts: 22

[SOLVED] X230t kernel panic on suspend

Hi,
since kernel 3.10 i get kernel panics when suspending my laptop to ram. This happens in about 8 oder 9 of 10 times.
Before 3.10 i got this only after about 2 or 3 weeks and after many suspends.

The panic is indicated by the fast blinking power/suspend led, screen is off.

I use linux-ck-ivybridge 3.10.1-2
Linux laptop 3.10.1-2-ck #1 SMP PREEMPT Sun Jul 14 07:32:37 EDT 2013 x86_64 GNU/Linux

HW:

- i5-3320M
- HD4000 GPU
- Samsung 830 SSD

I'm booting via UEFI stub, with this line i generate my bootentry:

echo "root=UUID=c8a1a4bf-20db-4659-9384-e8f5dc32ce93 raid=noautodetect  acpi_backlight=vendor rootfstype=ext4 elevator=noop add_efi_memmap quiet ro initrd=\\initramfs-arch.img" | iconv -f ascii -t ucs2 | efibootmgr -c -g -d /dev/sda -p 1 -L "Arch Linux (EFISTUB)" -l \\vmlinuz-arch.efi -@ -

modules loaded:

fuse snd_hda_codec_hdmi snd_hda_codec_realtek nls_cp437 vfat fat joydev iTCO_wdt iTCO_vendor_support arc4 wacom qmi_wwan qcserial cdc_wdm usb_wwan usbnet usbserial mii iwldvm intel_powerclamp coretemp kvm_intel mac80211 kvm crc32_pclmul crc32c_intel ghash_clmulni_intel aesni_intel psmouse aes_x86_64 iwlwifi lrw gf128mul glue_helper serio_raw ablk_helper cryptd i2c_i801 pcspkr cfg80211 thermal snd_hda_intel thinkpad_acpi wmi snd_hda_codec nvram rfkill battery ac snd_hwdep e1000e snd_pcm snd_page_alloc snd_timer mperf lpc_ich ptp snd mei_me pps_core evdev soundcore mei processor nfs lockd fscache sunrpc microcode efivars ext4 crc16 mbcache jbd2 usbhid hid sd_mod ahci libahci libata ehci_pci xhci_hcd sdhci_pci ehci_hcd sdhci scsi_mod mmc_core usbcore usb_common i915 video button i2c_algo_bit intel_agp intel_gtt drm_kms_helper drm i2c_core

i use KMS with i915 module in initrd

Now i have the problem, i don't know how to get information on this. in journalctl only show that the machine suspends and then the reboot line and a normal boot after kernel panic.

My system is up to date, no testing/experimental

Last edited by jnhieber (2013-07-20 09:41:28)

Offline

#2 2013-07-20 03:27:02

tekstryder
Member
Registered: 2013-02-14
Posts: 19

Re: [SOLVED] X230t kernel panic on suspend

Same suspend issue here. Started somewhere in the 3.9.x series. For me it affects only ck-kernels. Do you have this issue with the Arch kernel?

Previous thread:
https://bbs.archlinux.org/viewtopic.php?id=165922

Offline

#3 2013-07-20 09:40:24

jnhieber
Member
Registered: 2011-02-01
Posts: 22

Re: [SOLVED] X230t kernel panic on suspend

Thanks, I switched to stock kernel and the first suspends works.

I used -ck for a really long time and wouldn't believe that it is the problem.

So Thanks for the hint, I'll close this. If any problems still appear I will post in the kernel sections, that would be better.

Offline

Board footer

Powered by FluxBB