You are not logged in.

#1 2013-07-24 10:44:36

yugiohfan2011
Member
From: Waco, TX
Registered: 2010-12-18
Posts: 20
Website

startx: X server runs for split second, then dumps me back to shell

I'm trying to install an X server on a newly installed Arch Linux VirtualBox guest machine, but when I type "startx", the X server only runs for a split second, and then dumps me back to the shell. Here are my ~/.xinitrc and /var/log/Xorg.0.log files posted via wgetpaste. What could be wrong?

http://bpaste.net/show/116910 <-- ~/.xinitrc
http://bpaste.net/show/116915 <-- /var/log/Xorg.0.log

Brandon Taylor


Brandon Taylor

Offline

#2 2013-07-24 11:09:42

aeqwa
Member
From: Germany, Wuppertal
Registered: 2013-04-04
Posts: 6

Re: startx: X server runs for split second, then dumps me back to shell

I'm not sure but i dont see any desktop or window manager in your .xinitrc .
.xinitrc is used to execute a window manager or a desktop when the x server starts.
So you need to install a desktop or window manager that you like.

Desktops: https://wiki.archlinux.org/index.php/De … nvironment
Window managers: https://wiki.archlinux.org/index.php/Window_Manager
xinitrc: https://wiki.archlinux.org/index.php/Xinitrc


i3wm / urxvt / luakit

Offline

#3 2013-07-24 11:11:59

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,966
Website

Re: startx: X server runs for split second, then dumps me back to shell

As the output says, the session is terminating normally.

What is VBoxClient-all supposed to do?  (edit: I just installed it to try to find out, but it has no man page, nor does it respond to --help or -h).

EDIT: the virtualbox wiki page is quite clear that this command must be followed by a window manager, or DE in your xinitrc.  You need to tell X to do something, otherwise it will very happily do nothing as you have told it to.

Last edited by Trilby (2013-07-24 11:15:02)


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Offline

#4 2013-07-24 19:23:02

yugiohfan2011
Member
From: Waco, TX
Registered: 2010-12-18
Posts: 20
Website

Re: startx: X server runs for split second, then dumps me back to shell

Just like those Apple II and Commodore 64 machines of yesteryear, huh?

Okay, I believe I've got it down now.


Brandon Taylor

Offline

Board footer

Powered by FluxBB