You are not logged in.

#1 2013-07-26 10:43:17

dmaschine
Member
Registered: 2013-06-20
Posts: 24

optirun doesn't work after kernel & nvidia upgrade

Hey guys,

After the update of bbswitch and nvidia (and of course kernel version 3.10.3) optirun fails with the following output:

 optirun glxspheres
[ 3749.126555] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module "mouse" (module does not exist, 0)

[ 3749.126608] [ERROR]Aborting because fallback start is disabled.

Any thoughts on this ?

Last edited by dmaschine (2013-07-31 11:20:05)

Offline

#2 2013-07-26 10:58:25

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: optirun doesn't work after kernel & nvidia upgrade

I had this problem once, and installing xf86-input-mouse solved it.


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#3 2013-07-26 11:14:14

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

Now the error just changed to:

 optirun glxspheres
[  118.263312] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please

[  118.263355] [ERROR]Aborting because fallback start is disabled.

Seems to be a deeper problem of nvidia driver ?

Offline

#4 2013-07-26 11:20:59

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

Additionally pacman -Qs gives:

 
local/bumblebee 3.2.1-3
    NVIDIA Optimus support for Linux through VirtualGL
local/lib32-nvidia-utils 319.32-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 0.6-2
    Nvidia VDPAU library
local/nvidia 319.32-4
    NVIDIA drivers for linux
local/nvidia-utils 319.32-1
    NVIDIA drivers utilities

In the arch packages the nvidia package is flaged - Any problem with that ? I don't really know what this flagging wants to say^^

Offline

#5 2013-07-26 13:23:50

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: optirun doesn't work after kernel & nvidia upgrade

There was once a similar problem to yours. Check this : https://bbs.archlinux.org/viewtopic.php … 3#p1103913.
The flagging means someone flag this package as outdated. It could be related, but I don't think so.

Last edited by Cthulhu82 (2013-07-26 13:24:57)


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#6 2013-07-26 14:21:49

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

Hey,

Yeah, I just found that post, too. For me it solved the problem even if I had to downgrade a few packages but now optirun works again. For those who have similar problems:

I removed nvidia (sudo pacman -Rs nvidia) and nvidia-utils. After that i downgraded the kernel from 3.10.3 (because nvidia and the kernel had dependencies) to 3.9.9. I had this version in pacman's cache (var/cache/pacman/pkg/linux......) and used it to downgrade the kernel with # sudo pacman -U 'thatpkg'. After that I installed the older nvidia package and utils package the same way, reboot and now it works again. Generally I think this issue is related to the nvidia packages and their version numbers being different.

Have a nice day!

Offline

#7 2013-07-26 14:49:03

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: optirun doesn't work after kernel & nvidia upgrade

The strange thing is that everything is up to date in my system and optirun run perfectly…


« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#8 2013-07-26 20:09:29

barchiesi
Member
Registered: 2011-11-04
Posts: 15

Re: optirun doesn't work after kernel & nvidia upgrade

I'm having the same issues with a fully updated system.

dmaschine wrote:

Hey,

Yeah, I just found that post, too. For me it solved the problem even if I had to downgrade a few packages but now optirun works again. For those who have similar problems:

I removed nvidia (sudo pacman -Rs nvidia) and nvidia-utils. After that i downgraded the kernel from 3.10.3 (because nvidia and the kernel had dependencies) to 3.9.9. I had this version in pacman's cache (var/cache/pacman/pkg/linux......) and used it to downgrade the kernel with # sudo pacman -U 'thatpkg'. After that I installed the older nvidia package and utils package the same way, reboot and now it works again. Generally I think this issue is related to the nvidia packages and their version numbers being different.

Have a nice day!

Could you give me the nvidia and nvidia-utils versions you are using?

Offline

#9 2013-07-27 08:33:19

Cthulhu82
Member
From: Angers, France
Registered: 2013-04-01
Posts: 149

Re: optirun doesn't work after kernel & nvidia upgrade

Mine are :

bumblebee 3.2.1-3
lib32-nvidia-utils 319.32-1
libvdpau 0.6-2
nvidia 319.32-4
nvidia-utils 319.32-1

« En essayant continuellement, on finit par réussir.
Donc plus ça rate, plus ça a de chance de marcher. »
Devise Shadock

Offline

#10 2013-07-27 10:16:20

Kaelris
Member
Registered: 2013-07-27
Posts: 3

Re: optirun doesn't work after kernel & nvidia upgrade

Hi, I have a similar problem since upgrading yesterday:

optirun glxspheres
[  203.519966] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[  203.520007] [ERROR]Aborting because fallback start is disabled.

My GPU:

lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 650M] (rev ff)

My packages:

bumblebee 3.2.1-3
nvidia 319.32-4
bbswitch 0.7-6
linux 3.10.3-1

I can make it work again by downgrading to:

nvidia-319.32-2
bbswitch-0.7-4
linux-3.9.9-1

But I would still like to find a way to use up-to-date packages...

Offline

#11 2013-07-27 10:32:01

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: optirun doesn't work after kernel & nvidia upgrade

Guys, stop the downgrading bullshit. It isn't solving anyone's troubles. Be smart, be progressive, have a willingness to fix problems, this is Arch. So far, none of you have even provided the full Xorg.1.log or dmesg output. How am I even supposed to help you with your problems? Please only post logs of fully updated systems that you have rebooted once since upgrading nvidia or linux. Other logs will be misleading.

Offline

#12 2013-07-27 11:30:09

Malstrond
Member
From: Germany
Registered: 2009-06-03
Posts: 87

Re: optirun doesn't work after kernel & nvidia upgrade

Same problem struck me too after upgrading the following:

upgraded linux (3.9.9-1 -> 3.10.2-1)
upgraded bbswitch (0.7-4 -> 0.7-6)
upgraded git (1.8.3.3-1 -> 1.8.3.4-1)
upgraded harfbuzz (0.9.18-1 -> 0.9.19-1)
upgraded lirc-utils (1:0.9.0-49 -> 1:0.9.0-52)
upgraded nvidia (319.32-2 -> 319.32-4)

Reverting these changes also causes it to work again for me.

Xorg.8.log:

X.Org X Server 1.14.2
Release Date: 2013-06-25
[    59.598] X Protocol Version 11, Revision 0
[    59.598] Build Operating System: Linux 3.9.7-1-ARCH x86_64 
[    59.598] Current Operating System: Linux Tarsonis 3.10.2-1-ARCH #1 SMP PREEMPT Mon Jul 22 08:47:24 CEST 2013 x86_64
[    59.598] Kernel command line: cryptdevice=PARTUUID=d7981651-fb58-40c8-8037-9d9140f84ecb:root:allow-discards root=/dev/mapper/root efi_no_storage_paranoia add_efi_memmap initrd=\EFI\ArchLinux\initramfs-linux.img
[    59.598] Build Date: 01 July 2013  10:48:42AM
[    59.598]  
[    59.598] Current version of pixman: 0.30.0
[    59.598] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    59.598] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    59.598] (==) Log file: "/var/log/Xorg.8.log", Time: Fri Jul 26 19:23:18 2013
[    59.599] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[    59.599] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[    59.599] (==) ServerLayout "Layout0"
[    59.599] (==) No screen section available. Using defaults.
[    59.599] (**) |-->Screen "Default Screen Section" (0)
[    59.599] (**) |   |-->Monitor "<default monitor>"
[    59.599] (==) No device specified for screen "Default Screen Section".
	Using the first device section listed.
[    59.599] (**) |   |-->Device "DiscreteNvidia"
[    59.599] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    59.599] (**) Option "AutoAddDevices" "false"
[    59.599] (**) Option "AutoAddGPU" "false"
[    59.599] (**) Not automatically adding devices
[    59.599] (==) Automatically enabling devices
[    59.599] (**) Not automatically adding GPU devices
[    59.599] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    59.599] 	Entry deleted from font path.
[    59.599] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    59.599] 	Entry deleted from font path.
[    59.599] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    59.599] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    59.599] 	Entry deleted from font path.
[    59.599] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    59.599] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/Type1/
[    59.599] (++) ModulePath set to "/usr/lib/nvidia/xorg/,/usr/lib/xorg/modules"
[    59.599] (==) |-->Input Device "<default pointer>"
[    59.599] (==) |-->Input Device "<default keyboard>"
[    59.599] (==) The core pointer device wasn't specified explicitly in the layout.
	Using the default mouse configuration.
[    59.599] (==) The core keyboard device wasn't specified explicitly in the layout.
	Using the default keyboard configuration.
[    59.599] (II) Loader magic: 0x7fdc20
[    59.599] (II) Module ABI versions:
[    59.599] 	X.Org ANSI C Emulation: 0.4
[    59.599] 	X.Org Video Driver: 14.1
[    59.599] 	X.Org XInput driver : 19.1
[    59.599] 	X.Org Server Extension : 7.0
[    59.599] (II) xfree86: Adding drm device (/dev/dri/card1)
[    59.599] (II) xfree86: Adding drm device (/dev/dri/card0)
[    59.599] setversion 1.4 failed
[    59.600] (--) PCI:*(0:1:0:0) 10de:0fd1:1558:1150 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    59.600] Initializing built-in extension Generic Event Extension
[    59.600] Initializing built-in extension SHAPE
[    59.600] Initializing built-in extension MIT-SHM
[    59.600] Initializing built-in extension XInputExtension
[    59.600] Initializing built-in extension XTEST
[    59.600] Initializing built-in extension BIG-REQUESTS
[    59.601] Initializing built-in extension SYNC
[    59.601] Initializing built-in extension XKEYBOARD
[    59.601] Initializing built-in extension XC-MISC
[    59.601] Initializing built-in extension SECURITY
[    59.601] Initializing built-in extension XINERAMA
[    59.601] Initializing built-in extension XFIXES
[    59.601] Initializing built-in extension RENDER
[    59.601] Initializing built-in extension RANDR
[    59.601] Initializing built-in extension COMPOSITE
[    59.601] Initializing built-in extension DAMAGE
[    59.601] Initializing built-in extension MIT-SCREEN-SAVER
[    59.601] Initializing built-in extension DOUBLE-BUFFER
[    59.601] Initializing built-in extension RECORD
[    59.601] Initializing built-in extension DPMS
[    59.601] Initializing built-in extension X-Resource
[    59.601] Initializing built-in extension XVideo
[    59.601] Initializing built-in extension XVideo-MotionCompensation
[    59.601] Initializing built-in extension XFree86-VidModeExtension
[    59.601] Initializing built-in extension XFree86-DGA
[    59.601] Initializing built-in extension XFree86-DRI
[    59.601] Initializing built-in extension DRI2
[    59.601] (II) LoadModule: "glx"
[    59.601] (II) Loading /usr/lib/nvidia/xorg/modules/extensions/libglx.so
[    59.694] (II) Module glx: vendor="NVIDIA Corporation"
[    59.694] 	compiled for 4.0.2, module version = 1.0.0
[    59.694] 	Module class: X.Org Server Extension
[    59.694] (II) NVIDIA GLX Module  319.32  Wed Jun 19 14:55:38 PDT 2013
[    59.695] Loading extension GLX
[    59.695] (II) LoadModule: "nvidia"
[    59.695] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    59.703] (II) Module nvidia: vendor="NVIDIA Corporation"
[    59.703] 	compiled for 4.0.2, module version = 1.0.0
[    59.703] 	Module class: X.Org Video Driver
[    59.705] (II) LoadModule: "mouse"
[    59.706] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
[    59.706] (II) Module mouse: vendor="X.Org Foundation"
[    59.706] 	compiled for 1.14.0, module version = 1.9.0
[    59.706] 	Module class: X.Org XInput Driver
[    59.706] 	ABI class: X.Org XInput driver, version 19.1
[    59.706] (II) LoadModule: "kbd"
[    59.706] (WW) Warning, couldn't open module kbd
[    59.706] (II) UnloadModule: "kbd"
[    59.706] (II) Unloading kbd
[    59.706] (EE) Failed to load module "kbd" (module does not exist, 0)
[    59.706] (II) NVIDIA dlloader X Driver  319.32  Wed Jun 19 14:34:12 PDT 2013
[    59.706] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    59.707] (--) using VT number 2

[    59.708] (II) Loading sub module "fb"
[    59.708] (II) LoadModule: "fb"
[    59.708] (II) Loading /usr/lib/xorg/modules/libfb.so
[    59.709] (II) Module fb: vendor="X.Org Foundation"
[    59.709] 	compiled for 1.14.2, module version = 1.0.0
[    59.709] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    59.709] (WW) Unresolved symbol: fbGetGCPrivateKey
[    59.709] (II) Loading sub module "wfb"
[    59.709] (II) LoadModule: "wfb"
[    59.709] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    59.710] (II) Module wfb: vendor="X.Org Foundation"
[    59.710] 	compiled for 1.14.2, module version = 1.0.0
[    59.710] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    59.710] (II) Loading sub module "shadow"
[    59.710] (II) LoadModule: "shadow"
[    59.711] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    59.711] (II) Module shadow: vendor="X.Org Foundation"
[    59.711] 	compiled for 1.14.2, module version = 1.1.0
[    59.711] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    59.711] (II) Loading sub module "ramdac"
[    59.711] (II) LoadModule: "ramdac"
[    59.711] (II) Module "ramdac" already built-in
[    59.712] (II) NVIDIA(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    59.712] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    59.712] (==) NVIDIA(0): RGB weight 888
[    59.712] (==) NVIDIA(0): Default visual is TrueColor
[    59.712] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    59.712] (**) NVIDIA(0): Option "NoLogo" "true"
[    59.712] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[    59.712] (**) NVIDIA(0): Option "UseEDID" "false"
[    59.712] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[    59.712] (**) NVIDIA(0): Enabling 2D acceleration
[    59.712] (**) NVIDIA(0): Ignoring EDIDs
[    59.712] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[    59.712] (**) NVIDIA(0):     mode
[    64.823] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[    64.823] (EE) NVIDIA(0):     check your system's kernel log for additional error
[    64.823] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
[    64.823] (EE) NVIDIA(0):     README for additional information.
[    64.823] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[    64.823] (EE) NVIDIA(0): Failing initialization of X screen 0
[    64.823] (II) UnloadModule: "nvidia"
[    64.823] (II) UnloadSubModule: "shadow"
[    64.823] (II) UnloadSubModule: "wfb"
[    64.823] (II) UnloadSubModule: "fb"
[    64.823] (EE) Screen(s) found, but none have a usable configuration.
[    64.823] (EE) 
Fatal server error:
[    64.823] (EE) no screens found(EE) 
[    64.823] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    64.823] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[    64.823] (EE) 
[    64.823] (EE) Server terminated with error (1). Closing log file.

dmesg:

[   58.777787] bbswitch: enabling discrete graphics
[   59.599124] pci 0000:01:00.0: power state changed by ACPI to D0
[   59.662448] nvidia: module license 'NVIDIA' taints kernel.
[   59.662451] Disabling lock debugging due to kernel taint
[   59.667348] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[   59.667604] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[   59.667611] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  319.32  Wed Jun 19 15:51:20 PDT 2013
[   64.884125] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   64.884133] NVRM: os_pci_init_handle: invalid context!
[   64.884134] NVRM: os_pci_init_handle: invalid context!
[   64.884137] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   64.884140] NVRM: os_pci_init_handle: invalid context!
[   64.884141] NVRM: os_pci_init_handle: invalid context!
[   64.901417] NVRM: RmInitAdapter failed! (0x25:0x28:1148)
[   64.901424] NVRM: rm_init_adapter(0) failed

Exact same issue here. Maybe this thread on our forums is also related, and maybe this thread on the Nvidia forums.


Svenstaro wrote:

Guys, stop the downgrading bullshit.

If downgrading is "bullshit", then why does the Wiki suggest

Warning: This clears out the entire package cache. Doing this is considered a bad practice; it prevents the ability to downgrade something directly from the cache folder.

By your logic, it should advise users to always clear the pacman cache, because that would prevent bullshit from happening. You should edit it!

Last edited by Malstrond (2013-11-07 19:20:34)

Offline

#13 2013-07-27 11:38:40

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: optirun doesn't work after kernel & nvidia upgrade

It's bullshit because it doesn't solve the issues for anyone. It's a temporary hack at best. The wiki also says "Partial upgrades are unsupported" in a heading on that same page. Downgrading makes your system partially upgraded and it's unsupported. Let's waste less time arguing about best practices and focus on the problem at hand.

It would appear that bbswitch still works. What happens if you manually insert nvidia?

Offline

#14 2013-07-27 11:50:46

Malstrond
Member
From: Germany
Registered: 2009-06-03
Posts: 87

Re: optirun doesn't work after kernel & nvidia upgrade

Same problem manually inserting and without bbswitch:

# modprobe nvidia
[   51.595555] nvidia: module license 'NVIDIA' taints kernel.
[   51.595558] Disabling lock debugging due to kernel taint
[   51.600074] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[   51.600125] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[   51.600309] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[   51.600313] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  319.32  Wed Jun 19 15:51:20 PDT 2013
# optirun glxspheres
[   75.997952] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   75.997959] NVRM: os_pci_init_handle: invalid context!
[   75.997960] NVRM: os_pci_init_handle: invalid context!
[   75.997964] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   75.997967] NVRM: os_pci_init_handle: invalid context!
[   75.997968] NVRM: os_pci_init_handle: invalid context!
[   76.015309] NVRM: RmInitAdapter failed! (0x25:0x28:1148)
[   76.015316] NVRM: rm_init_adapter(0) failed

Last edited by Malstrond (2013-11-07 19:22:20)

Offline

#15 2013-07-27 16:47:18

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: optirun doesn't work after kernel & nvidia upgrade

Works for me.

Running primusrun glxspheres results in this:

OpenGL Renderer: GeForce GT 555M/PCIe/SSE2

[ 1387.759909] bbswitch: enabling discrete graphics
[ 1387.760251] acer_wmi: Unknown function number - 3 - 3
[ 1388.282537] pci 0000:01:00.0: power state changed by ACPI to D0
[ 1388.350821] nvidia: module license 'NVIDIA' taints kernel.
[ 1388.350825] Disabling lock debugging due to kernel taint
[ 1388.356281] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[ 1388.356466] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 1388.356471] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  319.32  Wed Jun 19 15:51:20 PDT 2013
[ 1408.675859] [drm] Module unloaded
[ 1408.677356] bbswitch: disabling discrete graphics
[ 1408.689662] pci 0000:01:00.0: Refused to change power state, currently in D0
[ 1408.690060] acer_wmi: Unknown function number - 3 - 2
[ 1408.693054] pci 0000:01:00.0: power state changed by ACPI to D3cold

[  1967.973]
X.Org X Server 1.14.2
Release Date: 2013-06-25
[  1967.973] X Protocol Version 11, Revision 0
[  1967.973] Build Operating System: Linux 3.9.7-1-ARCH x86_64
[  1967.973] Current Operating System: Linux cypher 3.10.3-1-ARCH #1 SMP PREEMPT Fri Jul 26 11:26:59 CEST 2013 x86_64
[  1967.973] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=0b298ce8-bd72-45d3-a655-08a43271085a ro acpi_backlight=vendor
[  1967.973] Build Date: 01 July 2013  10:48:42AM
[  1967.973] 
[  1967.973] Current version of pixman: 0.30.0
[  1967.973]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[  1967.973] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1967.974] (==) Log file: "/var/log/Xorg.8.log", Time: Sat Jul 27 18:42:25 2013
[  1967.974] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
[  1967.974] (++) Using config directory: "/etc/bumblebee/xorg.conf.d"
[  1967.974] (==) ServerLayout "Layout0"
[  1967.974] (==) No screen section available. Using defaults.
[  1967.974] (**) |-->Screen "Default Screen Section" (0)
[  1967.974] (**) |   |-->Monitor "<default monitor>"
[  1967.974] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
[  1967.974] (**) |   |-->Device "DiscreteNvidia"
[  1967.974] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
[  1967.974] (**) Option "AutoAddDevices" "false"
[  1967.974] (**) Option "AutoAddGPU" "false"
[  1967.974] (**) Not automatically adding devices
[  1967.974] (==) Automatically enabling devices
[  1967.974] (**) Not automatically adding GPU devices
[  1967.974] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  1967.974]    Entry deleted from font path.
[  1967.974] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[  1967.974]    Entry deleted from font path.
[  1967.974]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[  1967.974] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[  1967.974]    Entry deleted from font path.
[  1967.974]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[  1967.974] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/Type1/
[  1967.974] (++) ModulePath set to "/usr/lib/nvidia/xorg/,/usr/lib/xorg/modules"
[  1967.974] (==) |-->Input Device "<default pointer>"
[  1967.974] (==) |-->Input Device "<default keyboard>"
[  1967.974] (==) The core pointer device wasn't specified explicitly in the layout.
        Using the default mouse configuration.
[  1967.974] (==) The core keyboard device wasn't specified explicitly in the layout.
        Using the default keyboard configuration.
[  1967.974] (II) Loader magic: 0x7fdc20
[  1967.974] (II) Module ABI versions:
[  1967.974]    X.Org ANSI C Emulation: 0.4
[  1967.974]    X.Org Video Driver: 14.1
[  1967.974]    X.Org XInput driver : 19.1
[  1967.974]    X.Org Server Extension : 7.0
[  1967.974] (II) xfree86: Adding drm device (/dev/dri/card1)
[  1967.974] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1967.974] setversion 1.4 failed
[  1967.976] (--) PCI:*(0:1:0:0) 10de:0dce:1025:0564 rev 161, Mem @ 0xd0000000/33554432, 0xa0000000/268435456, 0xb0000000/67108864, I/O @ 0x00006000/128, BIOS @ 0x????????/524288
[  1967.976] Initializing built-in extension Generic Event Extension
[  1967.976] Initializing built-in extension SHAPE
[  1967.976] Initializing built-in extension MIT-SHM
[  1967.976] Initializing built-in extension XInputExtension
[  1967.976] Initializing built-in extension XTEST
[  1967.976] Initializing built-in extension BIG-REQUESTS
[  1967.976] Initializing built-in extension SYNC
[  1967.976] Initializing built-in extension XKEYBOARD
[  1967.976] Initializing built-in extension XC-MISC
[  1967.976] Initializing built-in extension SECURITY
[  1967.976] Initializing built-in extension XINERAMA
[  1967.976] Initializing built-in extension XFIXES
[  1967.976] Initializing built-in extension RENDER
[  1967.976] Initializing built-in extension RANDR
[  1967.976] Initializing built-in extension COMPOSITE
[  1967.976] Initializing built-in extension DAMAGE
[  1967.976] Initializing built-in extension MIT-SCREEN-SAVER
[  1967.976] Initializing built-in extension DOUBLE-BUFFER
[  1967.976] Initializing built-in extension RECORD
[  1967.976] Initializing built-in extension DPMS
[  1967.976] Initializing built-in extension X-Resource
[  1967.976] Initializing built-in extension XVideo
[  1967.976] Initializing built-in extension XVideo-MotionCompensation
[  1967.976] Initializing built-in extension XFree86-VidModeExtension
[  1967.976] Initializing built-in extension XFree86-DGA
[  1967.976] Initializing built-in extension XFree86-DRI
[  1967.976] Initializing built-in extension DRI2
[  1967.976] (II) LoadModule: "glx"
[  1967.976] (II) Loading /usr/lib/nvidia/xorg/modules/extensions/libglx.so
[  1967.984] (II) Module glx: vendor="NVIDIA Corporation"
[  1967.984]    compiled for 4.0.2, module version = 1.0.0
[  1967.984]    Module class: X.Org Server Extension
[  1967.984] (II) NVIDIA GLX Module  319.32  Wed Jun 19 14:55:38 PDT 2013
[  1967.984] Loading extension GLX
[  1967.984] (II) LoadModule: "nvidia"
[  1967.984] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[  1967.984] (II) Module nvidia: vendor="NVIDIA Corporation"
[  1967.984]    compiled for 4.0.2, module version = 1.0.0
[  1967.984]    Module class: X.Org Video Driver
[  1967.984] (II) LoadModule: "mouse"
[  1967.985] (WW) Warning, couldn't open module mouse
[  1967.985] (II) UnloadModule: "mouse"
[  1967.985] (II) Unloading mouse
[  1967.985] (EE) Failed to load module "mouse" (module does not exist, 0)
[  1967.985] (II) LoadModule: "kbd"
[  1967.985] (WW) Warning, couldn't open module kbd
[  1967.985] (II) UnloadModule: "kbd"
[  1967.985] (II) Unloading kbd
[  1967.985] (EE) Failed to load module "kbd" (module does not exist, 0)
[  1967.985] (II) NVIDIA dlloader X Driver  319.32  Wed Jun 19 14:34:12 PDT 2013
[  1967.985] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[  1967.985] (--) using VT number 7

[  1967.985] (II) Loading sub module "fb"
[  1967.985] (II) LoadModule: "fb"
[  1967.985] (II) Loading /usr/lib/xorg/modules/libfb.so
[  1967.985] (II) Module fb: vendor="X.Org Foundation"
[  1967.985]    compiled for 1.14.2, module version = 1.0.0
[  1967.985]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1967.985] (WW) Unresolved symbol: fbGetGCPrivateKey
[  1967.985] (II) Loading sub module "wfb"
[  1967.985] (II) LoadModule: "wfb"
[  1967.985] (II) Loading /usr/lib/xorg/modules/libwfb.so
[  1967.985] (II) Module wfb: vendor="X.Org Foundation"
[  1967.985]    compiled for 1.14.2, module version = 1.0.0
[  1967.985]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1967.985] (II) Loading sub module "shadow"
[  1967.985] (II) LoadModule: "shadow"
[  1967.985] (II) Loading /usr/lib/xorg/modules/libshadow.so
[  1967.986] (II) Module shadow: vendor="X.Org Foundation"
[  1967.986]    compiled for 1.14.2, module version = 1.1.0
[  1967.986]    ABI class: X.Org ANSI C Emulation, version 0.4
[  1967.986] (II) Loading sub module "ramdac"
[  1967.986] (II) LoadModule: "ramdac"
[  1967.986] (II) Module "ramdac" already built-in
[  1967.986] (II) NVIDIA(0): Creating default Display subsection in Screen section
        "Default Screen Section" for depth/fbbpp 24/32
[  1967.986] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[  1967.986] (==) NVIDIA(0): RGB weight 888
[  1967.986] (==) NVIDIA(0): Default visual is TrueColor
[  1967.986] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[  1967.986] (**) NVIDIA(0): Option "NoLogo" "true"
[  1967.986] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[  1967.986] (**) NVIDIA(0): Option "UseEDID" "false"
[  1967.986] (**) NVIDIA(0): Option "UseDisplayDevice" "none"
[  1967.986] (**) NVIDIA(0): Enabling 2D acceleration
[  1967.986] (**) NVIDIA(0): Ignoring EDIDs
[  1967.986] (**) NVIDIA(0): Option "UseDisplayDevice" set to "none"; enabling NoScanout
[  1967.986] (**) NVIDIA(0):     mode
[  1972.288] (II) NVIDIA(GPU-0): Not probing EDID on CRT-0.
[  1972.290] (II) NVIDIA(0): NVIDIA GPU GeForce GT 555M (GF106) at PCI:1:0:0 (GPU-0)
[  1972.290] (--) NVIDIA(0): Memory: 2097152 kBytes
[  1972.290] (--) NVIDIA(0): VideoBIOS: 70.06.2b.00.06
[  1972.290] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[  1972.290] (--) NVIDIA(0): Valid display device(s) on GeForce GT 555M at PCI:1:0:0
[  1972.290] (--) NVIDIA(0):     CRT-0 (boot, connected)
[  1972.290] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[  1972.290] (II) NVIDIA(0): Validated MetaModes:
[  1972.290] (II) NVIDIA(0):     "nvidia-auto-select"
[  1972.290] (II) NVIDIA(0): Virtual screen size determined to be 640 x 480
[  1972.290] (WW) NVIDIA(0): Unable to get display device for DPI computation.
[  1972.290] (==) NVIDIA(0): DPI set to (75, 75); computed from built-in default
[  1972.290] (--) Depth 24 pixmap format is 32 bpp
[  1972.290] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[  1972.290] (II) NVIDIA:     access.
[  1972.293] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[  1972.293] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[  1972.293] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[  1972.293] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[  1972.293] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[  1972.293] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[  1972.293] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[  1972.293] (II) NVIDIA(0):     Config Options in the README.
[  1972.293] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[  1972.297] Loading extension NV-GLX
[  1972.302] (==) NVIDIA(0): Disabling shared memory pixmaps
[  1972.302] (==) NVIDIA(0): Backing store disabled
[  1972.302] (==) NVIDIA(0): Silken mouse enabled
[  1972.302] (==) NVIDIA(0): DPMS enabled
[  1972.302] Loading extension NV-CONTROL
[  1972.303] (II) Loading sub module "dri2"
[  1972.303] (II) LoadModule: "dri2"
[  1972.303] (II) Module "dri2" already built-in
[  1972.303] (II) NVIDIA(0): [DRI2] Setup complete
[  1972.303] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[  1972.303] (--) RandR disabled
[  1972.306] (II) Initializing extension GLX
[  1972.335] (II) LoadModule: "mouse"
[  1972.335] (WW) Warning, couldn't open module mouse
[  1972.335] (II) UnloadModule: "mouse"
[  1972.335] (II) Unloading mouse
[  1972.335] (EE) Failed to load module "mouse" (module does not exist, 0)
[  1972.335] (EE) No input driver matching `mouse'
[  1972.335] (II) LoadModule: "kbd"
[  1972.335] (WW) Warning, couldn't open module kbd
[  1972.335] (II) UnloadModule: "kbd"
[  1972.335] (II) Unloading kbd
[  1972.335] (EE) Failed to load module "kbd" (module does not exist, 0)
[  1972.335] (EE) No input driver matching `kbd'
[  1972.336] (II) config/udev: Adding input device Power Button (/dev/input/event4)
[  1972.336] (II) AutoAddDevices is off - not adding device.
[  1972.336] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[  1972.336] (II) AutoAddDevices is off - not adding device.
[  1972.336] (II) config/udev: Adding input device Lid Switch (/dev/input/event3)
[  1972.336] (II) AutoAddDevices is off - not adding device.
[  1972.336] (II) config/udev: Adding input device Sleep Button (/dev/input/event2)
[  1972.336] (II) AutoAddDevices is off - not adding device.
[  1972.336] (II) config/udev: Adding drm device (/dev/dri/card1)
[  1972.336] (II) config/udev: Adding drm device (/dev/dri/card0)
[  1972.336] (II) xfree86: Adding drm device (/dev/dri/card0)
[  1972.336] setversion 1.4 failed
[  1972.337] (II) config/udev: Adding input device 1.3M HD 264 WebCam (/dev/input/event14)
[  1972.337] (II) AutoAddDevices is off - not adding device.
[  1972.337] (II) config/udev: Adding input device HDA Digital PCBeep (/dev/input/event9)
[  1972.337] (II) AutoAddDevices is off - not adding device.
[  1972.337] (II) config/udev: Adding input device HDA Intel PCH HDMI/DP,pcm=3 (/dev/input/event10)
[  1972.337] (II) AutoAddDevices is off - not adding device.
[  1972.337] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event11)
[  1972.337] (II) AutoAddDevices is off - not adding device.
[  1972.337] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event12)
[  1972.337] (II) AutoAddDevices is off - not adding device.
[  1972.337] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event13)
[  1972.337] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device SUYIN USB Device (/dev/input/event7)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device SUYIN USB Device (/dev/input/event8)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device SUYIN USB Device (/dev/input/mouse0)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device Acer WMI hotkeys (/dev/input/event5)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device Acer BMA150 accelerometer (/dev/input/event6)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1972.338] (II) config/udev: Adding input device Acer BMA150 accelerometer (/dev/input/js0)
[  1972.338] (II) AutoAddDevices is off - not adding device.
[  1974.986] (EE) Server terminated successfully (0). Closing log file.

bbswitch 0.7-6
nvidia 319.32-4
linux 3.10.3-1

You guys need to show me a clear way to reproduce this. Mindlessly downgrading packages is not the way but if you can show me which package broke it for you, I can try to fix it. However, on my sane and up-to-date system running the newest available kernel, it apparently works for me and so it should work for you.

Last edited by Svenstaro (2013-07-27 16:50:15)

Offline

#16 2013-07-27 17:26:44

Kaelris
Member
Registered: 2013-07-27
Posts: 3

Re: optirun doesn't work after kernel & nvidia upgrade

Well as I said earlier:

nvidia-319.32-2
bbswitch-0.7-4
linux-3.9.9-1

Those packages work fine for me. However if I upgrade to:

nvidia 319.32-4
bbswitch 0.7-6
linux 3.10.3-1

Then it doesn't work and I get the same logs as Malstrond. I can't tell which one of these 3 packages causes the problem because dependencies. Bbswitch probably works since the same problem happens while manually inserting nvidia, so I guess the nvidia package is the problem? Maybe that is why it was flagged as outdated?

Offline

#17 2013-07-27 18:51:47

Malstrond
Member
From: Germany
Registered: 2009-06-03
Posts: 87

Re: optirun doesn't work after kernel & nvidia upgrade

These are the same version changes which make or break it for me too.

bbswitch has ben ruled out already and it and nvidia only had a pkgrel change because they were rebuilt for the new kernel version anyway.

Offline

#18 2013-07-27 20:59:21

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: optirun doesn't work after kernel & nvidia upgrade

The nvidia module actually oops sometimes in my kernel. Did any of you notice that? It might be the root cause.

Offline

#19 2013-07-29 12:16:53

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

Same here.
The nvidia - driver package seems to be the main problem - It's maybe related to the fact, nvidia packages need to be the same version?

Offline

#20 2013-07-29 14:50:15

Azrael85
Member
Registered: 2012-05-30
Posts: 23

Re: optirun doesn't work after kernel & nvidia upgrade

I'm with that problem too. What exactly do you need to try to find where is the problem?? full Xorg.1.log after reboot like you said a couple days ago??

Offline

#21 2013-07-31 11:23:04

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

dmesg after update:

[ 262.928916] nvidia: module license 'NVIDIA' taints kernel.
[ 262.928920] Disabling lock debugging due to kernel taint
[ 262.933516] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[ 262.933561] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[ 262.933749] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 262.933755] NVRM: loading NVIDIA UNIX x86_64 Kernel Module 319.32 Wed Jun 19 15:51:20 PDT 2013
[ 269.558327] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[ 269.558337] NVRM: os_pci_init_handle: invalid context!
[ 269.558339] NVRM: os_pci_init_handle: invalid context!
[ 269.558343] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[ 269.558348] NVRM: os_pci_init_handle: invalid context!
[ 269.558349] NVRM: os_pci_init_handle: invalid context!
[ 269.575214] NVRM: RmInitAdapter failed! (0x25:0x28:1148)
[ 269.575221] NVRM: rm_init_adapter(0) failed

And Xorg.8.log gives:

269.392] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0. Please
[ 269.392] (EE) NVIDIA(0): check your system's kernel log for additional error
[ 269.392] (EE) NVIDIA(0): messages and refer to Chapter 8: Common Problems in the
[ 269.392] (EE) NVIDIA(0): README for additional information.
[ 269.392] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[ 269.392] (EE) NVIDIA(0): Failing initialization of X screen 0
[ 269.392] (II) UnloadModule: "nvidia"
[ 269.392] (II) UnloadSubModule: "shadow"
[ 269.392] (II) UnloadSubModule: "wfb"
[ 269.392] (II) UnloadSubModule: "fb"
[ 269.392] (EE) Screen(s) found, but none have a usable configuration.
[ 269.392] (EE)
Fatal server error:
[ 269.392] (EE) no screens found(EE)
[ 269.392] (EE)

Offline

#22 2013-07-31 11:26:09

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: optirun doesn't work after kernel & nvidia upgrade

Do you get the same problem if you manually update the nvidia package to the newest available upstream version? As in, if you use nvidia-beta.

Offline

#23 2013-08-01 10:09:37

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

I think you mean the .run package from nvidia ?

Offline

#24 2013-08-01 13:29:58

Svenstaro
Developer
From: Germany
Registered: 2008-11-19
Posts: 366

Re: optirun doesn't work after kernel & nvidia upgrade

No, I mean the AUR package nvidia-beta. Please test that an report results.

Offline

#25 2013-08-01 14:54:39

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: optirun doesn't work after kernel & nvidia upgrade

Ok, I'll try it

Offline

Board footer

Powered by FluxBB