You are not logged in.

#1 2013-07-27 10:42:02

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 297

systemd-udevd Error

Since the latest systemd updates I am getting this error from initram:
systemd-udevd[247]: Error calling EVIOCSKEYCODE: invalid argument

It does not get logged in journalctl, so I typed it off from the screen...

Not quite sure what this means? My system seems to be working o.k. but this is a little bit embarrassing...

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#2 2013-08-12 09:53:54

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 297

Re: systemd-udevd Error

Still valid in kernel 3.10.6 with systemd 206-1, journalctl shows 13 red entries:

systemd-udevd[249]: Error calling EVIOCSKEYCODE: Invalid argument

Must have overseen this by the time of the first posting.

No ideas?


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#3 2013-08-14 13:54:09

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

Re: systemd-udevd Error

It seems to be in the source file udev-builtin-keyboard.c when it maps the scancode to keycode (EVIOCSKEYCODE is the setkeycode ioctl).
It is probably linked to the fact that systemd now uses a hardware database to do the mapping i.e. the hwdb contains an incorrect data file.

What's your machine vendor, model, ... ?

Can you also try booting with these parameters in your kernel commandline to identify which scancode/keycode are problematic ones ?

systemd.log_level=debug systemd.log_target=kmsg log_buf_len=1M

You should see something like this in the log:

keyboard: mapping scan code ... (...) to key code ... (...)

Offline

#4 2013-08-14 14:57:18

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 297

Re: systemd-udevd Error

valr,

first of all: thank you for your interest.

The machine is custom built by myself. The mainboard is a GIGABYTE GA-P55-USB3 rev. 2.0

I booted with the suggested kernel commandline args but there are no entries from the keyboard like you thought. I have pasted a complete output of journalctl here.

As I stated before: this didn't happen before kernel 3.10.x

Harvey


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

#5 2013-08-14 15:40:41

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: systemd-udevd Error

valr wrote:

It is probably linked to the fact that systemd now uses a hardware database to do the mapping i.e. the hwdb contains an incorrect data file.

This is only true of systemd in [testing]. OP Never stated what version of systemd they were using.

Offline

#6 2013-08-14 15:59:40

splashy
Member
Registered: 2010-08-21
Posts: 128

Re: systemd-udevd Error

Can we have a look on your /etc/fstab file?

Offline

#7 2013-08-14 16:57:24

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: systemd-udevd Error

splashy wrote:

Can we have a look on your /etc/fstab file?

This can't possibly be relevant given that it happens in the initramfs....

Offline

#8 2013-08-14 17:54:41

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

Re: systemd-udevd Error

falconindy wrote:
valr wrote:

It is probably linked to the fact that systemd now uses a hardware database to do the mapping i.e. the hwdb contains an incorrect data file.

This is only true of systemd in [testing]. OP Never stated what version of systemd they were using.

Assumption taken because post is in testing forum.
Version 206 confirmed by the complete output that Harey has posted:

Aug 14 16:39:11 obelix systemd-udevd[57]: starting version 206

Harey,
Possibly the logging is not to be enabled on kernel command line but via /etc/udev/udev.conf i.e. set udev_log="debug" in that file.
Can you try with that (not sure it will work with initramfs, it's something I don't really understand) ?

Cheers

Offline

#9 2013-08-14 19:53:51

falconindy
Developer
From: New York, USA
Registered: 2009-10-22
Posts: 4,097
Website

Re: systemd-udevd Error

This won't work because of a bug in udev. /etc/udev/udev.conf is currently useless. Just set systemd.log_level.

edit: ref: http://cgit.freedesktop.org/systemd/sys … 52383110bf

Last edited by falconindy (2013-08-14 20:06:19)

Offline

#10 2013-08-14 20:50:55

valr
Member
From: Belgium
Registered: 2012-01-08
Posts: 62

Re: systemd-udevd Error

falconindy wrote:

This won't work because of a bug in udev. /etc/udev/udev.conf is currently useless. Just set systemd.log_level.

Yep, true. Thanks falconindy.

But setting systemd.log_level was what I first proposed and doesn't seem to work.
Without debug, it's difficult to know what are the keys that generate the error. Any idea?

Offline

#11 2013-08-15 15:46:43

Harey
Member
From: Bavaria, Germany
Registered: 2007-03-24
Posts: 297

Re: systemd-udevd Error

I did a test today with another keyboard/mouse and the errors are gone from journalctl. So my Logitech Cordless Dektop Comfort Laser is causing this issue.

Harvey

Last edited by Harey (2013-08-15 15:47:05)


Linux is like a wigwam: No Gates, no Windows and an Apache inside

Offline

Board footer

Powered by FluxBB