You are not logged in.

#1 2013-07-29 19:26:11

Registered: 2013-07-29
Posts: 6

Sound not Working on Samsung Q1

Simply put the sound on my computer is not working.  I will add however that the beep you get in the terminal when you press backspace too many times is still functional.  Also I do not have alsaconf; I understand that it was deprecated a year or so ago.
Please let me know what other information to give.


#2 2013-07-29 21:53:28

Registered: 2013-03-10
Posts: 39

Re: Sound not Working on Samsung Q1

Is the sound unmuted in alsamixer?


#3 2013-07-30 05:02:50

Registered: 2013-07-29
Posts: 6

Re: Sound not Working on Samsung Q1

Yes; I have tried that several times and it is unmuted.

Last edited by annyms (2013-07-30 05:32:30)


#4 2013-07-30 11:52:32

Registered: 2009-11-24
Posts: 155

Re: Sound not Working on Samsung Q1

1) Is it broken just for normal user accounts, or also for root? Try running a sound-producing program as root, e.g.:

sudo speaker-test -c 2

systemd-logind should dynamically update ACL permissions on the files in /dev/snd/ whenever a user logs into their account - maybe this mechanism is not triggered on your system for some reason?
You should see '+' signs indicating ACL permissions at the end of the first column in the output of ls -l /dev/snd. To list the ACL permissions of an individual file in detail, do:

getfacl /dev/snd/pcmC0D0c

You can bypass the ACL permissions altogether, by adding your user to the audio group - however there can be side-effects.

2) If sound doesn't work for root either, have you made sure the correct sound driver modules are loaded?
You can find out which ones are loaded using:

lsmod | grep '^snd'

3) If the correct drivers are loaded, have you made sure the correct sound output device is selected?

The following command should list your available sound devices:

aplay --list-devices

Each list entry is of the form "card 0: ... , device 4: ..."

Test each of the listed card,device number combinations using the following command (with the respective numbers substituted), to see if any of them produces sound:

speaker-test -D plughw:0,4

If you find one that works, make the choice permanent by creating the file ~/.asoundrc with the following content (with the correct numbers substituted of course):

defaults.pcm.!card 0
defaults.pcm.!device 4

Last edited by sas (2013-07-30 11:58:38)


#5 2013-07-30 21:10:04

Registered: 2013-07-29
Posts: 6

Re: Sound not Working on Samsung Q1

It is beyond the scope of this topic but I am running nothing but root right now (hope to fix it soon since I understand it is a bad idea).  So that is not the problem (and I did run "speaker-test -c 2") anyhow with no favorable results.
The output of "lsmod | grep '^snd'" is:

[root@FORTITUDE /]# lsmod | grep '^snd'
snd_hda_codec_analog    62514  1 
snd_hda_intel          23352  2 
snd_hda_codec          86035  2 snd_hda_intel,snd_hda_codec_analog
snd_hwdep               4843  1 snd_hda_codec
snd_pcm                63698  2 snd_hda_codec,snd_hda_intel
snd_page_alloc          6071  2 snd_pcm,snd_hda_intel
snd_timer              14903  1 snd_pcm
snd                    45066  10 snd_hwdep,snd_timer,snd_pcm,snd_hda_codec,snd_hda_intel,snd_hda_codec_analog

I do not know how to evaluate whether or not these are the correct sound driver modules.
The output of "aplay --list-devices" is:

[root@FORTITUDE /]# aplay --list-devices
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: AD198x Analog [AD198x Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

I tried to run "speaker-test -D plughw:0,0"; again, no sound.
Thank you for your help!

Last edited by annyms (2013-07-30 21:15:55)


Board footer

Powered by FluxBB