You are not logged in.

#1 2013-08-04 14:21:42

shimi
Member
Registered: 2013-08-04
Posts: 1

[Solved]Ctrl+V not working in libreoffice on gnome(non-latin layout)

When using gnome-shell&libreoffice or calligra, universal keyboard shortcuts such as ctrl+v or ctrl+z don't do anything while on a non-latin layout(hebrew in my case).
If I want to paste something with ctrl+v I have to change layout to English and only then will it work.

Under MATE the shortcuts work fine regardless of the layout in both applications(and all others i have tried).

Under GNOME Shell all other applications I tried accept the shortcuts regardless of the layout(Firefox, gedit, Empathy, Nautilus)

Anyone has an idea as to what might cause this behavior when using GNOME?

Thanks.

EDIT: Solved for libreoffice by removing the package "libreoffice-gnome". UI is not as pretty now but at least the keyboard shortcuts work.

Last edited by shimi (2013-08-09 09:00:50)

Offline

#2 2014-03-05 22:43:34

burafino
Member
From: London
Registered: 2009-12-07
Posts: 13
Website

Re: [Solved]Ctrl+V not working in libreoffice on gnome(non-latin layout)

After months of switching layouts and banging my head against this bug, I thought I should check LibreOffice settings (I'm using 4.1.5.3 now). What figures? I did find something. And in just a few clicks.

This is not a bug! It's simply a matter of configuration.

For the regular keyboard shortcuts (like Ctrl+C, Ctrl+V, etc.) to remain operational in LibreOffice applications while using a non-latin keyboard layout (like Greek or Russian), go to Tools -> Options -> Language Settings -> Languages, check the Ignore system input language option, save, and Bob's your uncle.

Hope this helps.

Cheers!

PS
Technically, though, shortcuts still remain language-dependent. This means if you enable this option, you will have to set your document languages manually.

Offline

Board footer

Powered by FluxBB