You are not logged in.

#1 2013-08-08 12:22:56

tinh
Member
Registered: 2012-12-16
Posts: 15

[solved]Impossible to build Haxe package

Hi everyone.

I tried to get the Haxe's package but I fell on a dependency issue.

Here is my operation:

login@local ~ % yaourt -S haxe

==> Downloading haxe PKGBUILD from AUR...
x PKGBUILD
x haxeserver
x haxe.sh
x haxe.csh
x haxe.install
Comment by ZauberParacelsus  (2013-04-17 23:28)
I get the following error from this PKGBUILD:

ocamlopt -g -I libs/extlib -I libs/extc -I libs/neko -I libs/javalib -I libs/ziplib -I libs/swflib -I libs/xml-light -c genswf.ml
File "genswf.ml", line 834, characters 15-24:
Error: Unbound module Ttf
make: *** [genswf.cmx] Error 2

Comment by dseg  (2013-05-10 15:47)
@ZauberParacelsus
Same error for me too.
Could you remove entire src directory before build?

rm -rf src  makepkg

Comment by dseg  (2013-05-10 15:47)
Updated to 3.0.0-rc2

Comment by dseg  (2013-05-30 00:16)
Updated to 3.0.0 (release)

Comment by camboris  (2013-06-06 00:51)
They changed en env var that haxe uses to find the std library. You have HAXE_LIBRARY_PATH and it should be HAXE_STD_PATH
Here is a discussion about this. https://groups.google.com/forum/?fromgroups#!topic/haxelang/EfHKIfGtHac

haxe 3.0.0-1  (Wed Apr 30 16:11:20 CEST 2008)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> haxe dependencies:
 - sh (already installed)
 - subversion (already installed)
 - ocaml>=4.00.0 (already installed)
 - zlib (already installed)
 - neko>=2.0.0 (building from AUR)
 - neko>=2.0.0 (building from AUR)


==> Edit haxe.install ? [Y/n] ("A" to abort)
==> ----------------------------------------
==>

==> Continue building haxe ? [Y/n]
==> ------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for haxe:

==> Downloading neko PKGBUILD from AUR...
x install.neko.patch
x PKGBUILD
Comment by TopHattedCoder  (2013-02-24 23:32)
Needs updating to Neko 2.0.0...

Comment by xyproto  (2013-02-25 12:48)
Updated to 2.0.0. Thanks for notifying, TopHattedCoder.

Comment by xyproto  (2013-02-25 13:22)
Submitted a feature request for Neko: http://code.google.com/p/nekovm/issues/detail?id=34

Comment by olidesborough  (2013-05-22 00:15)
This has been broken since the change from MySQL to MariaDB - just need to change the dependency in the PKGBUILD from 'libmysqlclient' to 'libmariadbclient'

Comment by xyproto  (2013-05-23 11:06)
Thanks, olidesborough. Updated the package.

neko 2.0.0-2  (Wed Jul  4 14:42:35 CEST 2007)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> neko dependencies:
 - gtk2 (already installed)
 - libmariadbclient (already installed)
 - pcre (already installed)
 - zlib (already installed)
 - sqlite (already installed)
 - pkgconfig (already installed)
 - apr (already installed)
 - gc (package found)
 - apache (package found)
 - setconf (building from AUR)


==> Continue building neko ? [Y/n]
==> ------------------------------
==>
==> Building and installing package
==> Install or build missing dependencies for neko:
[sudo] password for login:
error: target login found: setconf
==> Restart building neko ? [y/N]
==> -----------------------------
==> N
login@local ~ % echo "what to do?"
What to do?
login@local ~ %

Do you have any suggestions because I was unable to find the following package:

setconf

Thanks

Last edited by tinh (2013-08-08 12:42:18)

Offline

#2 2013-08-08 12:39:44

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [solved]Impossible to build Haxe package

Offline

#3 2013-08-08 12:43:33

tinh
Member
Registered: 2012-12-16
Posts: 15

Re: [solved]Impossible to build Haxe package

Thank you. I forgot to re-enable community from pacman.conf. Sory to disturb. How can I delete my post? It's pretty useless, actually!

Offline

#4 2013-08-08 12:46:20

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [solved]Impossible to build Haxe package

No need to delete the thread. You've posted the solution and marked it solved, so it's OK by me.
There's a 'Report' link in the bottom right corner of every post - use this if somebody is misbehaving, you accidentally doublepost etc. If you want, you can use it to ask the moderators to remove this thread.

Offline

#5 2013-08-08 12:55:11

tinh
Member
Registered: 2012-12-16
Posts: 15

Re: [solved]Impossible to build Haxe package

If you say it's ok for you. No need to delete then.

Offline

Board footer

Powered by FluxBB