You are not logged in.

#1 2013-08-09 08:01:22

combuster
Member
From: Serbia
Registered: 2008-09-30
Posts: 711
Website

[SOLVED] loginctl and polkit problem in Xfce!

Problem is I can't mount anything in thunar, no cd's no usb, the message is:

Failed to mount, not authorized to perform operation

I can see this in .xsession-errors

(polkit-gnome-authentication-agent-1:2016): polkit-gnome-1-WARNING **: Unable to determine the session we are in: No session for pid 2016

When I type loginctl i get

SESSION        UID USER             SEAT           

0 sessions listed.

I am starting xfce session via lightdm, enabled it via systemctl enable lightdm.service

What the heck could be wrong ?

/edit: Hm, there is really no pid with 2016 (tried it several times)

Last edited by combuster (2013-08-12 10:55:21)

Offline

#2 2013-08-09 08:29:17

combuster
Member
From: Serbia
Registered: 2008-09-30
Posts: 711
Website

Re: [SOLVED] loginctl and polkit problem in Xfce!

I'm not sure if this is relevant cause I have the same headache with the normal local user, but I'm using AD user account to login, so have a slight modifications to /etc/pam.d/system-auth

#%PAM-1.0

auth      required	pam_env.so
auth      sufficient	pam_unix.so try_first_pass nullok
auth      required	pam_winbind.so use_first_pass use_authtok
auth      optional	pam_permit.so

account   sufficient	pam_unix.so
account   sufficient	pam_winbind.so try_first_pass use_authtok
account   optional	pam_permit.so
account   required	pam_time.so

password  sufficient	pam_unix.so   
password  sufficient	pam_winbind.so try_first_pass use_authtok
password  optional	pam_permit.so

session   required	pam_mkhomedir.so skel=/etc/skel/ umask=0022
session   sufficient	pam_unix.so
session   sufficient	pam_winbind.so use_first_pass use_authtok
session   required	pam_limits.so
session   required	pam_env.so
session   optional	pam_permit.so

Offline

#3 2013-08-09 09:50:30

torors
Member
Registered: 2012-09-28
Posts: 94

Re: [SOLVED] loginctl and polkit problem in Xfce!

Have you installed  thunar-volman and configured it like described in the wiki?

Offline

#4 2013-08-09 10:15:08

combuster
Member
From: Serbia
Registered: 2008-09-30
Posts: 711
Website

Re: [SOLVED] loginctl and polkit problem in Xfce!

Yes, no dice...

Offline

#5 2013-08-09 13:18:25

opensrcrox
Member
Registered: 2012-08-10
Posts: 32

Re: [SOLVED] loginctl and polkit problem in Xfce!

Try this ( considering your logind problem ) as an experiment :  Edit /etc/pam.d/lightdm and append

 session         required        pam_loginuid.so
 session         required        pam_systemd.so

.. and then after restarting your session, check loginctl again.

Disclaimer: I don't use lightdm, and I haven't studied it ... but give it a shot if you want to experiment smile

Offline

#6 2013-08-12 10:54:53

combuster
Member
From: Serbia
Registered: 2008-09-30
Posts: 711
Website

Re: [SOLVED] loginctl and polkit problem in Xfce!

Thnx opensrcrox, this got me on the right track (I've ruled out almost everything else during the weekend) and adding

session   optional      pam_loginuid.so
-session  optional      pam_systemd.so
-session  optional      pam_ck_connector.so nox11

to system-auth solved the issue!

/edit:

Since consolekit is deprecated I wonder why this last pam module is even needed. I'll try without it...

/edit:

not needed, works without it

Last edited by combuster (2013-08-12 11:08:39)

Offline

Board footer

Powered by FluxBB