You are not logged in.

#1 2013-08-09 21:15:56

russose
Member
Registered: 2013-08-09
Posts: 20

Hibernation does not shutdown the computer

Hello,

the hibernation was working perfectly until one of the last updates. I can not say exactly when things get broken since I didn't rebooted my computer for weeks (it was in hibernation only) and so the last kernel updates were probably not applied... However, after a real reboot, when I hibernate now, everything works fine except that I have to "shutdown" the computer manually pressing the on/off button myself. When I start the computer again, it resumes from hibernation perfectly without doing the whole start sequence...

Does someone have an idea where I could look for to avoid pressing the on/off button myself to close the computer?

Thanks for your help,
Salvatore

PS: I am working with KDE and have an ATI graphic card.

Offline

#2 2013-08-09 22:15:13

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

Welcome to the forums.

How are you hibernating? I haven't hibernated for ages but the way I set it up, it is the kernel command line which carries information about the resume image. So it must begin the standard boot sequence which means it must use the currently installed kernel. So I'm not sure how hibernating would prevent the application of kernel updates?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#3 2013-08-09 22:21:30

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hi,

thanks cfr for the answer. I thought the start-up after hibernation would reuse the same kernel after the next full reboot. But according to what you say, I am wrong... I don't know what changed in my system but since a couple of days, hibernation works with the small drawback I explained (nothing dramatic but I have to switch my computer off manually).

I hibernate using KDE hibernation menu: K => Quit => Hibernation. Nothing special...

Salvatore

Offline

#4 2013-08-09 23:46:32

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

Do you mean Leave => Hibernate? I don't have Quit => Hibernation?

The thing is, I thought you needed not to resume in cases where the kernel had been updated so I'm really confused.

EDIT: In any case, you didn't really say how you hibernate. Do you use a swap partition? A swap file? tuxonice? The functionality in the kernel?

To put this another way, when you set up hibernation originally, how did you do it?

Last edited by cfr (2013-08-09 23:50:15)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#5 2013-08-10 01:41:52

rufus
Banned
From: san francisco
Registered: 2013-04-20
Posts: 153

Re: Hibernation does not shutdown the computer

yeah tuxonice would be the thing todo
   but whats the advantage of hibernating over suspend????


end ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
     'the machine is not the end to the means., we are. In history, in board rooms and politic the greatest  decision and effort
        evolves from passion, lust for life, and a common sense of humanity. Never forget what you are and why'.         -me

Offline

#6 2013-08-10 02:31:32

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

rufus wrote:

yeah tuxonice would be the thing todo

Why? Why do you think that would solve the OP's problem?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#7 2013-08-10 07:08:06

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hi,

I am working with a "French" KDE so the "K => Quit => Hibernation" was a attempt to translate... it is "Leave => Hibernate".
I have in KDE two way to suspend, either on ram or on disk. When I say "hibernation", it is the "suspend on disk" (again, I am translating the French menu in English so it is maybe not 100% the same wording...)

To have hibernation work when I install Archlinux, I did nothing special, I followed this page:
https://wiki.archlinux.org/index.php/Su … _Hibernate

but didn't do, as far as I remember, nothing special: with KDE, it was working out of the box. I use syslinux with the following APPEND:
APPEND root=UUID=eed88cd6-6ab6-462b-8a93-ae8e689fb33e resume=UUID=4e6ecaaf-a853-49eb-ad17-b3efaced3856 ro
so I just added the UUID of my swap partition.

I am a little confused, it was and is still working well, I am probably using the kernel hibernation... The only issue is that the computer does not shutdown completely now and I have to do it manually by pressing the on/off button.

Thanks for the support,
Salvatore

PS: you can ignore my statement about the updates not applied, I thought it was so but I was probably wrong. I use my computer, apply every day the updates, hibernate... and once a while, I reboot to have a clean reboot just in case.

Offline

#8 2013-08-10 21:56:30

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

If you shutdown from the KDE menu, does your machine power off then?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#9 2013-08-11 08:22:01

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hello,

If I shutdown, it works perfectly. If I suspend to ram, it works perfectly If I suspend to disk (hibernate), Linux does not manage to power-off my computer and I have to do it manually (but the resure works perfectly after).

Salvatore

Offline

#10 2013-08-11 15:37:30

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

Have you read the man page for systemd-sleep.conf?


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#11 2013-08-11 19:31:24

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hi,

I read the man page but didnt't found a solution. I have no sleep.conf file in my system.
I found also, thanks to your additional information, the following issue that is exactly the same than mine:

https://bugzilla.redhat.com/show_bug.cgi?id=917494

I also read an article suggesting to wait more than 5 minutes to ensure that the issue was not coming from a "dead" service: but even after 5 to 10 minutes, the computer does not poweroff. I also tried to reinstall vmware-player just in case the issue was caused by a buggy uninstallation of vmware-player.

But all these attempts did not solve the issue. I have no idea how could I solve this, maybe just waiting a new upgrade of my system in case it is a bug from the kernel that will be solved in future deliveries...

Salvatore

Offline

#12 2013-08-11 19:41:46

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

That bug seems to have been fixed, though. I'm sure Arch must have that fix by now if it is in the mainstream code (and not just a fedora patch).

Just to eliminate complications, do you get the same results if you use
1) systemctl hibernate
2) boot to CLI and do systemctl hibernate without starting X at all?

[Might be good to eliminate KDM/KDE from the list of suspects - just in case - though this seems unlikely, I admit.]

Also, I suggest looking at the logs/journal and posting anything which might be relevant if you don't know what to make of it. (Don't be offended by this - I'm not patronising you. I rarely know what to make of this stuff and am always astonished when others do wink.)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#13 2013-08-11 22:29:08

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hi,

I rebooted and instead of login to KDE, I did ALT-F1 to go to the terminal, then I login in the terminal and hibernate with "systemctl hibernate" and it worked! So "systemctl hibernate" from KDE running is not working and "systemctl hibernate" before login to KDE works.

I paste below the last ligns of journalctl:

juil. 19 22:51:19 My_Desktop su[12268]: pam_unix(su:session): session opened for user root by (uid=1000)
juil. 19 22:51:41 My_Desktop su[12268]: pam_unix(su:session): session closed for user root
-- Reboot --
août 03 20:51:25 My_Desktop sudo[2964]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 06 22:10:02 My_Desktop sudo[7014]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 07 22:39:12 My_Desktop sudo[1556]: pam_unix(sudo:auth): conversation failed
août 10 09:01:58 My_Desktop su[7995]: (to russose) russose on none
août 10 09:01:58 My_Desktop su[7995]: pam_unix(su:session): session opened for user root by (uid=1000)
août 10 09:02:15 My_Desktop su[7995]: pam_unix(su:session): session closed for user root
août 10 09:02:43 My_Desktop su[8068]: (to russose) russose on none
août 10 09:02:43 My_Desktop su[8071]: (to russose) russose on none
août 10 09:02:43 My_Desktop su[8071]: pam_unix(su:session): session opened for user root by (uid=1000)
août 10 09:10:00 My_Desktop su[8071]: pam_unix(su:session): session closed for user root
août 11 20:40:42 My_Desktop su[13321]: (to russose) russose on none
août 11 20:40:42 My_Desktop su[13324]: (to russose) russose on none
août 11 20:40:42 My_Desktop su[13324]: pam_unix(su:session): session opened for user root by (uid=1000)
août 11 20:40:47 My_Desktop su[13324]: pam_unix(su:session): session closed for user root
août 11 20:41:48 My_Desktop su[13367]: (to russose) russose on none
août 11 20:41:48 My_Desktop su[13370]: (to russose) russose on none
août 11 20:41:48 My_Desktop su[13370]: pam_unix(su:session): session opened for user root by (uid=1000)
août 11 20:42:09 My_Desktop su[13370]: pam_unix(su:session): session closed for user root
août 11 23:53:46 My_Desktop sudo[20937]: pam_unix(sudo:auth): conversation failed

the messages "pam_unix(sudo:auth): conversation failed" are writen in red.

Thanks cfr for your help, I am not an linux expert so don't worry, I will take for good any suggestions even if it is for newbee wink

Salvatore

Offline

#14 2013-08-11 22:53:33

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

russose wrote:

I rebooted and instead of login to KDE, I did ALT-F1 to go to the terminal, then I login in the terminal and hibernate with "systemctl hibernate" and it worked! So "systemctl hibernate" from KDE running is not working and "systemctl hibernate" before login to KDE works.

OK. Interesting. What if you run systemctl hibernate from Konsole while in KDE? Does that fail?

I paste below the last ligns of journalctl:

Please use code tags like this (quote this message to see how):

juil. 19 22:51:19 My_Desktop su[12268]: pam_unix(su:session): session opened for user root by (uid=1000)
juil. 19 22:51:41 My_Desktop su[12268]: pam_unix(su:session): session closed for user root
-- Reboot --
août 03 20:51:25 My_Desktop sudo[2964]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 06 22:10:02 My_Desktop sudo[7014]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 07 22:39:12 My_Desktop sudo[1556]: pam_unix(sudo:auth): conversation failed
août 10 09:01:58 My_Desktop su[7995]: (to russose) russose on none
août 10 09:01:58 My_Desktop su[7995]: pam_unix(su:session): session opened for user root by (uid=1000)
août 10 09:02:15 My_Desktop su[7995]: pam_unix(su:session): session closed for user root
août 10 09:02:43 My_Desktop su[8068]: (to russose) russose on none
août 10 09:02:43 My_Desktop su[8071]: (to russose) russose on none
août 10 09:02:43 My_Desktop su[8071]: pam_unix(su:session): session opened for user root by (uid=1000)
août 10 09:10:00 My_Desktop su[8071]: pam_unix(su:session): session closed for user root
août 11 20:40:42 My_Desktop su[13321]: (to russose) russose on none
août 11 20:40:42 My_Desktop su[13324]: (to russose) russose on none
août 11 20:40:42 My_Desktop su[13324]: pam_unix(su:session): session opened for user root by (uid=1000)
août 11 20:40:47 My_Desktop su[13324]: pam_unix(su:session): session closed for user root
août 11 20:41:48 My_Desktop su[13367]: (to russose) russose on none
août 11 20:41:48 My_Desktop su[13370]: (to russose) russose on none
août 11 20:41:48 My_Desktop su[13370]: pam_unix(su:session): session opened for user root by (uid=1000)
août 11 20:42:09 My_Desktop su[13370]: pam_unix(su:session): session closed for user root
août 11 23:53:46 My_Desktop sudo[20937]: pam_unix(sudo:auth): conversation failed

It makes it a lot easier to read (and makes it scrollable if there's a lot of it).
Is that log from a failed case i.e. where it hibernates but doesn't shut off? I don't see where the hibernate request is... You need logs from when you try to hibernate and it doesn't poweroff to (hopefully) see what's causing the problem.

One thing you could try is creating a clean user account, logging into KDE as that user and seeing if hibernate from KDE's menu works properly then. If it does, you'd know it was something about your account configuration. If not, it must be system wide.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#15 2013-08-12 20:13:04

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hi,


I tried "systemctl hibernate" from both:
1) the Konsole in KDE in my account
2) the account of my wife that does not really tune her KDE session
and in both cases, it fails.

Here is the end of the journalctl command:

-- Reboot --
juin 23 21:50:43 My_Desktop su[2318]: (to russose) russose on none
juin 23 21:50:43 My_Desktop su[2321]: (to russose) russose on none
juin 23 21:50:43 My_Desktop su[2321]: pam_unix(su:session): session opened for user root by (uid=1000)
juin 23 21:50:47 My_Desktop su[2321]: pam_unix(su:session): session closed for user root
juin 23 21:50:59 My_Desktop su[2367]: (to russose) russose on none
juin 23 21:50:59 My_Desktop su[2370]: (to russose) russose on none
juin 23 21:50:59 My_Desktop su[2370]: pam_unix(su:session): session opened for user root by (uid=1000)
juin 23 21:52:05 My_Desktop su[2370]: pam_unix(su:session): session closed for user root
juin 24 23:03:28 My_Desktop sshd[7621]: Received disconnect from 192.168.1.92: 11: disconnected by user
-- Reboot --
juin 27 00:16:19 My_Desktop sudo[3995]: pam_unix(sudo:auth): authentication failure; logname=russose uid=1000 euid=0 tty=/dev/pts/2 ruser=russose rhost=  user=russose
juin 27 00:16:23 My_Desktop sudo[3995]: pam_unix(sudo:auth): conversation failed
juin 27 00:17:27 My_Desktop su[4012]: (to russose) russose on none
juin 27 00:17:27 My_Desktop su[4015]: (to russose) russose on none
juin 27 00:17:27 My_Desktop su[4015]: pam_unix(su:session): session opened for user root by (uid=1000)
juin 27 00:19:01 My_Desktop su[4062]: (to russose) russose on none
juin 27 00:19:01 My_Desktop su[4065]: (to russose) russose on none
juin 27 00:19:01 My_Desktop su[4065]: pam_unix(su:session): session opened for user root by (uid=1000)
juin 27 00:23:22 My_Desktop su[4115]: (to russose) russose on none
juin 27 00:23:22 My_Desktop su[4118]: (to russose) russose on none
juin 27 00:23:22 My_Desktop su[4118]: pam_unix(su:session): session opened for user root by (uid=1000)
juin 27 00:24:36 My_Desktop su[4118]: pam_unix(su:session): session closed for user root
juin 29 08:56:36 My_Desktop sshd[18318]: Received disconnect from 192.168.1.92: 11: disconnected by user
juin 29 09:12:28 My_Desktop sshd[18472]: Received disconnect from 192.168.1.92: 11: disconnected by user
-- Reboot --
juin 30 22:16:24 My_Desktop sshd[13143]: Received disconnect from 192.168.1.92: 11: disconnected by user
juin 30 23:16:06 My_Desktop sshd[13426]: Received disconnect from 192.168.1.92: 11: disconnected by user
-- Reboot --
juil. 17 20:47:38 My_Desktop sshd[1941]: Received disconnect from 192.168.1.92: 11: disconnected by user
juil. 19 22:51:19 My_Desktop su[12265]: (to russose) russose on none
juil. 19 22:51:19 My_Desktop su[12268]: (to russose) russose on none
juil. 19 22:51:19 My_Desktop su[12268]: pam_unix(su:session): session opened for user root by (uid=1000)
juil. 19 22:51:41 My_Desktop su[12268]: pam_unix(su:session): session closed for user root
-- Reboot --
août 03 20:51:25 My_Desktop sudo[2964]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 06 22:10:02 My_Desktop sudo[7014]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 07 22:39:12 My_Desktop sudo[1556]: pam_unix(sudo:auth): conversation failed
août 10 09:01:58 My_Desktop su[7995]: (to russose) russose on none
août 10 09:01:58 My_Desktop su[7995]: pam_unix(su:session): session opened for user root by (uid=1000)
août 10 09:02:15 My_Desktop su[7995]: pam_unix(su:session): session closed for user root
août 10 09:02:43 My_Desktop su[8068]: (to russose) russose on none
août 10 09:02:43 My_Desktop su[8071]: (to russose) russose on none
août 10 09:02:43 My_Desktop su[8071]: pam_unix(su:session): session opened for user root by (uid=1000)
août 10 09:10:00 My_Desktop su[8071]: pam_unix(su:session): session closed for user root
août 11 20:40:42 My_Desktop su[13321]: (to russose) russose on none
août 11 20:40:42 My_Desktop su[13324]: (to russose) russose on none
août 11 20:40:42 My_Desktop su[13324]: pam_unix(su:session): session opened for user root by (uid=1000)
août 11 20:40:47 My_Desktop su[13324]: pam_unix(su:session): session closed for user root
août 11 20:41:48 My_Desktop su[13367]: (to russose) russose on none
août 11 20:41:48 My_Desktop su[13370]: (to russose) russose on none
août 11 20:41:48 My_Desktop su[13370]: pam_unix(su:session): session opened for user root by (uid=1000)
août 11 20:42:09 My_Desktop su[13370]: pam_unix(su:session): session closed for user root
août 11 23:53:46 My_Desktop sudo[20937]: pam_unix(sudo:auth): conversation failed
-- Reboot --
août 12 00:16:53 My_Desktop sudo[518]: pam_unix(sudo:auth): authentication failure; logname=russose uid=1000 euid=0 tty=/dev/tty1 ruser=russose rhost=  user=russose

and the see the hibernate yesterday at 00:16 (going to sleep!) that didn't power off and I had to poweroff manually.

it seems there is an authentication failure... maybe I have to tune my policykit rules since my account is not able to poweroff :( ? That would be strange since it always worked.

Salvatore

Last edited by russose (2013-08-12 20:13:27)

Offline

#16 2013-08-12 21:25:08

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

I investigate the polkit area... arrived to the file "/usr/share/polkit-1/actions/org.freedesktop.login1.policy" that I modified frw time ago (to enable my wife to hibernate when my session was open). I thought the problem may come from here... so I reinstalled systemd and other small package to recover the original configuration of the files in the directory /usr/share/polkit-1/actions/.

But it is still not working... I start to loose my hope sad

You can find below the end of /var/log/pm-powersave.log :

/usr/lib/pm-utils/power.d/laptop-mode false: success.
Running hook /usr/lib/pm-utils/power.d/pcie_aspm false:
/usr/lib/pm-utils/power.d/pcie_aspm: ligne 9 : echo: erreur d'écriture : Opération non permise

/usr/lib/pm-utils/power.d/pcie_aspm false: success.
Running hook /usr/lib/pm-utils/power.d/readahead false:
Setting readahead for /dev/sdb1 to 256...Done.
Setting readahead for /dev/sda1 to 256...Done.
Setting readahead for /dev/sdb6 to 256...Done.
Setting readahead for /dev/sdb7 to 256...Done.
Setting readahead for /dev/sdb8 to 256...Done.

/usr/lib/pm-utils/power.d/readahead false: success.
Running hook /usr/lib/pm-utils/power.d/sata_alpm false:
Setting SATA APLM on host2 to max_performance...Done.
Setting SATA APLM on host3 to max_performance...Done.
Setting SATA APLM on host4 to max_performance...Done.
Setting SATA APLM on host5 to max_performance...Done.

/usr/lib/pm-utils/power.d/sata_alpm false: success.
Running hook /usr/lib/pm-utils/power.d/sched-powersave false:
**sched policy powersave OFF

/usr/lib/pm-utils/power.d/sched-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/wireless false:

/usr/lib/pm-utils/power.d/wireless false: success.
Running hook /usr/lib/pm-utils/power.d/xfs_buffer false:

/usr/lib/pm-utils/power.d/xfs_buffer false: success.
Running hook /usr/lib/pm-utils/power.d/hal-cd-polling false:

/usr/lib/pm-utils/power.d/hal-cd-polling false: success.
Running hook /usr/lib/pm-utils/power.d/intel-audio-powersave false:
Setting power savings for snd_hda_intel to 0...Done.

/usr/lib/pm-utils/power.d/intel-audio-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/journal-commit false:
Setting journal commit time for / to 0...Done.
Setting journal commit time for /media/BACKUP to 0...Done.
Setting journal commit time for /media/DIVERS to 0...Done.
Setting journal commit time for /media/MEDIA to 0...Done.
Setting journal commit time for /media/DATA to 0...Done.

/usr/lib/pm-utils/power.d/journal-commit false: success.
Running hook /usr/lib/pm-utils/power.d/laptop-mode false:
Laptop mode disabled.

/usr/lib/pm-utils/power.d/laptop-mode false: success.
Running hook /usr/lib/pm-utils/power.d/pcie_aspm false:
/usr/lib/pm-utils/power.d/pcie_aspm: ligne 9 : echo: erreur d'écriture : Opération non permise

/usr/lib/pm-utils/power.d/pcie_aspm false: success.
Running hook /usr/lib/pm-utils/power.d/readahead false:
Setting readahead for /dev/sdb1 to 256...Done.
Setting readahead for /dev/sda1 to 256...Done.
Setting readahead for /dev/sdb8 to 256...Done.
Setting readahead for /dev/sdb7 to 256...Done.
Setting readahead for /dev/sdb6 to 256...Done.

/usr/lib/pm-utils/power.d/readahead false: success.
Running hook /usr/lib/pm-utils/power.d/sata_alpm false:
Setting SATA APLM on host2 to max_performance...Done.
Setting SATA APLM on host3 to max_performance...Done.
Setting SATA APLM on host4 to max_performance...Done.
Setting SATA APLM on host5 to max_performance...Done.

/usr/lib/pm-utils/power.d/sata_alpm false: success.
Running hook /usr/lib/pm-utils/power.d/sched-powersave false:
**sched policy powersave OFF

/usr/lib/pm-utils/power.d/sched-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/wireless false:

/usr/lib/pm-utils/power.d/wireless false: success.
Running hook /usr/lib/pm-utils/power.d/xfs_buffer false:

/usr/lib/pm-utils/power.d/xfs_buffer false: success.
Running hook /usr/lib/pm-utils/power.d/hal-cd-polling false:

/usr/lib/pm-utils/power.d/hal-cd-polling false: success.
Running hook /usr/lib/pm-utils/power.d/intel-audio-powersave false:
Setting power savings for snd_hda_intel to 0...Done.

/usr/lib/pm-utils/power.d/intel-audio-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/journal-commit false:
Setting journal commit time for / to 0...Done.
Setting journal commit time for /media/BACKUP to 0...Done.
Setting journal commit time for /media/DATA to 0...Done.
Setting journal commit time for /media/MEDIA to 0...Done.
Setting journal commit time for /media/DIVERS to 0...Done.

/usr/lib/pm-utils/power.d/journal-commit false: success.
Running hook /usr/lib/pm-utils/power.d/laptop-mode false:
Laptop mode disabled.

/usr/lib/pm-utils/power.d/laptop-mode false: success.
Running hook /usr/lib/pm-utils/power.d/pcie_aspm false:
/usr/lib/pm-utils/power.d/pcie_aspm: ligne 9 : echo: erreur d'écriture : Opération non permise

/usr/lib/pm-utils/power.d/pcie_aspm false: success.
Running hook /usr/lib/pm-utils/power.d/readahead false:
Setting readahead for /dev/sdb1 to 256...Done.
Setting readahead for /dev/sda1 to 256...Done.
Setting readahead for /dev/sdb6 to 256...Done.
Setting readahead for /dev/sdb7 to 256...Done.
Setting readahead for /dev/sdb8 to 256...Done.

/usr/lib/pm-utils/power.d/readahead false: success.
Running hook /usr/lib/pm-utils/power.d/sata_alpm false:
Setting SATA APLM on host2 to max_performance...Done.
Setting SATA APLM on host3 to max_performance...Done.
Setting SATA APLM on host4 to max_performance...Done.
Setting SATA APLM on host5 to max_performance...Done.

/usr/lib/pm-utils/power.d/sata_alpm false: success.
Running hook /usr/lib/pm-utils/power.d/sched-powersave false:
**sched policy powersave OFF

/usr/lib/pm-utils/power.d/sched-powersave false: success.
Running hook /usr/lib/pm-utils/power.d/wireless false:

/usr/lib/pm-utils/power.d/wireless false: success.
Running hook /usr/lib/pm-utils/power.d/xfs_buffer false:

/usr/lib/pm-utils/power.d/xfs_buffer false: success.

There is a strange line with an error (in French):
/usr/lib/pm-utils/power.d/pcie_aspm: ligne 9 : echo: erreur d'écriture : Opération non permise
that means : line 9: write error - operation not allowed.

Any idea how can I allow pcie_aspm to shutdown my computer wink ?

Offline

#17 2013-08-12 22:01:05

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

Do you have sudo installed? It looks like it is trying to use sudo in the case that fails. Not sure quite why this should be different, mind...


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#18 2013-08-12 22:30:55

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

yes I have sudo... I tried also "sudo systemctl hibernate" but it does not work neither sad

Offline

#19 2013-08-12 23:00:28

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

You may want to get rid of pm-utils. If you can't because it is a dependency - I think KDE depends on it and that's why I still have it - you can effectively mask its effects.

cd /usr/lib/pm-utils/power.d
mkdir -p /etc/pm/power.d
for i in *
do
touch /etc/pm/power.d/$i
done

For example, I have

$ l /etc/pm/power.d/
total 8.0K
drwxr-xr-x 2 root root 4.0K Med   3  2012 ./
drwxr-xr-x 6 root root 4.0K Med  21  2012 ../
-rw-r--r-- 1 root root    0 Med   3  2012 cpupower
-rw-r--r-- 1 root root    0 Rha  19  2011 hal-cd-polling
-rw-r--r-- 1 root root    0 Rha  19  2011 intel-audio-powersave
-rw-r--r-- 1 root root    0 Rha  19  2011 journal-commit
-rw-r--r-- 1 root root    0 Rha  19  2011 laptop-mode
-rw-r--r-- 1 root root    0 Rha  19  2011 pcie_aspm
-rw-r--r-- 1 root root    0 Rha  19  2011 readahead
-rw-r--r-- 1 root root    0 Rha  19  2011 sata_alpm
-rw-r--r-- 1 root root    0 Rha  19  2011 sched-powersave
-rw-r--r-- 1 root root    0 Rha  19  2011 wireless
-rw-r--r-- 1 root root    0 Rha  19  2011 xfs_buffer

Notice they are all 0 bytes i.e. empty.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#20 2013-08-13 11:33:35

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

is there a way to first test the hibernation without pm-utils first to avoid making this operation if it still does not work? Any idea why pcie_aspm cannot do his job? It was working perfectly during months until few days ago...

Offline

#21 2013-08-13 20:35:35

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

Well if it doesn't help, you can just delete those files.

No idea about pcie_aspm. I'm not even sure what it does.

pm-utils, as I understand it, is buggy because unmaintained. In particular, I doubt it fits all that well with systemd or, probably, with newer kernels. I believe that the plan is probably to ditch it as soon as possible. Right now, I can't remove it from my system because KDE needs upower which needs pm-utils. However, I believe that an update in the not-too-distant future of upower will remove this dependency.

I think a lot of what pm-utils was designed to do was work around quirks and hiccoughs which systemd now deals better with on its own. But I don't know the details and might have got the wrong impression.


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#22 2013-08-14 15:47:57

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

ok, I will try. So if I understood well, I have to play your script:

for i in *
do
touch /etc/pm/power.d/$i
done

in the directory /etc/pm/power.d (to be created if not existing).

And before, I have to try to delete pm-utils and see if it can be deleted "alone" without too many dependancies...

Is it right?

Salvatore

Offline

#23 2013-08-14 20:32:37

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

Hello,

I launched the script... it created the files... but the hibernation is still not shutting down my computer and the error message in pm-powersave.log is the same sad Should I continue to hope to solve this issue? wink

Any new idea?

Salvatore

Offline

#24 2013-08-14 20:46:38

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 6,104

Re: Hibernation does not shutdown the computer

Switch to the directory /usr/lib/pm-utils/power.d before you run the script.

Or else do

mkdir -p /etc/pm/power.d;
for i in /usr/lib/pm-utils/power.d/*; do touch /etc/pm/power.d/$(basename $i); done

as it won't matter where you are in that case.

All this does is create the /etc/pm/power.d directory, and for each file in /usr/lib/pm-utils/power.d/, it creates an empty file in /etc/pm/power.d/ of the same name which effectively "masks" the effect of the one installed under /usr/lib/. If by any chance you already have a file of the same name in /etc/pm/power.d/ already, all it will do is change the file's modification date - it won't overwrite the file, for example.

Last edited by cfr (2013-08-14 20:49:54)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Corporation Wireless 8265 / 8275 | US keyboard with Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#25 2013-08-14 21:47:59

russose
Member
Registered: 2013-08-09
Posts: 20

Re: Hibernation does not shutdown the computer

ok, that's what I did and it created the files but it still doesn't work sad

Here is the content of my /etc/pm/power.d/ directory

[russose@My_Desktop log]$ ls -al /etc/pm/power.d/
total 8
drwxr-xr-x 2 root root 4096 14 août  22:22 .
drwxr-xr-x 5 root root 4096 30 mai   23:04 ..
-rw-r--r-- 1 root root    0 14 août  22:22 hal-cd-polling
-rw-r--r-- 1 root root    0 14 août  22:22 intel-audio-powersave
-rw-r--r-- 1 root root    0 14 août  22:22 journal-commit
-rw-r--r-- 1 root root    0 14 août  22:22 laptop-mode
-rw-r--r-- 1 root root    0 14 août  22:22 pcie_aspm
-rw-r--r-- 1 root root    0 14 août  22:22 readahead
-rw-r--r-- 1 root root    0 14 août  22:22 sata_alpm
-rw-r--r-- 1 root root    0 14 août  22:22 sched-powersave
-rw-r--r-- 1 root root    0 14 août  22:22 wireless
-rw-r--r-- 1 root root    0 14 août  22:22 xfs_buffer
[russose@My_Desktop log]$ 

Offline

Board footer

Powered by FluxBB