You are not logged in.

#1 2013-08-10 22:19:11

Castore
Member
Registered: 2011-05-24
Posts: 4

Problem with nVidia 325.15-1

After the last upgrade of the nvidia driver at every boot, my system freeze after, about a minute. I've tried with kernel-lts too but no luck.
I've downgraded the driver and everything is ok. Nouveau, exept for performance and temperatures issues, works well.

My card is a nVidia GeForce 9200 and I've never had problems before with proprietary or open nvidia driver.
Any suggestion?

I can give every other info that could help.
Thanks in advance

Offline

#2 2013-08-11 06:26:56

catseye
Member
Registered: 2009-03-09
Posts: 16

Re: Problem with nVidia 325.15-1

Hello,

Castore wrote:

After the last upgrade of the nvidia driver at every boot, my system freeze after, about a minute. I've tried with kernel-lts too but no luck. I've downgraded the driver and everything is ok. Nouveau, exept for performance and temperatures issues, works well.

My card is a nVidia GeForce 9200 and I've never had problems before with proprietary or open nvidia driver.

Try this piece of advice that is given in Arch's very fine wiki here, except that you have to say

options nvidia NVreg_EnableMSI=0

because you want to disable the new MSI scheme that is now enabled by default in the 325.* driver line (check out the release notes for the new NVIDIA driver for details). That helped in my case (I have a board with a builtin 8200 GPU) and made all those nasty freezes go away for good that started to happen with the new series.

Last edited by catseye (2013-08-11 06:27:22)

Offline

#3 2013-08-11 20:02:12

Castore
Member
Registered: 2011-05-24
Posts: 4

Re: Problem with nVidia 325.15-1

catseye wrote:

Hello,

Castore wrote:

After the last upgrade of the nvidia driver at every boot, my system freeze after, about a minute. I've tried with kernel-lts too but no luck. I've downgraded the driver and everything is ok. Nouveau, exept for performance and temperatures issues, works well.

My card is a nVidia GeForce 9200 and I've never had problems before with proprietary or open nvidia driver.

Try this piece of advice that is given in Arch's very fine wiki here, except that you have to say

options nvidia NVreg_EnableMSI=0

because you want to disable the new MSI scheme that is now enabled by default in the 325.* driver line (check out the release notes for the new NVIDIA driver for details). That helped in my case (I have a board with a builtin 8200 GPU) and made all those nasty freezes go away for good that started to happen with the new series.

Thanks but, my modprobe file is empty, what can I do?
Thanks a lot.

Offline

#4 2013-08-12 05:33:55

catseye
Member
Registered: 2009-03-09
Posts: 16

Re: Problem with nVidia 325.15-1

Castore wrote:

Thanks but, my modprobe file is empty, what can I do?

Well, if you don't have a file named /etc/modprobe.d/modprobe.conf on your system, then just create one yourself. I have created a new file named /etc/modprobe.d/nvidia.conf on my system (the details about module configuration are described here in great detail) with just the following content:

blacklist nouveau
options nvidia NVreg_EnableMSI=0

The blacklist nouveau statement is necessary on my system because otherwise the kernel will pick up the nouveau module on the next reboot making it impossible for the nvidia module to take over control -- I don't know why that happens as the /usr/lib/modprobe.d/nvidia.conf file that is installed by the nvidia package should prevent that, but it was necessary on my system anyway.

Once you have created that file, reboot so the change can take effect.  You can check if the nvidia.conf configuration file has made any difference by typing

cat /proc/interrupts | grep -i nvidia

If the fourth column of the output does not read PCI-MSI-edge but something else -- in my case it reads IO-APIC-fasteoi -- then it has worked.

Offline

#5 2015-10-05 14:17:23

chaos_prevails
Member
Registered: 2015-10-05
Posts: 1

Re: Problem with nVidia 325.15-1

Hello,
thank you catseye!

I would like to confirm that this solved the crash issue for me aswell! I use a Asus M2N78 with Geforce 8200 IGP and use ubuntu 14.04 64bit with unity.

I had constant issues with the nouveau drivers (freezes after some hours of work, graphical artefacts, high temperature). Switching to the nvidia drivers crashed my PC as soon as I logged in (sometimes even before). The PC worked fine with a Geforce 8400 PCI-e card. I couldn't really see any difference in /var/log/syslog between 8200 and 8400.

I use nvidia 340 updates (just enabled via the additional drivers tab in unity):

dpkg -l | grep -i nvidia
ii  bbswitch-dkms                                               0.7-2ubuntu1                                        amd64        Interface for toggling the power on nVidia Optimus video cards
ii  libcuda1-340-updates                                        340.93-0ubuntu0.0.1                                 amd64        NVIDIA CUDA runtime library
ii  nvidia-340-updates                                          340.93-0ubuntu0.0.1                                 amd64        NVIDIA binary driver - version 340.93
ii  nvidia-libopencl1-340-updates                               340.93-0ubuntu0.0.1                                 amd64        NVIDIA OpenCL Driver and ICD Loader library
ii  nvidia-opencl-icd-340-updates                               340.93-0ubuntu0.0.1                                 amd64        NVIDIA OpenCL ICD
ii  nvidia-prime                                                0.6.2                                               amd64        Tools to enable NVIDIA's Prime
ii  nvidia-settings                                             355.06-100ubuntu100~ppa0~trusty0                    amd64        Tool for configuring the NVIDIA graphics driver

I had to add

options nvidia_340_updates NVreg_EnableMSI=0

into /etc/modprobe.d/nvidia.conf

Using options nvidia NVreg_EnableMSI=0 didn't disable NVreg_EnableMSI, although the module is called nvidia

lsmod | grep -i nvidia
nvidia              10563584  53 
drm                   344064  3 nvidia

Interrupt is now IO-APIC:

cat /proc/interrupts | grep -i nvidia
 20:      75010     337952   IO-APIC  20-fasteoi   ehci_hcd:usb2, nvidia

I'm running without crashes for 2 days now (impossible with the nouveau drivers). Using dual head 2*1280x1024, temperature is still high at 67C, but better than with nouveau (72C, sometimes even 73C).

Thank you again, another pci-e card which I can use somewhere else and be more HW efficient.
Tim

Last edited by chaos_prevails (2015-10-05 14:19:59)

Offline

#6 2015-10-06 13:00:25

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,126
Website

Re: Problem with nVidia 325.15-1

Please don't necrobump old topics, chaos_prevails.

Closing.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB