You are not logged in.

#1 2013-08-10 22:32:56

contiver
Member
Registered: 2013-07-31
Posts: 13

[SOLVED] Getting freezes after using dwm for some time and exiting it

Hello, I have an Asus Ux51, with a fresh (less than a month) arch installation. If I recall correctly I had a couple of freezes in other occasions but I don't remember much about those so I rather focus on the only freeze I can more or less reproduce and I've been having lately. After using dwm for some time with a couple of programs opened (rTorrent, browser, and some terminals for instance), if I close dwm or just press the power button to shut down, it starts closing everything and either stays with a black screen, or hangs while X prints the log information. It's not always though, for example, if I just boot it, open dwm and close it without giving it much use it usually closes fine.
Tried googling a bit to see the usual ways to troubleshoot this but didn't get really far.
This is my /var/log/Xorg.0.log

    [     7.573] 
X.Org X Server 1.14.2
Release Date: 2013-06-25
[     7.573] X Protocol Version 11, Revision 0
[     7.573] Build Operating System: Linux 3.9.7-1-ARCH x86_64 
[     7.574] Current Operating System: Linux arch 3.10.3-1-ARCH #1 SMP PREEMPT Fri Jul 26 11:26:59 CEST 2013 x86_64
[     7.574] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=74e92d67-41b6-4911-8ceb-009ae8c9cdab ro quiet add_efi_memmap i915.i915_enable_rc6=1 pcie_aspm=force drm.vblankoffdelay=1 i915.semaphores=1 "acpi_osi=!Windows 2012"
[     7.574] Build Date: 01 July 2013  10:48:42AM
[     7.574]  
[     7.574] Current version of pixman: 0.30.0
[     7.574] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[     7.574] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     7.574] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Aug 10 19:08:34 2013
[     7.574] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     7.575] (==) No Layout section.  Using the first Screen section.
[     7.575] (==) No screen section available. Using defaults.
[     7.575] (**) |-->Screen "Default Screen Section" (0)
[     7.575] (**) |   |-->Monitor "<default monitor>"
[     7.575] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[     7.575] (==) Automatically adding devices
[     7.575] (==) Automatically enabling devices
[     7.575] (==) Automatically adding GPU devices
[     7.578] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[     7.578] 	Entry deleted from font path.
[     7.578] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[     7.578] 	Entry deleted from font path.
[     7.578] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[     7.578] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[     7.578] 	Entry deleted from font path.
[     7.578] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[     7.578] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/,
	/usr/share/fonts/OTF/
[     7.578] (==) ModulePath set to "/usr/lib/xorg/modules"
[     7.578] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[     7.578] (II) Loader magic: 0x7fdc20
[     7.578] (II) Module ABI versions:
[     7.578] 	X.Org ANSI C Emulation: 0.4
[     7.578] 	X.Org Video Driver: 14.1
[     7.578] 	X.Org XInput driver : 19.1
[     7.578] 	X.Org Server Extension : 7.0
[     7.578] (II) xfree86: Adding drm device (/dev/dri/card1)
[     7.579] (II) xfree86: Adding drm device (/dev/dri/card0)
[     7.580] (--) PCI:*(0:0:2:0) 8086:0166:1043:15a7 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[     7.580] (--) PCI: (0:1:0:0) 10de:0fd1:1043:15a7 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     7.580] Initializing built-in extension Generic Event Extension
[     7.580] Initializing built-in extension SHAPE
[     7.580] Initializing built-in extension MIT-SHM
[     7.580] Initializing built-in extension XInputExtension
[     7.580] Initializing built-in extension XTEST
[     7.580] Initializing built-in extension BIG-REQUESTS
[     7.580] Initializing built-in extension SYNC
[     7.580] Initializing built-in extension XKEYBOARD
[     7.580] Initializing built-in extension XC-MISC
[     7.580] Initializing built-in extension SECURITY
[     7.580] Initializing built-in extension XINERAMA
[     7.580] Initializing built-in extension XFIXES
[     7.580] Initializing built-in extension RENDER
[     7.581] Initializing built-in extension RANDR
[     7.581] Initializing built-in extension COMPOSITE
[     7.581] Initializing built-in extension DAMAGE
[     7.581] Initializing built-in extension MIT-SCREEN-SAVER
[     7.581] Initializing built-in extension DOUBLE-BUFFER
[     7.581] Initializing built-in extension RECORD
[     7.581] Initializing built-in extension DPMS
[     7.581] Initializing built-in extension X-Resource
[     7.581] Initializing built-in extension XVideo
[     7.581] Initializing built-in extension XVideo-MotionCompensation
[     7.582] Initializing built-in extension XFree86-VidModeExtension
[     7.583] Initializing built-in extension XFree86-DGA
[     7.583] Initializing built-in extension XFree86-DRI
[     7.584] Initializing built-in extension DRI2
[     7.584] (II) LoadModule: "glx"
[     7.585] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     7.586] (II) Module glx: vendor="X.Org Foundation"
[     7.586] 	compiled for 1.14.2, module version = 1.0.0
[     7.586] 	ABI class: X.Org Server Extension, version 7.0
[     7.586] (==) AIGLX enabled
[     7.587] Loading extension GLX
[     7.587] (==) Matched intel as autoconfigured driver 0
[     7.587] (==) Matched nouveau as autoconfigured driver 1
[     7.587] (==) Matched nvidia as autoconfigured driver 2
[     7.587] (==) Matched nv as autoconfigured driver 3
[     7.587] (==) Matched intel as autoconfigured driver 4
[     7.587] (==) Matched vesa as autoconfigured driver 5
[     7.587] (==) Matched modesetting as autoconfigured driver 6
[     7.587] (==) Matched fbdev as autoconfigured driver 7
[     7.587] (==) Assigned the driver to the xf86ConfigLayout
[     7.587] (II) LoadModule: "intel"
[     7.588] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     7.592] (II) Module intel: vendor="X.Org Foundation"
[     7.592] 	compiled for 1.14.2, module version = 2.21.12
[     7.592] 	Module class: X.Org Video Driver
[     7.592] 	ABI class: X.Org Video Driver, version 14.1
[     7.592] (II) LoadModule: "nouveau"
[     7.592] (WW) Warning, couldn't open module nouveau
[     7.592] (II) UnloadModule: "nouveau"
[     7.592] (II) Unloading nouveau
[     7.592] (EE) Failed to load module "nouveau" (module does not exist, 0)
[     7.592] (II) LoadModule: "nvidia"
[     7.592] (WW) Warning, couldn't open module nvidia
[     7.592] (II) UnloadModule: "nvidia"
[     7.592] (II) Unloading nvidia
[     7.592] (EE) Failed to load module "nvidia" (module does not exist, 0)
[     7.592] (II) LoadModule: "nv"
[     7.592] (WW) Warning, couldn't open module nv
[     7.592] (II) UnloadModule: "nv"
[     7.592] (II) Unloading nv
[     7.592] (EE) Failed to load module "nv" (module does not exist, 0)
[     7.592] (II) LoadModule: "vesa"
[     7.593] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[     7.593] (II) Module vesa: vendor="X.Org Foundation"
[     7.593] 	compiled for 1.14.0, module version = 2.3.2
[     7.593] 	Module class: X.Org Video Driver
[     7.593] 	ABI class: X.Org Video Driver, version 14.1
[     7.593] (II) LoadModule: "modesetting"
[     7.593] (WW) Warning, couldn't open module modesetting
[     7.593] (II) UnloadModule: "modesetting"
[     7.593] (II) Unloading modesetting
[     7.593] (EE) Failed to load module "modesetting" (module does not exist, 0)
[     7.593] (II) LoadModule: "fbdev"
[     7.593] (WW) Warning, couldn't open module fbdev
[     7.593] (II) UnloadModule: "fbdev"
[     7.593] (II) Unloading fbdev
[     7.593] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     7.593] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
	i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
	4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
	Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
	Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
	Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
	Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
	Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
	Ivybridge Server (GT2), HD Graphics, HD Graphics 4600,
	Haswell Desktop (GT3), HD Graphics, HD Graphics 4600,
	Haswell Mobile (GT3), HD Graphics, HD Graphics P4600/P4700,
	Haswell Server (GT3), Haswell (GT1), Haswell (GT2), Haswell (GT3),
	HD Graphics, Haswell (GT2), Haswell (GT3), Haswell SDV Desktop (GT1),
	Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT3),
	Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
	Haswell SDV Mobile (GT3), Haswell SDV Server (GT1),
	Haswell SDV Server (GT2), Haswell SDV Server (GT3),
	Haswell SDV (GT1), Haswell SDV (GT2), Haswell SDV (GT3),
	Haswell SDV (GT1), Haswell SDV (GT2), Haswell SDV (GT3),
	Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
	Iris(TM) Graphics 5100, HD Graphics, HD Graphics 4400,
	HD Graphics 5000, Haswell ULT Server (GT1), Haswell ULT Server (GT2),
	Iris(TM) Graphics 5100, Haswell ULT (GT1), Haswell ULT (GT2),
	Iris(TM) Graphics 5100, HD Graphics, HD Graphics 4200,
	Iris(TM) Graphics 5100, Haswell CRW Desktop (GT1), HD Graphics 4600,
	Iris(TM) Pro Graphics 5200, Haswell CRW Mobile (GT1),
	HD Graphics 4600, Iris(TM) Pro Graphics 5200,
	Haswell CRW Server (GT1), Haswell CRW Server (GT2),
	Iris(TM) Pro Graphics 5200, Haswell CRW (GT1), Haswell CRW (GT2),
	Iris(TM) Pro Graphics 5200, Haswell CRW (GT1), Haswell CRW (GT2),
	Iris(TM) Pro Graphics 5200, ValleyView PO board
[     7.594] (II) VESA: driver for VESA chipsets: vesa
[     7.594] (++) using VT number 1

[     7.594] (WW) Falling back to old probe method for vesa
[     7.594] (II) intel(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[     7.594] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     7.594] (==) intel(0): RGB weight 888
[     7.594] (==) intel(0): Default visual is TrueColor
[     7.594] (--) intel(0): Integrated Graphics Chipset: Intel(R) Ivybridge Mobile (GT2)
[     7.594] (**) intel(0): Relaxed fencing enabled
[     7.594] (**) intel(0): Wait on SwapBuffers? enabled
[     7.594] (**) intel(0): Triple buffering? enabled
[     7.594] (**) intel(0): Framebuffer tiled
[     7.594] (**) intel(0): Pixmaps tiled
[     7.594] (**) intel(0): 3D buffers tiled
[     7.594] (**) intel(0): SwapBuffers wait enabled
[     7.594] (==) intel(0): video overlay key set to 0x101fe
[     7.594] (II) intel(0): Output eDP1 has no monitor section
[     7.595] (--) intel(0): found backlight control interface /sys/class/backlight/acpi_video1
[     7.596] (II) intel(0): Output VGA1 has no monitor section
[     7.596] (II) intel(0): EDID for output eDP1
[     7.596] (II) intel(0): Manufacturer: LGD  Model: 323  Serial#: 0
[     7.596] (II) intel(0): Year: 2012  Week: 0
[     7.596] (II) intel(0): EDID Version: 1.4
[     7.596] (II) intel(0): Digital Display Input
[     7.596] (II) intel(0): 6 bits per channel
[     7.596] (II) intel(0): Digital interface is DisplayPort
[     7.596] (II) intel(0): Max Image Size [cm]: horiz.: 35  vert.: 19
[     7.596] (II) intel(0): Gamma: 2.20
[     7.596] (II) intel(0): No DPMS capabilities specified
[     7.596] (II) intel(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
[     7.596] (II) intel(0): First detailed timing is preferred mode
[     7.596] (II) intel(0): Preferred mode is native pixel format and refresh rate
[     7.596] (II) intel(0): redX: 0.629 redY: 0.350   greenX: 0.349 greenY: 0.614
[     7.596] (II) intel(0): blueX: 0.154 blueY: 0.112   whiteX: 0.313 whiteY: 0.329
[     7.596] (II) intel(0): Manufacturer's mask: 0
[     7.596] (II) intel(0): Supported detailed timing:
[     7.596] (II) intel(0): clock: 138.0 MHz   Image Size:  345 x 194 mm
[     7.596] (II) intel(0): h_active: 1920  h_sync: 1952  h_sync_end 1988 h_blank_end 2088 h_border: 0
[     7.596] (II) intel(0): v_active: 1080  v_sync: 1085  v_sync_end 1090 v_blanking: 1102 v_border: 0
[     7.596] (II) intel(0):  LG Display
[     7.596] (II) intel(0):  LP156WF4-SPB1
[     7.596] (II) intel(0): EDID (in hex):
[     7.596] (II) intel(0): 	00ffffffffffff0030e4230300000000
[     7.596] (II) intel(0): 	00160104952313780a25b5a159599d27
[     7.596] (II) intel(0): 	1c505400000001010101010101010101
[     7.596] (II) intel(0): 	010101010101e83580a8703816402024
[     7.596] (II) intel(0): 	550059c2100000180000000000000000
[     7.596] (II) intel(0): 	00000000000000000000000000fe004c
[     7.596] (II) intel(0): 	4720446973706c61790a2020000000fe
[     7.596] (II) intel(0): 	004c503135365746342d535042310069
[     7.596] (II) intel(0): Not using default mode "320x240" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "400x300" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "512x384" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "640x480" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "640x512" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "800x600" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "896x672" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "928x696" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "960x720" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "700x525" (doublescan mode not supported)
[     7.597] (II) intel(0): Not using default mode "1024x768" (doublescan mode not supported)
[     7.597] (II) intel(0): Printing probed modes for output eDP1
[     7.597] (II) intel(0): Modeline "1920x1080"x60.0  138.00  1920 1952 1988 2088  1080 1085 1090 1102 -hsync -vsync (66.1 kHz eP)
[     7.597] (II) intel(0): Modeline "1400x1050"x60.0  122.00  1400 1488 1640 1880  1050 1052 1064 1082 +hsync +vsync (64.9 kHz d)
[     7.597] (II) intel(0): Modeline "1280x1024"x60.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz d)
[     7.597] (II) intel(0): Modeline "1280x960"x60.0  108.00  1280 1376 1488 1800  960 961 964 1000 +hsync +vsync (60.0 kHz d)
[     7.597] (II) intel(0): Modeline "1024x768"x60.0   65.00  1024 1048 1184 1344  768 771 777 806 -hsync -vsync (48.4 kHz d)
[     7.597] (II) intel(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
[     7.597] (II) intel(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
[     7.597] (II) intel(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
[     7.598] (II) intel(0): EDID for output VGA1
[     7.598] (II) intel(0): Output eDP1 connected
[     7.598] (II) intel(0): Output VGA1 disconnected
[     7.598] (II) intel(0): Using exact sizes for initial modes
[     7.598] (II) intel(0): Output eDP1 using initial mode 1920x1080
[     7.598] (II) intel(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
[     7.598] (II) intel(0): Kernel page flipping support detected, enabling
[     7.598] (==) intel(0): DPI set to (96, 96)
[     7.598] (II) Loading sub module "fb"
[     7.598] (II) LoadModule: "fb"
[     7.598] (II) Loading /usr/lib/xorg/modules/libfb.so
[     7.599] (II) Module fb: vendor="X.Org Foundation"
[     7.599] 	compiled for 1.14.2, module version = 1.0.0
[     7.599] 	ABI class: X.Org ANSI C Emulation, version 0.4
[     7.599] (II) Loading sub module "dri2"
[     7.599] (II) LoadModule: "dri2"
[     7.599] (II) Module "dri2" already built-in
[     7.599] (II) UnloadModule: "vesa"
[     7.599] (II) Unloading vesa
[     7.599] (==) Depth 24 pixmap format is 32 bpp
[     7.599] (II) intel(0): [DRI2] Setup complete
[     7.599] (II) intel(0): [DRI2]   DRI driver: i965
[     7.599] (II) intel(0): Allocated new frame buffer 1920x1080 stride 7680, tiled
[     7.599] (II) UXA(0): Driver registered support for the following operations:
[     7.599] (II)         solid
[     7.599] (II)         copy
[     7.599] (II)         composite (RENDER acceleration)
[     7.599] (II)         put_image
[     7.599] (II)         get_image
[     7.599] (==) intel(0): Backing store disabled
[     7.599] (==) intel(0): Silken mouse enabled
[     7.600] (II) intel(0): Initializing HW Cursor
[     7.600] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     7.600] (==) intel(0): DPMS enabled
[     7.600] (==) intel(0): Intel XvMC decoder enabled
[     7.600] (II) intel(0): Set up textured video
[     7.600] (II) intel(0): [XvMC] xvmc_vld driver initialized.
[     7.600] (II) intel(0): direct rendering: DRI2 Enabled
[     7.600] (==) intel(0): hotplug detection: "enabled"
[     7.613] (--) RandR disabled
[     7.634] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[     7.634] (II) AIGLX: enabled GLX_INTEL_swap_event
[     7.634] (II) AIGLX: enabled GLX_ARB_create_context
[     7.634] (II) AIGLX: enabled GLX_ARB_create_context_profile
[     7.634] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[     7.634] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[     7.634] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[     7.634] (II) AIGLX: Loaded and initialized i965
[     7.634] (II) GLX: Initialized DRI2 GL provider for screen 0
[     7.634] (II) intel(0): Setting screen physical size to 508 x 285
[     7.669] (II) config/udev: Adding input device Video Bus (/dev/input/event9)
[     7.669] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     7.669] (II) LoadModule: "evdev"
[     7.669] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[     7.670] (II) Module evdev: vendor="X.Org Foundation"
[     7.670] 	compiled for 1.14.2, module version = 2.8.1
[     7.670] 	Module class: X.Org XInput Driver
[     7.670] 	ABI class: X.Org XInput driver, version 19.1
[     7.670] (II) Using input driver 'evdev' for 'Video Bus'
[     7.670] (**) Video Bus: always reports core events
[     7.670] (**) evdev: Video Bus: Device: "/dev/input/event9"
[     7.670] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     7.670] (--) evdev: Video Bus: Found keys
[     7.670] (II) evdev: Video Bus: Configuring as keyboard
[     7.670] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input10/event9"
[     7.670] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 6)
[     7.670] (**) Option "xkb_rules" "evdev"
[     7.670] (**) Option "xkb_model" "pc104"
[     7.670] (**) Option "xkb_layout" "us"
[     7.684] (II) config/udev: Adding input device Video Bus (/dev/input/event8)
[     7.684] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     7.684] (II) Using input driver 'evdev' for 'Video Bus'
[     7.684] (**) Video Bus: always reports core events
[     7.684] (**) evdev: Video Bus: Device: "/dev/input/event8"
[     7.684] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     7.684] (--) evdev: Video Bus: Found keys
[     7.684] (II) evdev: Video Bus: Configuring as keyboard
[     7.684] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:03/LNXVIDEO:00/input/input9/event8"
[     7.684] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[     7.684] (**) Option "xkb_rules" "evdev"
[     7.684] (**) Option "xkb_model" "pc104"
[     7.684] (**) Option "xkb_layout" "us"
[     7.684] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[     7.685] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     7.685] (II) Using input driver 'evdev' for 'Power Button'
[     7.685] (**) Power Button: always reports core events
[     7.685] (**) evdev: Power Button: Device: "/dev/input/event2"
[     7.685] (--) evdev: Power Button: Vendor 0 Product 0x1
[     7.685] (--) evdev: Power Button: Found keys
[     7.685] (II) evdev: Power Button: Configuring as keyboard
[     7.685] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2/event2"
[     7.685] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 8)
[     7.685] (**) Option "xkb_rules" "evdev"
[     7.685] (**) Option "xkb_model" "pc104"
[     7.685] (**) Option "xkb_layout" "us"
[     7.685] (II) config/udev: Adding input device Lid Switch (/dev/input/event1)
[     7.685] (II) No input driver specified, ignoring this device.
[     7.685] (II) This device may have been added with another device file.
[     7.685] (II) config/udev: Adding input device Sleep Button (/dev/input/event3)
[     7.685] (**) Sleep Button: Applying InputClass "evdev keyboard catchall"
[     7.685] (II) Using input driver 'evdev' for 'Sleep Button'
[     7.685] (**) Sleep Button: always reports core events
[     7.685] (**) evdev: Sleep Button: Device: "/dev/input/event3"
[     7.685] (--) evdev: Sleep Button: Vendor 0 Product 0x3
[     7.685] (--) evdev: Sleep Button: Found keys
[     7.685] (II) evdev: Sleep Button: Configuring as keyboard
[     7.685] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input3/event3"
[     7.685] (II) XINPUT: Adding extended input device "Sleep Button" (type: KEYBOARD, id 9)
[     7.685] (**) Option "xkb_rules" "evdev"
[     7.685] (**) Option "xkb_model" "pc104"
[     7.685] (**) Option "xkb_layout" "us"
[     7.685] (II) config/udev: Adding drm device (/dev/dri/card1)
[     7.685] (II) config/udev: Adding drm device (/dev/dri/card0)
[     7.686] (II) config/udev: Adding input device USB2.0 HD UVC WebCam (/dev/input/event6)
[     7.686] (**) USB2.0 HD UVC WebCam: Applying InputClass "evdev keyboard catchall"
[     7.686] (II) Using input driver 'evdev' for 'USB2.0 HD UVC WebCam'
[     7.686] (**) USB2.0 HD UVC WebCam: always reports core events
[     7.686] (**) evdev: USB2.0 HD UVC WebCam: Device: "/dev/input/event6"
[     7.686] (--) evdev: USB2.0 HD UVC WebCam: Vendor 0x4f2 Product 0xb36e
[     7.686] (--) evdev: USB2.0 HD UVC WebCam: Found keys
[     7.686] (II) evdev: USB2.0 HD UVC WebCam: Configuring as keyboard
[     7.686] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.3/3-1.3:1.0/input/input6/event6"
[     7.686] (II) XINPUT: Adding extended input device "USB2.0 HD UVC WebCam" (type: KEYBOARD, id 10)
[     7.686] (**) Option "xkb_rules" "evdev"
[     7.686] (**) Option "xkb_model" "pc104"
[     7.686] (**) Option "xkb_layout" "us"
[     7.686] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event5)
[     7.686] (II) No input driver specified, ignoring this device.
[     7.686] (II) This device may have been added with another device file.
[     7.686] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[     7.686] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[     7.686] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[     7.686] (**) AT Translated Set 2 keyboard: always reports core events
[     7.686] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[     7.686] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[     7.686] (--) evdev: AT Translated Set 2 keyboard: Found keys
[     7.686] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[     7.686] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[     7.686] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 11)
[     7.686] (**) Option "xkb_rules" "evdev"
[     7.686] (**) Option "xkb_model" "pc104"
[     7.686] (**) Option "xkb_layout" "us"
[     7.686] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event7)
[     7.686] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
[     7.686] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     7.687] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[     7.687] (II) LoadModule: "synaptics"
[     7.687] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[     7.687] (II) Module synaptics: vendor="X.Org Foundation"
[     7.687] 	compiled for 1.14.1, module version = 1.7.1
[     7.687] 	Module class: X.Org XInput Driver
[     7.687] 	ABI class: X.Org XInput driver, version 19.1
[     7.687] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[     7.687] (**) ETPS/2 Elantech Touchpad: always reports core events
[     7.687] (**) Option "Device" "/dev/input/event7"
[     7.810] (II) synaptics: ETPS/2 Elantech Touchpad: found clickpad property
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 3260 (res 32)
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 2119 (res 32)
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: buttons: left double triple
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[     7.810] (**) Option "TapButton1" "1"
[     7.810] (**) Option "TapButton2" "2"
[     7.810] (**) Option "TapButton3" "3"
[     7.810] (**) Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
[     7.810] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[     7.810] (**) ETPS/2 Elantech Touchpad: always reports core events
[     7.853] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio4/input/input8/event7"
[     7.853] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 12)
[     7.853] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[     7.853] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MaxSpeed is now 1.75
[     7.853] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) AccelFactor is now 0.051
[     7.853] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[     7.853] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
[     7.853] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[     7.853] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[     7.853] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[     7.853] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse0)
[     7.853] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[     7.853] (II) config/udev: Adding input device PC Speaker (/dev/input/event4)
[     7.853] (II) No input driver specified, ignoring this device.
[     7.853] (II) This device may have been added with another device file.

Found this recent thread in the forums, I'll give REISUB a try late, but the times it freezed I remember trying to blindly reboot it, or switching off virtual console and couldn't.
In case it's of any use, this is my # uname -a

Linux arch 3.10.3-1-ARCH #1 SMP PREEMPT Fri Jul 26 11:26:59 CEST 2013 x86_64 GNU/Linux

Could it have something to do with the nvidia optimus setup that this laptop has? When installing arch I found out that there was no support yet for it so I'm just using the intel drivers (following what the arch wiki said).
Any ideas or advice to point me in the right direction would be very much appreciated.
Thanks in advance.

Last edited by contiver (2013-08-16 20:25:34)

Offline

#2 2013-08-12 19:17:34

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,739
Website

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

Some details about how your start X and dwm would help. Also what does, "if I close dwm or just press the power button to shut down" mean? How do you "close" dwm? And does pressing the power button trigger a systemd poweroff?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2013-08-13 16:48:23

contiver
Member
Registered: 2013-07-31
Posts: 13

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

I use startx to start dwm, my .xinitrc is the following:

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  done
  unset f
fi


# dwm (dynamic window manager) settings

st &

# Set keyboard during X session to US altgr-intl 
setxkbmap -rules evdev -model evdev -layout us -variant altgr-intl &

# Call .fehbg to set wallpaper
sh ~/.fehbg & 

# Set Mod3key to the menu key in the ASUS UX51 laptop to use it in dwm
 ( sleep 1 &&  xmodmap ~/.Xmodmap) &
exec dwm

When I said "close dwm" I meant using the quit function that comes in the dwm config.h file, which by default is [Shift]+[Alt]+[q]. Pressing the power button has the same effect as typing "shutdown now" in a terminal, I suppose that's a systemd poweroff?
Anyway, I haven't got much time to test it lately but it's been behaving better since I recently updated my system using # pacman -Syu , so I'm not sure if it's fixed or the problem will pop-up again eventually. I'll update with a new post if I have any news.

Offline

#4 2013-08-13 18:27:25

skeerly
Member
From: Canada
Registered: 2012-01-14
Posts: 20

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

I and some other people with Intel integrated graphics have the same problem killing X from dwm. See this thread  https://bbs.archlinux.org/viewtopic.php?id=167086 The problem seemed to be related to the suckless terminal (st), but it may be more general. There's no fix that I'm aware of.

Offline

#5 2013-08-14 04:24:53

contiver
Member
Registered: 2013-07-31
Posts: 13

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

Oh, that seems highly probable, since I'm using st too (I even have it opening on start up as you can see in my .xinitrc). I had a freeze again today, so thanks for the heads up, will try using another terminal for some time and see if I still get any freezes. If everything seems fine after some days I'll mark this as solved.
----
Edit: giving it a close read to that thread you posted, tried spawning 2 terminals with the bind I have in my config.h using:

static const char *termcmd[] = { "st", NULL };

Nothing too fancy. Anyway, after I spawned 2 and closed everything worked fine, then I did another startx, opened several more, tried closing again and got the usual freeze. Are you guys able to replicate it 100% every time? or are you sometimes able to spawn an st terminal and quitting without problems?

Last edited by contiver (2013-08-14 04:37:11)

Offline

#6 2013-08-14 15:13:22

skeerly
Member
From: Canada
Registered: 2012-01-14
Posts: 20

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

I don't start st in my .xinitrc. I launch it from dmenu and usually everything is fine. If I launch it from dwm's internal command using Alt-Shf-Return, X freezes 100% of the time. A workaround was suggested by st's main developer to call st like this:

static const char *termcmd[]  = { "/bin/sh", "-c", "st", NULL };

but it didn't work for me.

Very rarely X will freeze anyway. I haven't been able to pin it down. When X fails, my journal returns this:

BUG: unable to handle kernel paging request at ffffc90014ce8000
IP: [<ffffffff812bfe7f>] bitfill_aligned+0x8f/0x140
PGD 7c00b067 PUD 7c018067 PMD 7b3eb067 PTE 0
Oops: 0002 [#1] PREEMPT SMP 
Modules linked in: nls_cp437 vfat fat snd_usb_audio snd_usbmidi_lib snd_hwdep snd_rawmidi snd_seq_device snd_pcm snd_page_alloc snd_timer
CPU: 1 PID: 7520 Comm: X Not tainted 3.10.5-1-ck #1
Hardware name:                  /D410PT, BIOS MOPNV10N.86A.0155.2009.1106.0430 11/06/2009
task: ffff88007aa786b0 ti: ffff8800797ee000 task.ti: ffff8800797ee000
RIP: 0010:[<ffffffff812bfe7f>]  [<ffffffff812bfe7f>] bitfill_aligned+0x8f/0x140
RSP: 0018:ffff8800797efaa8  EFLAGS: 00010212
RAX: 0000000003ffff5c RBX: 0000000000000000 RCX: 0000000000000000
RDX: 0000000003ffff5c RSI: ffffc90014901520 RDI: ffffc90014ce7fe0
RBP: ffff8800797efab8 R08: 00000000ffffd700 R09: 0000000003f83204
R10: 0000000000000000 R11: ffffc90014ce7fd8 R12: ffffffffffffffff
R13: ffffc90014901520 R14: ffffffff812bfdf0 R15: 0000000000000320
FS:  00007fb350033880(0000) GS:ffff88007ea80000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
CR2: ffffc90014ce8000 CR3: 000000007b104000 CR4: 00000000000007e0
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Stack:
  0000000000000000 ffff88007a4d3000 ffff8800797efb28 ffffffff812bfbb9
  ffffffff00000000 ffff88007c00c000 0000000000000000 ffffffff8186f240
  0000000000000000 ffffffff00000006 ffffd700797efb58 ffff88007a4d3000
Call Trace:
  [<ffffffff812bfbb9>] cfb_fillrect+0x1c9/0x400
  [<ffffffff812ba2e5>] bit_clear_margins+0x165/0x190
  [<ffffffff812b3633>] fbcon_clear_margins+0x63/0x90
  [<ffffffff812b7a9f>] fbcon_switch+0x3df/0x570
  [<ffffffff813200bd>] redraw_screen+0x17d/0x240
  [<ffffffff812b6eeb>] fbcon_blank+0x20b/0x2d0
  [<ffffffff81320767>] do_unblank_screen+0xa7/0x1b0
  [<ffffffff813175d1>] vt_ioctl+0x10d1/0x1170
  [<ffffffff8130b407>] tty_ioctl+0x277/0xb90
  [<ffffffff8118fb21>] ? mntput_no_expire+0x41/0x150
  [<ffffffff81183a3e>] do_vfs_ioctl+0x2de/0x4c0
  [<ffffffff8117328e>] ? ____fput+0xe/0x10
  [<ffffffff8107766c>] ? task_work_run+0x9c/0xe0
  [<ffffffff81183ca3>] SyS_ioctl+0x83/0xa0
  [<ffffffff814bab9d>] system_call_fastpath+0x1a/0x1f
Code: 08 45 01 d8 31 d2 44 89 c0 41 f7 f1 83 f8 07 89 c2 76 4f 44 8d 08 48 8d 3e 0f 1f 00 4c 89 17 4c 89 57 08 4c 89 57 10 4c 89 57 18 <4
RIP  [<ffffffff812bfe7f>] bitfill_aligned+0x8f/0x140
 RSP <ffff8800797efaa8>
CR2: ffffc90014ce8000
---[ end trace aff6cb5ad5097aef ]--- 

Offline

#7 2013-08-16 20:25:16

contiver
Member
Registered: 2013-07-31
Posts: 13

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

Since I stopped spawning st terminals with the dwm shortcut I haven't had a problem once. Seems like that was the problem, thanks for the heads up!
Will mark this as solved (although aside from using another terminal or not spawning st with the shortcut, we can only wait for a fix from the develpers I guess).

Offline

#8 2013-11-27 05:30:06

andmars
Member
Registered: 2012-03-13
Posts: 349

Re: [SOLVED] Getting freezes after using dwm for some time and exiting it

Hello,

I was looking into the last few commits of st since 0.4.1 and found that the problem (at least for my system) lies in this commit:

http://git.suckless.org/st/commit/?id=f … 7ab5d0ea69

I've reported this to the suckless mailing list you can read here (read the whole thread):

http://lists.suckless.org/dev/1311/18359.html

Maybe you can try st without this commit and see if it works (it does for me).

Greets
A

Offline

Board footer

Powered by FluxBB