You are not logged in.

#1 2013-08-15 20:47:47

Registered: 2013-05-24
Posts: 17

Conky - Certain monitors seem stuck

I have the XFCE genmon plugin on my panel and am piping Conky's output to it. The MEM and TEMP values change, but CPU and NET don't I've tried opening and closing programs, changing the CPU part to show all my CPU cores, the values are still stuck. I've tried both running it through the genmon plugin and in the terminal and I get the same result.

The command to start Conky:

conky -c /home/christian/.conkyrc-genmon

The .conkyrc file in question:

# ~/.conkyrc-genmon
# conky configuration for genmon plugin

# settings
background no
out_to_console yes
out_to_x no
total_run_times 1
uppercase no
use_spacer none
cpu_avg_samples 2
net_avg_samples 2

# output to console
CPU ${cpu cpu0}%   \
MEM ${memperc}%   \
TEMP ${acpitemp}°C   \
${if_existing /proc/net/route wlp4s0}\
down ${downspeed wlp4s0} up ${upspeed wlp4s0}\
${else}${if_existing /proc/net/route enp5s0f0}\
down ${downspeed enp5s0f0} up ${upspeed enp5s0f0}\

So is this a bug in Conky, or am I missing something in my .conkyrc?

If it helps, the genmon plugin is set to run Conky every second. Having Conky run every hour (3600 seconds) and changing the total_run_times to 3600 doesn't help either.

It appears that this is not a bug in Conky but a deficiency in the genmon applet. So is there any alternative to genmon or should I hack some other way to put Conky on top of the XFCE panel?

Last edited by cardinal-biggles (2013-08-27 20:55:22)


Board footer

Powered by FluxBB