You are not logged in.

#1 2013-08-19 21:03:49

ctown.myth
Member
Registered: 2010-02-10
Posts: 163

[Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Hello everyone,

Just upgaraded to 4.11, and after a couple of minutes, systemd-journald starts taking up a full core/thread. Doing anything after is ridiculously slow, and anything that needs systemd access stalls. So sudo, su and systemctl and journalctl all stall after it starts acting up.

I checked both on my laptop and desktop and both have the same problem; if I let it persist for some time, kwin drops out and I can no longer do any kind of input, mouse or keyboard.

Searching through journalctl after a reboot, I only get this:

sudo journalctl -r | grep systemd-journald
Aug 19 11:12:06 TheCookieBook systemd[1]: systemd-journald.service: main process exited, code=exited, status=1/FAILURE
Aug 19 11:12:06 TheCookieBook systemd[1]: systemd-journald.service holdoff time over, scheduling restart.
Aug 19 11:12:06 TheCookieBook systemd[1]: Unit systemd-journald.service entered failed state.
Aug 19 11:12:06 TheCookieBook systemd-journald[120]: Got invalid event from epoll.

Searching through last boot, all I get is a mess of pulseaudio bluetooth-related errors:

$ journalctl --since=today | tac | sed -n '/-- Reboot --/{n;:r;/-- Reboot --/q;p;n;b r}' | tac
Aug 19 09:57:42 TheCookieBook pulseaudio[1491]: [pulseaudio] bluetooth-util.c: org.bluez.AudioSource.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" wi
th signature "" on interface "org.bluez.AudioSource" doesn't exist
Aug 19 09:57:42 TheCookieBook pulseaudio[1491]: [pulseaudio] bluetooth-util.c: org.bluez.HandsfreeGateway.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetPropertie
s" with signature "" on interface "org.bluez.HandsfreeGateway" doesn't exist
Aug 19 09:57:42 TheCookieBook pulseaudio[1491]: [pulseaudio] bluetooth-util.c: org.bluez.HandsfreeGateway.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetPropertie
s" with signature "" on interface "org.bluez.HandsfreeGateway" doesn't exist

I'm deducing that the pulseaudio errors can't be the one holding my system because the desktop has the same problem, but there's no bluetooth there. I'm still trying to shuffle through the previous boot system log, but I wanted to get an idea of what's going on.

Last edited by ctown.myth (2013-08-19 21:26:52)


AKA MyCookie!

Offline

#2 2013-08-19 21:26:32

ctown.myth
Member
Registered: 2010-02-10
Posts: 163

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

I think I've found it, nepomuk is acting up again. This time nepomukindexer is segfaulting and dumping it's core all over the place and causing a big mess. I'll mark this thread as solved right now, but if it comes back I'll re-open it.


AKA MyCookie!

Offline

#3 2013-08-19 23:12:49

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

I'm having the same issue: systemd-journald using one core at 100%.

journalctl contains many lines like this:

Aug 20 01:03:55 phantom kernel: nepomukindexer[1083]: segfault at 560 ip 00007ff9801876a6 sp 00007fff50fe4f10 error 4 in libQtGui.so.4.8.5[7f
Aug 20 01:03:55 phantom systemd-coredump[1087]: Process 1083 (nepomukindexer) dumped core.
Aug 20 01:03:58 phantom kernel: nepomukindexer[1088]: segfault at 560 ip 00007f1b99ebc6a6 sp 00007fffad0afab0 error 4 in libQtGui.so.4.8.5[7f
Aug 20 01:03:58 phantom systemd-coredump[1092]: Process 1088 (nepomukindexer) dumped core.

Only solution seem so be disabling nepomuk completely?

Last edited by BasT (2013-08-19 23:16:23)

Offline

#4 2013-08-20 01:57:31

ctown.myth
Member
Registered: 2010-02-10
Posts: 163

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Disabling nepomuk indexing should be good enough, I still can't find which is the problem, the file indexer or the email indexer.


AKA MyCookie!

Offline

#5 2013-08-20 02:43:13

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,549
Website

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Same here.
Disabled Nepomuk and problem goes away.

Edit: I do not much  care for Nepomuk but it you want to troubleshoot the issue you may be able to use System Settings > Desktop Search and disable one at a time File Indexer and/or Email Indexer.

Last edited by ralvez (2013-08-20 02:46:27)

Offline

#6 2013-08-20 10:43:09

caligula
Member
Registered: 2013-04-23
Posts: 14

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Same here. Disabled nepomuk, hoping for the best.
Is there a bug report?

Offline

#7 2013-08-20 13:09:50

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 438

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

there is something with your setups, I upgraded to 4.11 and didn't had the issue.


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#8 2013-08-20 21:06:13

ctown.myth
Member
Registered: 2010-02-10
Posts: 163

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Thaodan wrote:

there is something with your setups, I upgraded to 4.11 and didn't had the issue.

You must be doing something special then, because I created a new user, with a complete black /home and the problem still persisted. Was there anything you installed as a opt. dependency for nepomuk that might've been escalated to a required dependency?


AKA MyCookie!

Offline

#9 2013-08-20 23:15:06

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,549
Website

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

I have two systems.
In one (a Dell Optiplex) I had no issue. On the second an ASUS system I do.
It may be related to hardware or CPU or something of that nature... I do not know for sure.
What I'm sure about is that is not related to being "special" wink


R.

Offline

#10 2013-08-20 23:50:51

ctown.myth
Member
Registered: 2010-02-10
Posts: 163

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Are they both the same CPU make, what are the hardware differences between them?

Both my laptop and desktop are Intel make, laptop is an Ivy Bridge and desktop is Sandy Bridge (2500K on a Z68).

EDIT: AMAIGAWD 100th post!

Last edited by ctown.myth (2013-08-20 23:57:43)


AKA MyCookie!

Offline

#11 2013-08-21 00:34:19

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,549
Website

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

The ASUS is:

Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) per core:    1
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Model name:            Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
Stepping:              11
CPU MHz:               1596.000
BogoMIPS:              4812.33
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
NUMA node0 CPU(s):     0-3

The Optiplex is in my other office (20 min away ) so I do not have the data at hand. I'll take a look and post it later.
But I know it is Intel for sure.

The other thing is that the DELL machine is older that this one.

R.

Offline

#12 2013-08-21 08:59:54

johnnik
Member
Registered: 2012-10-31
Posts: 5

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Just to add some more info I have the same problem and the email indexer off, so it seems to be the file indexer. In my case also segfault occurs in libQtGui.so.4.8.5.

I think that disabling nepomuk is not really a solution though. hmm

Offline

#13 2013-08-21 15:49:23

ralvez
Member
From: Canada
Registered: 2005-12-06
Posts: 1,549
Website

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

@johnnik,

If you mean is "not a long term solution" I would agree. In particular if you use nepomuk wink
I do not particularly care for it so I'm fine in that regard.

On the other hand if you mean that it does not fix the problem for you, then there must be something else with your system. It seems to have solved the problem for
everyone else so far.

R.

Last edited by ralvez (2013-08-21 15:50:44)

Offline

#14 2013-08-21 15:54:48

johnnik
Member
Registered: 2012-10-31
Posts: 5

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

@ralvez,

Sorry you are right, not very clear the way I wrote it.

Yes I actually meant not a long term solution. Disabling it solves the problem but since I do use nepomuk I would rather not to.

Thanks anyway smile

Offline

#15 2013-08-21 16:47:50

caligula
Member
Registered: 2013-04-23
Posts: 14

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Did anyone try after today's updates of kdebase and kdepim packages?

Offline

#16 2013-08-21 17:45:08

dreamersbrow
Member
From: Iowa
Registered: 2011-03-27
Posts: 15

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Yes. I tried the updates and the problem persists.

Also, I don't seem to find a bug posted for this.  Has anyone else found one?

Last edited by dreamersbrow (2013-08-21 17:48:57)

Offline

#17 2013-08-21 17:54:04

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

I don't have any PIM installed or any email client for that matter but I nepomukindexer is still bombarding systemd-journal.

Offline

#18 2013-08-21 18:55:21

Thaodan
Member
From: Dortmund, Nordrein-Westfalen
Registered: 2012-04-28
Posts: 438

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

you could try to reset your akonadi db


Linux odin 3.13.1-pf #1 SMP PREEMPT Wed Mar 5 21:47:28 CET 2014 x86_64 GNU/Linux

Offline

#19 2013-08-25 18:56:50

micsnare
Member
Registered: 2013-08-25
Posts: 35

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

hi,

i'm new here, so please don't shoot wink

kmail/nepomuk/akonadi is killing me with its slowness.

how would I go about disabling nepomuk and akonadi?

so far I've done the following steps, without any success:

system-settings > desktop search > disabled file indexing service & email indexer (it says at the top that the desktop search is still active and running although I've unchecked the nepomuk semantik service) how can I fully disable it?

ps -ef |grep nepomuk
theresa   1887  1754  0 20:46 ?        00:00:00 /usr/bin/akonadi_nepomuk_feeder --identifier akonadi_nepomuk_feeder

see it's still active for some reason?!?

the next step was to disable the service in:

system-settings > startup&shutdown > service manager > nepomuk search module UNCHECKED and it says it's not started.

Still displaying Mails in Kmail is terribly slow.
What else needs doing to turn off Nepomuk for good?

thanks in advance,
theresa

Offline

#20 2013-08-26 03:03:53

ctown.myth
Member
Registered: 2010-02-10
Posts: 163

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Uncheck "Enable Nepomuk Semantic Desktop", that should disable nepomuk, again in theory.


AKA MyCookie!

Offline

#21 2013-08-29 06:08:48

sulaweyo
Member
From: Austria
Registered: 2013-07-08
Posts: 15

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Hi,

did anybody already find a solution for this?
I kind of don't want do disable nepomuk and the question remains what causes this. So far, for my system, i could pinpoint it to the file indexer part, mail indexer is working fine.
As soon as i start the file indexer journald takes up one core.

Offline

#22 2013-08-29 11:31:24

BasT
Member
Registered: 2010-08-28
Posts: 78

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Deleting ~/.kde4/share/apps/nepomuk/ fixed the problem for me.

Offline

#23 2013-08-30 20:27:02

MekkaGodzilla
Member
Registered: 2012-01-22
Posts: 9

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

sulaweyo wrote:

Hi,

did anybody already find a solution for this?
I kind of don't want do disable nepomuk and the question remains what causes this. So far, for my system, i could pinpoint it to the file indexer part, mail indexer is working fine.
As soon as i start the file indexer journald takes up one core.

I deleted my ~/.kde4 folder, logged out, and logged back in.
All my KDE config is screwed, but nepomuk is back up and running. Try the solution suggested above for less colateral damage.

Offline

#24 2013-08-31 05:09:43

MekkaGodzilla
Member
Registered: 2012-01-22
Posts: 9

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

Nevermind, nepomuk is back to core dumping again.

Offline

#25 2013-08-31 05:16:21

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: [Solved] systemd-journald 100% usage after upgrade to KDE 4.11

On my system nepomuk isn't running at all. Irrespective of if nepomuk is enabled. Is anyone aware of bug report on KDE bug tracker?

Offline

Board footer

Powered by FluxBB