You are not logged in.

#1 2013-08-20 09:28:25

surrz
Member
Registered: 2013-08-20
Posts: 1

Failed load Kernel Modules | fglrx exec Format Error

Hello

after I started my computer this morning it won't load fglrx anymore.
Yesterday everything worked just fine. But I can still start the xserver without any problem.

systemctl status systemd-modules-load.serivce outputs:

systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static)
   Active: failed (Result: exit-code) since Tue 2013-08-20 10:59:28 CEST; 20min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 113 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)

Aug 20 10:59:28 orz-aa-0 systemd-modules-load[113]: Failed to insert 'fglrx': Exec format error
Aug 20 10:59:28 orz-aa-0 systemd[1]: systemd-modules-load.service: main process exited, code=exited, status=1/FAILURE
Aug 20 10:59:28 orz-aa-0 systemd[1]: Failed to start Load Kernel Modules.
Aug 20 10:59:28 orz-aa-0 systemd[1]: Unit systemd-modules-load.service entered failed state.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

and modprobe fglrx outputs:

modprobe: ERROR: could not insert 'fglrx': Exec format error

Installed are:
catalyst 13.8-1
catalyst-utils 13.8-1
lib32-catalyst-utils 13.8-1
xorg-bdftopcf 1.0.4-1
xorg-font-util 1.3.0-1
xorg-font-utils 7.6-3
xorg-fonts-alias 1.0.3-1
xorg-fonts-encodings 1.0.4-3
xorg-fonts-misc 1.0.1-2
xorg-luit 1.1.1-1
xorg-mkfontdir 1.0.7-1
xorg-mkfontscale 1.1.1-1
xorg-server 1.14.2-2
xorg-server-common 1.14.2-2
xorg-setxkbmap 1.3.0-1
xorg-twm 1.0.7-1
xorg-xauth 1.0.7-1
xorg-xclock 1.0.6-1
xorg-xhost 1.0.6-1
xorg-xinit 1.3.2-3
xorg-xkbcomp 1.2.4-1
xorg-xmodmap 1.0.7-1
xorg-xrdb 1.0.9-2
xorg-xset 1.2.2-2

I'm really a newbie to arch linux and would appreciate any help.
Thanks in advance.

surrz

Last edited by surrz (2013-08-20 10:53:28)

Offline

#2 2013-08-20 15:30:10

yanom
Member
Registered: 2013-06-30
Posts: 36

Re: Failed load Kernel Modules | fglrx exec Format Error

Same here. It's probably that damn kernel upgrade we had yesterday. FGLRX never responds well to that.....

Offline

#3 2013-08-20 15:41:35

dakez
Member
Registered: 2013-08-20
Posts: 1

Re: Failed load Kernel Modules | fglrx exec Format Error

I'm also experiencing this issue. This is a fresh install of Arch as well. Any insight would be appreciated. smile

Offline

#4 2013-08-20 20:56:38

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

Same here. Definitely the kernel update.

Offline

#5 2013-08-21 01:28:17

dz
Member
Registered: 2013-08-21
Posts: 16

Re: Failed load Kernel Modules | fglrx exec Format Error

Same issue since the same time.  catalyst 13.8-3 and X 1.14.2-2.

Offline

#6 2013-08-21 02:17:16

progandy
Member
Registered: 2012-05-17
Posts: 5,047

Re: Failed load Kernel Modules | fglrx exec Format Error

You should try the new 13.8+beta2 (use catalyst-test from the AUR, set _betaver to 2 and change the md5sum)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#7 2013-08-21 04:39:48

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

progandy wrote:

You should try the new 13.8+beta2 (use catalyst-test from the AUR, set _betaver to 2 and change the md5sum)

I am trying to do so, but I don't know how to change the md5sum, so it's giving me an error. Can you tell me how to change it?

Offline

#8 2013-08-21 04:49:23

progandy
Member
Registered: 2012-05-17
Posts: 5,047

Re: Failed load Kernel Modules | fglrx exec Format Error

fiendfan1 wrote:
progandy wrote:

You should try the new 13.8+beta2 (use catalyst-test from the AUR, set _betaver to 2 and change the md5sum)

I am trying to do so, but I don't know how to change the md5sum, so it's giving me an error. Can you tell me how to change it?

Read the wiki wink https://wiki.archlinux.org/index.php/Ma … ew_md5sums (or wait for the update of the precompiled package. The new beta is only 2 days old)

Last edited by progandy (2013-08-21 04:50:34)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#9 2013-08-21 05:04:18

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

progandy wrote:

Read the wiki wink https://wiki.archlinux.org/index.php/Ma … ew_md5sums (or wait for the update of the precompiled package. The new beta is only 2 days old)

I did the whole install and still, same thing happens. I will keep trying to fix it until Vi0l0 updates the package on sunday.

Offline

#10 2013-08-21 05:12:15

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

I grepped /var/log/Xorg.0.log as suggested by the wiki, here's the results:

sudo grep '(EE)' /var/log/Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.890] (EE) fglrx(0): atiddxDriScreenInit failed. Probably kernel module missing or incompatible. 
[fiendfan1@arch ~]$ grep '(WW)' /var/log/Xorg.0.log
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    19.150] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    19.150] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    19.150] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    19.150] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    19.586] (WW) Falling back to old probe method for fglrx
[    19.710] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
[    19.812] (WW) fglrx(0): board is an unknown third party board, chipset is supported
[    19.889] (WW) fglrx(0): Dynamic Surface Resizing cannot be enabled
[    19.890] (WW) fglrx(0): ***********************************************************
[    19.890] (WW) fglrx(0): * DRI initialization failed                               *
[    19.890] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *
[    19.890] (WW) fglrx(0): * 2D and 3D acceleration disabled                         *
[    19.890] (WW) fglrx(0): ***********************************************************
[    19.908] (WW) fglrx(0): Textured Video not supported without DRI enabled.
[    20.014] (WW) fglrx(0): Option "VendorName" is not used
[    20.014] (WW) fglrx(0): Option "ModelName" is not used
[    20.425] (WW) evdev: USB USB Keykoard: ignoring absolute axes.

I don't know what any of this means, anyone have any ideas?

Offline

#11 2013-08-21 08:12:35

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

Turns out I wasn't fully installing the package. Everything is working now.

Here's how I did it:
1. Download catalyst test from the AUR: https://aur.archlinux.org/packages/catalyst-test/
2. Extract the tar.gz you get and open the file called PKGBUILD.
3. Find the place in the file where it says "_betano=1" and change it to "_betano=2"
4. cd to the folder containing the PKGBUILD and run "makepkg -s" from terminal. This will generate a tar.xz file in the same folder as the PKGBUILD
5. in terminal, run "sudo pacman -U catalyst-test-13.8-1-x86_64.pkg.tar.xz" (that was the name of my file)
6. I had to remove/backup a bunch of files, that may have been just me, otherwise, just reboot and it should work.

Offline

#12 2013-08-21 16:03:29

yanom
Member
Registered: 2013-06-30
Posts: 36

Re: Failed load Kernel Modules | fglrx exec Format Error

fiendfan1 wrote:
[    19.890] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *

This is the relevant part. The FGLRX module has not been updated to handle the latest kernel. We just have to sit tight and wait for Vi0l0 to fix it (or use catalyst-test from the AUR, as mentioned above)


I wonder if us AMD proprietary driver users could benefit from using the arch stable kernel instead of the normal? Would these fglrx packages still work on the stable kernel?

Offline

#13 2013-08-21 21:15:20

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

yanom wrote:
fiendfan1 wrote:
[    19.890] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *

This is the relevant part. The FGLRX module has not been updated to handle the latest kernel. We just have to sit tight and wait for Vi0l0 to fix it (or use catalyst-test from the AUR, as mentioned above)


I wonder if us AMD proprietary driver users could benefit from using the arch stable kernel instead of the normal? Would these fglrx packages still work on the stable kernel?

My above post may help you. Otherwise, you can wait for Vi0L0 to update the precompiled packages on saturday. I don't think it's necessary to use the stable kernel, but you could.

Offline

#14 2013-08-21 21:20:35

dz
Member
Registered: 2013-08-21
Posts: 16

Re: Failed load Kernel Modules | fglrx exec Format Error

I'm using Vi0l0's catalyst repository that has 13.8-3 -- isn't that one version higher than the one in AUR?

Offline

#15 2013-08-21 21:51:00

fiendfan1
Member
Registered: 2013-07-18
Posts: 45

Re: Failed load Kernel Modules | fglrx exec Format Error

dz wrote:

I'm using Vi0l0's catalyst repository that has 13.8-3 -- isn't that one version higher than the one in AUR?

The one in the AUR (if you change _betano to 2) is 2 days old, so probably not.

Offline

#16 2013-08-21 23:45:14

dz
Member
Registered: 2013-08-21
Posts: 16

Re: Failed load Kernel Modules | fglrx exec Format Error

fiendfan1 wrote:
dz wrote:

I'm using Vi0l0's catalyst repository that has 13.8-3 -- isn't that one version higher than the one in AUR?

The one in the AUR (if you change _betano to 2) is 2 days old, so probably not.

Bingo, you're totally right.  Switching to catalyst-test fixed it.

Offline

#17 2013-08-22 00:19:34

Zazzman
Member
Registered: 2011-12-26
Posts: 34

Re: Failed load Kernel Modules | fglrx exec Format Error

Please edit the topic to say [Solved], so that others will know that you're good to go!  Or to come here for the solution if they have the same issue.  I've had many a problem solved that way, by searching the forums to find a [SOLVED] topic for my issue!

Everybody's new at some point.  Enjoy the wide open learning experiences ahead!  And congrats on finding a solution.

Last edited by Zazzman (2013-08-22 00:22:11)

Offline

#18 2013-08-22 22:36:26

yanom
Member
Registered: 2013-06-30
Posts: 36

Re: Failed load Kernel Modules | fglrx exec Format Error

Booting into the stable kernel still has this problem.

Anyone know why? The drivers should be able to handle a 3.0.91 kernel!

Offline

#19 2013-08-22 23:24:34

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,163
Website

Re: Failed load Kernel Modules | fglrx exec Format Error

yanom wrote:
fiendfan1 wrote:
[    19.890] (WW) fglrx(0): * kernel module (fglrx.ko) may be missing or incompatible *

This is the relevant part. The FGLRX module has not been updated to handle the latest kernel. We just have to sit tight and wait for Vi0l0 to fix it (or use catalyst-test from the AUR, as mentioned above)

How about running sudo catalyst_build_module all to build the modules for all kernels installed manually? Admittedly, I am holding Catalyst at version 13.6 (because of the RAM leakage of 13.8 and performance drop of 13.7 I have) and running the ck kernel, but I have had no problems by building the modules manually.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

#20 2013-08-25 18:46:17

saalen
Member
Registered: 2012-08-23
Posts: 4
Website

Re: Failed load Kernel Modules | fglrx exec Format Error

I could fix this by replacing catalyst with catalyst-hook.

Offline

#21 2013-08-25 20:05:00

clfarron4
Member
From: London, UK
Registered: 2013-06-28
Posts: 2,163
Website

Re: Failed load Kernel Modules | fglrx exec Format Error

saalen wrote:

I could fix this by replacing catalyst with catalyst-hook.

I second that. Not going to give you the technical reason, but this is actually a sensible suggestion.


Claire is fine.
Problems? I have dysgraphia, so clear and concise please.
My public GPG key for package signing
My x86_64 package repository

Offline

Board footer

Powered by FluxBB