You are not logged in.

#1 2013-08-26 12:36:20

Henne91
Member
Registered: 2013-08-10
Posts: 9

Sane/Cups conflict

Hey!

I am trying to get my Brother DCP-7010L up and running which is connected via USB. When I first set it up with foomatic automatically it was installed in CUPS and I could see it in the Web-Interface and find it with lpinfo. However, it was using the driver for a similar Brother printer and always "froze" while printing. So I installed the original Brother drivers for this printer from AUR (brother-cups-wrapper-laser and brother-lpr-drivers-laser). Since selecting a different driver from the CUPS Web Interface didn't work I removed the printer using the Web Interface.

Now CUPS does not recognize the printer anymore. "Find new printer" or "Add printer" does not show any USB printers and lpinfo doesn't list the printer anymore.

I am not using any DE but only Awesome WM so I would prefer CLI tools or CUPS Web Interface.

I already tried a whole bunch of suggestions but nothing worked. Removing and reinstalling CUPS and all its dependencies including the CUPS configuration files didn't help eiter. Removing the Brother drivers also does not work.

ls -l /dev/usb/

shows correct permissions.

lpinfo -m | grep 7010
foomatic:Brother-DCP-7010-hl1250.ppd Brother DCP-7010 Foomatic/hl1250
foomatic:Brother-DCP-7010-lj4dith.ppd Brother DCP-7010 Foomatic/lj4dith
foomatic:Brother-DCP-7010-ljet4.ppd Brother DCP-7010 Foomatic/ljet4
foomatic:Brother-DCP-7010-ljet4d.ppd Brother DCP-7010 Foomatic/ljet4d
foomatic-db-ppds/Gestetner/PS/Gestetner-C7010_PS.ppd.gz Gestetner C7010 PS
foomatic-db-ppds/NRG/PS/NRG-C7010_PS.ppd.gz NRG C7010 PS
e/cups/model/foomatic-db-ppds/Brother/BR5070DN_GPL.ppd.gz!

lists the foomatic drivers and the Brother drivers (before removing them) as available.

lpinfo -v

just lists network protocols. The printer also appears in

lsusb
Bus 002 Device 007: ID 04f9:0182 Brother Industries, Ltd Composite Device

Nothing that looks helpful in cups' error_log

E [25/Aug/2013:20:15:50 +0200] Returning IPP server-error-internal-error for CUP
S-Add-Modify-Printer (ipp://localhost:631/printers/DCP7010) from localhost
E [26/Aug/2013:13:36:02 +0200] Unable to bind socket for address [v1.::1]:631 - 
Cannot assign requested address.
E [26/Aug/2013:13:37:37 +0200] [cups-driverd] Unable to access "/usr/lib/cups/dr
iver/usb" - No such file or directory
E [26/Aug/2013:13:37:37 +0200] copy_model: empty PPD file
E [26/Aug/2013:13:37:37 +0200] Returning IPP server-error-internal-error for CUP
S-Add-Modify-Printer (ipp://localhost:631/printers/DCP7010) from localhost
E [26/Aug/2013:13:43:41 +0200] Unable to bind socket for address [v1.::1]:631 - 
Cannot assign requested address.
E [26/Aug/2013:13:47:00 +0200] Unable to bind socket for address [v1.::1]:631 - 
Cannot assign requested address.

The message at 13:37 probably is the result of my failed attempt to add the printer via lpadmin.

Please let me know what other information you need.

Thanks
Hendrik

Last edited by Henne91 (2013-09-05 15:44:18)

Offline

#2 2013-08-28 15:24:55

Henne91
Member
Registered: 2013-08-10
Posts: 9

Re: Sane/Cups conflict

When plugging in the printer I am getting the following in my dmesg:

[ 1728.369152] usb 2-1.2: new full-speed USB device number 9 using ehci-pci
[ 1728.460935] usblp 2-1.2:1.0: usblp0: USB Bidirectional printer dev 9 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0182

Offline

#3 2013-08-28 15:49:25

Henne91
Member
Registered: 2013-08-10
Posts: 9

Re: Sane/Cups conflict

Found the solution. It is the exact same problem as in the following thread: https://bbs.archlinux.org/viewtopic.php?id=152590

So, the problem seems to be the following: Installing sane to enable the scanner function of this multifunction device will break permissions for the printer part. You have to adjust permissions and you can print again (I assume scanning will also still work, haven't tested it yet though).

Would you classify this as a bug? Nevertheless, I'll extend the information on the wiki page when I have time to do so.

Offline

#4 2013-09-05 15:48:36

Henne91
Member
Registered: 2013-08-10
Posts: 9

Re: Sane/Cups conflict

So, this problem is actually not solved:

The permissions are reset when unplugging the printer or rebooting. Therefore I have to set them every time I want to print.

What is the best way to fix this problem? It seems like the usb bus doesn't need the "scanner" group, since I can scan as regular user without the scanner group being set. But printing only works when the bus is owned by the "lp" group.

Please help me!
Thanks
Hendrik

Offline

#5 2013-09-05 20:51:54

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 867

Re: Sane/Cups conflict

I would love to see a solution to this issue. I have also had a problem with a Samsung SCX-4500W multifunction printer for a long time - it prints but I can't use the scanner functions in sane.  There may be a udev rule to set the correct permissions I guess - but also I don't know which groups the user should be in so that there are no problems with systemd.  If anyone knows the answer to this set of questions and knows a solution to whether the user should be a member of one or other or none of lp and scanner groups, as well as how to fix the permissions I would appreciate it a great deal.  I did ask on the sane-devel list but did not get to the bottom of this.


Mike C

Offline

#6 2013-09-06 10:00:40

matse
Member
Registered: 2011-04-27
Posts: 287

Re: Sane/Cups conflict

Hi,
you might try this solution which also works for me.

Offline

Board footer

Powered by FluxBB