You are not logged in.

#1 2013-08-27 13:08:14

AleCon
Member
Registered: 2013-06-28
Posts: 7

Xorg hangs on exit

Hi everybody,
I recently picked up the challenge to revive an old LENOVO thinkpad T22 by  installing  ARCH LINUX on it.
I'm definitely a newbie however I manage to do it quite well following the guide.
Unfortunately while I was setting the X Windows I run into some speed-bump.
This is my video chipset:
01:00.0 VGA compatible controller: S3 Graphics Ltd. 86C270-294 [SavageIX-MV] (rev 13)

I installed the xf86-video-savage drive and followed this guide to configure it:

https://wiki.archlinux.org/index.php/Savage

no luck whatsoever .

I then installed vesa and I obtained a working X-session however there is a catch:
the system hangs on exit, I have a blank screen and I need to force shutdown holding down power button.

I tried different way to exit (including  cli options) but none worked.

Can this problem be fixig or is it an inherent incompatibility  of the Vesa driver?
Am I missing something?
Can anyone point me in the right direction?

BTW: this is my first post, hopefully I made myself clear.
Thanks in advance for your suggestion

Offline

#2 2013-08-28 07:09:51

AleCon
Member
Registered: 2013-06-28
Posts: 7

Re: Xorg hangs on exit

More info

I checked the log looking for hint and this is the output
ERRORS

[    34.022] (EE) Failed to load module "savage" (module does not exist, 0)
[    34.032] (EE) Failed to load module "modesetting" (module does not exist, 0)
[    34.032] (EE) Failed to load /usr/lib/xorg/modules/drivers/fbdev_drv.so: /usr/lib/xorg/modules/drivers/fbdev_drv.so: file too short
[    34.032] (EE) Failed to load module "fbdev" (loader failed, 7)

WARNINGS

 [    33.868] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    33.868] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    33.869] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    33.869] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    34.022] (WW) Warning, couldn't open module savage
[    34.032] (WW) Warning, couldn't open module modesetting
[    34.192] (WW) VESA(0): Unable to estimate virtual size
[    34.193] (WW) VESA(0): No valid modes left. Trying less strict filter...
[    34.193] (WW) VESA(0): Unable to estimate virtual size

Offline

#3 2013-08-28 13:03:57

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Xorg hangs on exit

I have never used that hardware before.  But if you want to have a way of shutting down more cleanly on freezes, check out the Magic Sysrq key.  It is somewhere on our wiki, but you can find info about it all over the place.

You will have to turn it on though, by changing a setting in sysctl.conf.  The wiki will tell you what to do.

Offline

#4 2013-08-28 17:53:37

AleCon
Member
Registered: 2013-06-28
Posts: 7

Re: Xorg hangs on exit

Hi,
thanks so much for your reccommandation, I enabled Sysrq key and now I can avoid brute force shutdown and shut down with Alt-SysRq-o

This is definitely a good improvement
(as a side note: using Alt-SysRq-e give me the same locked up system as before..)

Ideally it would be nice to be able to go back to console login (as I'm using startx to initiate Xsession), however this will do for the time being
Thanks again

Offline

#5 2013-08-28 20:31:29

brebs
Member
Registered: 2007-04-03
Posts: 3,427

Re: Xorg hangs on exit

AleCon wrote:

the system hangs on exit

There's a patch for Nvidia - seems to be generic, might help your graphics card too.

Offline

#6 2013-08-29 11:40:27

AleCon
Member
Registered: 2013-06-28
Posts: 7

Re: Xorg hangs on exit

Thanks for this suggestion brebs
It seems well beyond my IT skill, but clearly I'm here (also) to learn!
I'll be needing a thorough read and if I can make sense of it I'll give it a go.

Offline

Board footer

Powered by FluxBB