You are not logged in.

#1 2013-08-29 11:33:12

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

F2FS Installation: small Problem

Hi there!

I've installed Arch on the new f2fs-filesystem (I was curious) and it runs well so far. But there's one thing I was wondering about: when creating the fstab, the following options for f2fs where set automatically:

acl,active_logs=6,background_gc_on,user_xattr

With my /, everything is fine when booting. But for the /home partition, the default options aren't working. I get this error message:

F2FS-fs (sda7): Unrecognized mount option "acl" or missing value

and I'm on the rescue shell. The same message appears with the options "background_gc_on" and "user_xattr". After removing those options, Arch boots up.


This problem only occours with the /home partition, on / the same option doesn't make any problems?


Does anyone has a clue about this?

Last edited by Thorsten Reinbold (2013-08-29 12:41:23)

Offline

#2 2013-08-29 13:07:18

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 684

Re: F2FS Installation: small Problem

This manual on mijmwired.net #mount options, suggest that these, acl,background_gc_on,user_xattr are automatically set.
So removing them makes sense, since they are enabled by default, only 'active_logs=6' should be enabled, I guess that's what I make out of reading it.


-Not all ladders are to be climbed on-

Offline

#3 2013-08-29 13:32:38

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,778

Re: F2FS Installation: small Problem

The only thing I can think of is to make sure your fstab is formatted correctly. As I understand fstab-gen (or whatever it's called) your /home was mounted with those options when it was run.

When you remove the options and boot successfully, look at the output of mount regarding the / and /home partitions. Mount options should be idenitcal.


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#4 2013-08-29 13:33:29

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

Re: F2FS Installation: small Problem

Thanks for the link, documentations seem to be a bit rare at this time. What I don't understand: when the options are enabled by default and my / boots up with them without problems, why the same options are making problems with /home? I'm a bit confused about this.

Offline

#5 2013-08-29 13:40:53

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

Re: F2FS Installation: small Problem

alphaniner wrote:

The only thing I can think of is to make sure your fstab is formatted correctly. As I understand fstab-gen (or whatever it's called) your /home was mounted with those options when it was run.

When you remove the options and boot successfully, look at the output of mount regarding the / and /home partitions. Mount options should be idenitcal.

You're right:

fstab:

# /etc/fstab: static file system information
#
# <file system>	<dir>	<type>	<options>	<dump>	<pass>
# UUID=557f06ff-09ad-43b2-87c1-517a3c93b17d
/dev/sda6           	/         	f2fs      	rw,noatime,nodiratime,acl,active_logs=6,background_gc_on,user_xattr	0 0

# UUID=6d632ccb-443d-44e4-827a-9ce1bc65dc18
/dev/sda3           	/boot     	ext2      	rw	0 2

# UUID=1dd0ce88-45a3-4b20-9cc2-aca041209612
/dev/sda7           	/home     	f2fs      	rw,noatime,nodiratime,active_logs=6	0 0

# UUID=f8a22843-f438-4fe8-b2a6-20433387c98f
/dev/sda5           	none      	swap      	defaults  	0 0

mount output:

/dev/sda6 on / type f2fs (rw,noatime,nodiratime,background_gc_on,user_xattr,acl,active_logs=6)
/dev/sda3 on /boot type ext2 (rw)
/dev/sda7 on /home type f2fs (rw,noatime,nodiratime,background_gc_on,user_xattr,acl,active_logs=6)

Does that mean the default options are set beside the fstab?

Offline

#6 2013-08-29 14:00:43

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 684

Re: F2FS Installation: small Problem

Yes, defaults should be enabled automatically, so you don't need to worry about therm.
That doesn't answer why they are added to fstab, and you need to remove them, though.


-Not all ladders are to be climbed on-

Offline

#7 2013-08-29 14:08:29

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,778

Re: F2FS Installation: small Problem

Thorsten Reinbold wrote:

Does that mean the default options are set beside the fstab?

Yes. Don't take this the wrong way, but that's what 'default options' means. When you mounted it during installation - presumably just with mount /dev/sda7 /mnt/home or similar - it was mounted with all those options. I think the fstab generator just gets the same info you see when you run mount to determine what to put in the fstab line.


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#8 2013-08-29 16:10:31

Thorsten Reinbold
Member
From: Germany
Registered: 2011-12-06
Posts: 314

Re: F2FS Installation: small Problem

Ah, ok. Thanks for the info. Only to be sure: that means when I want to change the default options, I'll have to turn them off/change them explicitly, otherwise they are set. I guess the defaults are hardcoded within the mkfs command or the kernel driver?

Last edited by Thorsten Reinbold (2013-08-29 16:10:54)

Offline

#9 2013-08-29 16:15:56

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,778

Re: F2FS Installation: small Problem

Thorsten Reinbold wrote:

Only to be sure: that means when I want to change the default options, I'll have to turn them off/change them explicitly, otherwise they are set.

You got it. I don't know where the defaults are coded though.


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Offline

#10 2013-11-20 12:46:32

na5m
Member
From: Rancho Cordova, CA
Registered: 2008-11-19
Posts: 30

Re: F2FS Installation: small Problem

***drunkenly chimes in :-D***

Had the same problem. My /boot is ext2 and my / is f2fs
I could boot into my system with f2fs as my root with no ultimate prob,
but I'd still get (a seemingly innocuous) logon error message.
The (drunken) cure: I eliminated "acl" and "user_xattr" from fstab

Their absence from my fstab is far less important to me right now
than is having an error-message-free boot ha!  ;-)


Let's go check out Hades!

Offline

#11 2013-11-20 13:34:30

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 684

Re: F2FS Installation: small Problem

alphaniner wrote:
Thorsten Reinbold wrote:

Only to be sure: that means when I want to change the default options, I'll have to turn them off/change them explicitly, otherwise they are set.

You got it. I don't know where the defaults are coded though.

Didn't see this until today.
You can change default options in 'etc/mke2fs.conf'
quote from wiki Tip: See the mkfs.ext4 man page for more options; edit /etc/mke2fs.conf to view/configure default options.


-Not all ladders are to be climbed on-

Offline

Board footer

Powered by FluxBB