You are not logged in.

#1 2013-08-29 18:56:33

lspci
Member
From: Virginia, USA
Registered: 2012-06-09
Posts: 242

[Solved] pkgfile fails to update

A while back I accidentally deleted all of the files in /var/cache/pkgfile, and ever since then pkgfile hasn't work right.  I can't get it to update successfully; it always exits non-zero.   Here's the error message that I keep getting: 

*** Error in `pkgfile': corrupted double-linked list: 0x00000000018fe060 ***

I already searched both the forums and Google, but I didn't find anything applicable on either of them.  I also checked the Wiki and the bug-reports for pkgfile, but didn't find anything on either. 

I've also tried uninstalling and reinstalling pkgfile, but that didn't seem to have any affect. 

Is anyone else having similar problems?

Last edited by lspci (2013-08-30 22:01:12)


Please don't be a help vampire. | Bitbucket

Give a little more for a little less today.  smile

Offline

#2 2013-08-29 21:23:25

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: [Solved] pkgfile fails to update

Did you follow the instructions in pacman's output when you reinstalled pkgfile?


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#3 2013-08-29 21:31:40

lspci
Member
From: Virginia, USA
Registered: 2012-06-09
Posts: 242

Re: [Solved] pkgfile fails to update

cfr wrote:

Did you follow the instructions in pacman's output when you reinstalled pkgfile?


The only instructions are to run pkgfile --update, which doesn't work because of the error that I've already mentioned--I'm running pkgfile as root/using sudo.  So, yes.

Last edited by lspci (2013-08-29 21:33:18)


Please don't be a help vampire. | Bitbucket

Give a little more for a little less today.  smile

Offline

#4 2013-08-29 21:42:32

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: [Solved] pkgfile fails to update

If you use pacsripts pkgfile you will see this:

pacscripts pkgfile wrote:

post_upgrade() {
  if [ "$(vercmp 5 "$2")" -eq 1 ]; then
    printf "==> DB format has changed. Please run pkgfile -uu\n"
  fi
}

The man page also covers this.  So try running with either '--update --update' or with '-uu' to force it.

Offline

#5 2013-08-29 22:02:57

lspci
Member
From: Virginia, USA
Registered: 2012-06-09
Posts: 242

Re: [Solved] pkgfile fails to update

WonderWoofy wrote:

If you use pacsripts pkgfile you will see this:

pacscripts pkgfile wrote:

post_upgrade() {
  if [ "$(vercmp 5 "$2")" -eq 1 ]; then
    printf "==> DB format has changed. Please run pkgfile -uu\n"
  fi
}

The man page also covers this.  So try running with either '--update --update' or with '-uu' to force it.

Doesn't help--pkgfile still locks up with the same error and when I interrupt it with Ctrl-C it returns an exit code of 130; also the man page--or at least the version of the man page that I have--doesn't include anything about the database format changing.

If it matters, which it may, pkgfile always crashes--or whatever you want to call it--as the last repo's package-files are downloaded or after the last repo's files have been downloaded. 

Here's what I get from pkgfile after running the following: 

sudo rm -rf /var/cache/pkgfile ; sudo pacman -S pkgfile

and then running sudo pkgfile -uu

:: Updating 11 repos...
warning: download failed: http://www.xsounds.org/~archstudio/x86_64/archstudio.files [HTTP 404]
error: failed to update repo: archstudio
  download complete: xyne-x86_64          [    37.7 KiB   105K/s  9 remaining]
warning: download failed: http://repo.mate-desktop.org/archlinux/x86_64/mate.files [HTTP 404]
error: failed to update repo: mate
warning: download failed: http://repo.herecura.be/herecura-stable/x86_64/herecura-stable.files [HTTP 404]
error: failed to update repo: herecura-stable
  download complete: haskell-core         [   240.0 KiB   424K/s  6 remaining]
  download complete: city                 [    28.0 KiB  48.6K/s  5 remaining]
  download complete: multilib             [   196.9 KiB  91.3K/s  4 remaining]
  download complete: core                 [   507.6 KiB   223K/s  3 remaining]
  download complete: arch-fonts           [   156.7 KiB  66.8K/s  2 remaining]
  download complete: extra                [     5.7 MiB   197K/s  1 remaining]
  download complete: community            [     7.5 MiB   175K/s  0 remaining]
*** Error in `pkgfile': corrupted double-linked list: 0x00000000018befd0 ***

Last edited by lspci (2013-08-29 22:12:39)


Please don't be a help vampire. | Bitbucket

Give a little more for a little less today.  smile

Offline

#6 2013-08-30 02:39:55

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 7,127

Re: [Solved] pkgfile fails to update

Try removing all non-official repos from pacman's conf and then see if it works. If so, add the other repos back one at a time to see if any of them are the problem.


CLI Paste | How To Ask Questions

Arch Linux | x86_64 | GPT | EFI boot | refind | stub loader | systemd | LVM2 on LUKS
Lenovo x270 | Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz | Intel Wireless 8265/8275 | US keyboard w/ Euro | 512G NVMe INTEL SSDPEKKF512G7L

Offline

#7 2013-08-30 03:19:43

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,414

Re: [Solved] pkgfile fails to update

Before doing that, it might be a good idea to try to eliminate any other variables as well.  So I would uninstall pkgfile, remove /var/cache/pkgfile and its contents, then reinstall pkgfile and try to update only the official repos.

Offline

#8 2013-08-30 15:32:01

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 10,642

Re: [Solved] pkgfile fails to update

I had the same error, and decided to see if adding a .files DB to my local repo would solve this.

repo-add -f ./LoneVVolf.files.tar.gz ./*pkg*

created the .files DB, after that pkgfile updated without an error.

So it seems pkgfile update now errors out when there are repos without a .files db .

Does seem like  a bug in pkgfile, but atleast there's a workaround.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Offline

#9 2013-08-30 22:00:00

lspci
Member
From: Virginia, USA
Registered: 2012-06-09
Posts: 242

Re: [Solved] pkgfile fails to update

Lone_Wolf wrote:

I had the same error, and decided to see if adding a .files DB to my local repo would solve this.

repo-add -f ./LoneVVolf.files.tar.gz ./*pkg*

created the .files DB, after that pkgfile updated without an error.

So it seems pkgfile update now errors out when there are repos without a .files db .

Does seem like  a bug in pkgfile, but atleast there's a workaround.

I don't have local repos anymore, I got rid of them after I realized that having AUR pkgs in a local repo can prevent the AUR pkg from ever being updated--I admit that this may no longer be an issue, but since I don't actually know, I'm just going to leave it at that.


Please don't be a help vampire. | Bitbucket

Give a little more for a little less today.  smile

Offline

#10 2013-08-30 22:00:58

lspci
Member
From: Virginia, USA
Registered: 2012-06-09
Posts: 242

Re: [Solved] pkgfile fails to update

cfr wrote:

Try removing all non-official repos from pacman's conf and then see if it works. If so, add the other repos back one at a time to see if any of them are the problem.


Thanks, that fixed it, which leads me to suspect that one of the repos hasn't updated to the new .files format, maybe?  Anyway, now I need to figure out which repo it was so that I can add the other ones back again.  Thanks for the help.


Please don't be a help vampire. | Bitbucket

Give a little more for a little less today.  smile

Offline

Board footer

Powered by FluxBB