You are not logged in.

#1 2005-12-05 23:53:19

vladuz976
Member
From: Venice, CA
Registered: 2005-11-04
Posts: 108

grub and mkinitrd doesn't work

hi,
i compiled a new kernel from source because i wanted a kernel for k7 and without smp for my system.  everything went fine building it but when i edit grub to boot the new kernel it gives errors.

# (0) Linux-2.6.14-ck6
title Arch-2.6.14-ck6 [/boot/vmlinuz-2.6.14-ck6]
root   (hd0,0)
kernel /vmlinuz-2.6.14-ck6 root=/dev/hda3 ro vga=792

# (1) Arch Linux
title  Arch Linux  [/boot/vmlinuz26]
root   (hd0,0)
kernel /vmlinuz26 root=/dev/hda3 ro vga=792

also mkinitrd doesn't work.

mkinitrd /boot/initrd-2.6.14-ck6.img 2.6.14-ck6

it keeps giving me output that i need to use some options.
the only thing that works is

mkinitrd full

and

mkinitrd auto

i don't exactly know what they do, but without booting into the new kernel those are useless anyway.
can someone help me out?

Offline

#2 2005-12-06 01:36:02

rayjgu3
Member
From: Chicago IL usa
Registered: 2004-07-04
Posts: 692

Re: grub and mkinitrd doesn't work

well if your kernel line is what you say it is i think you need to put /boot/  in there
unless your kernel really is in /
thats all i see , although i dont use grub alot so i may be wrong

Offline

#3 2005-12-06 02:15:51

vladuz976
Member
From: Venice, CA
Registered: 2005-11-04
Posts: 108

Re: grub and mkinitrd doesn't work

rayjgu3 wrote:

well if your kernel line is what you say it is i think you need to put /boot/  in there
unless your kernel really is in /
thats all i see , although i dont use grub alot so i may be wrong

yeah you're right that's odd. but the other kernel works that way, too even though vmlinuz is actually in /boot
i dont' maybe that is just how grub works

Offline

#4 2005-12-06 02:21:52

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: grub and mkinitrd doesn't work

vladuz976 wrote:

also mkinitrd doesn't work.

mkinitrd /boot/initrd-2.6.14-ck6.img 2.6.14-ck6

it keeps giving me output that i need to use some options.

It's giving you output that you need to use some options because you need to use some options.

Let's take a look at the output:

/sbin/mkinitrd <kernel_version> [options]

  Where <kernel_version> is one of:
    auto                        build for the installed Arch kernel
    full                        build with all possible modules
    kernel_version={version}    use kernel version (no autodetect)

  Options:
    --ide                       exclude ide modules
    --scsi                      exclude scsi modules
    --usb                       exclude usb modules
    --cdrom                     exclude cdrom modules
    --fw                        exclude firewire modules
    --raid                      exclude raid modules
    --dm                        exclude device mapper modules
    --remove-module={module}    exclude module
    --add-module={module}       add module
    --root-device={device}      skip auto detection of the root device
    --show                      show modules that are included in initrd

Your line (mkinitrd /boot/initrd-2.6.14-ck6.img 2.6.14-ck6) doesn't match anything listed there.  It's giving you that output because it's wrong.

mkinitrd --kernel-version=2.6.14-ck6

Offline

#5 2005-12-06 02:40:11

vladuz976
Member
From: Venice, CA
Registered: 2005-11-04
Posts: 108

Re: grub and mkinitrd doesn't work

so it should read:

/sbin/mkinitrd kernel_version=2.6.14-ck6-ARCH

when i have this:

[vladuz976@box ~]$ ls /lib/modules/
2.6.13-ARCH   2.6.14-ck6-ARCH

is that correct?

Offline

#6 2005-12-06 02:46:16

phrakture
Arch Overlord
From: behind you
Registered: 2003-10-29
Posts: 7,879
Website

Re: grub and mkinitrd doesn't work

vladuz976 wrote:

so it should read:

/sbin/mkinitrd kernel_version=2.6.14-ck6-ARCH

Ah, I put the "--" in there by habit.  Yes, that should work.

Offline

Board footer

Powered by FluxBB