You are not logged in.

#1 2013-09-09 10:49:30

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Intel Disable turbo mode ?[SOLVED]

I am using the 3.10 kernel with the boost support.

But i dont want it to be on because I am on a laptop with Intel(R) Core(TM) i5-2415M CPU @ 2.30GHz

I disable the intel_pstate in the kernel, and added the acpi freq governor as default, I choosed the conservative governor, but even if my frequency is low on idle, the turbo mode is still enabled.

I want to disable it to cool down my cpu is it possible ?

I use laptop_mode, and the output of cpupower --frequency-info is :

driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 800 MHz - 2.30 GHz
  available frequency steps: 2.30 GHz, 2.30 GHz, 2.20 GHz, 2.10 GHz, 2.00 GHz, 1.90 GHz, 1.80 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz, 1.10 GHz, 1000 MHz, 900 MHz, 800 MHz
  available cpufreq governors: ondemand, conservative, performance
  current policy: frequency should be within 800 MHz and 2.30 GHz.
                  The governor "conservative" may decide which speed to use
                  within this range.
  current CPU frequency is 800 MHz.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores


cpufreq in installed as built in the kernel not as a module, I hope it s not problematic to disable the boost mode.

EDIT : additionnal infos

I have tried this :

sudo wrmsr -p 2 0x1a0 0x4000850089

But it says no such files or directory, Is the 2 a correct option ? What do modifiy to make it work ?
Anyway what is weird is my cpu frequency without boost is 2.3ghz and the hardware limite are fixed at 2.3ghz(without boost) but it says boost activated.

Second question, I know that the conservative governor scale to different frequency at 75% load, it also scall gradually not to over heat the processors.
The powersave governor scal to different frequency at 95 pourcent load, but it doesnt scale gradually as far as i understood but go straight to the maximum frequency.

I want my conservative governor to scall frequency at 95 percents load not 75 percents

howto do it ??

thanks for your help

Last edited by maxarsys (2013-09-15 10:48:06)

Offline

#2 2013-09-09 17:11:15

Signum
Member
Registered: 2013-05-19
Posts: 10

Re: Intel Disable turbo mode ?[SOLVED]

Hi maxarsys

I think the better way for you is with intel_pstated enabled and using this command:

echo -n 1 > /sys/devices/system/cpu/intel_pstate/no_turbo

Should work with that. Also you can limit your frequencies with intel_pstate and, is not recomended at all to use the old governors for a newer cpu; personally I use the intel_pstate and is better than the old way.

Last edited by Signum (2013-09-09 17:11:34)


English is not my native language. So please, tell me if I am writing it wrong.

Offline

#3 2013-09-09 18:23:07

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Re: Intel Disable turbo mode ?[SOLVED]

I rebooted with the precompiled kernel with pstate, did what you wrote, but cpupower shows still the max frequency at 2.9ghz and not 2.3ghz.

I alse tried wrmsr -pi 0x1a0 0x4000850089 but it says no such files or directory.

i rebooted, but still 2.9ghz and turbo mode enable in cpupower.

Are you sure it s bad to use old governor ? because my cpu with the old governor conservative never goes higher than 80 degrees, it s bit slower but I dont mind at all, i rather keep the cpu cool.

Is it because the old governors have more frequency steps, and it s bad for the newer cpu ?

Because I dont see anystep in cpupower frequency-infos when I use it under pstate:

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 2.90 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 2.90 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores

You can compare with my first post

Also, under pstate and after  i did what you said, my cpu goes 20 degrees higher and throttle sometimes. While I never throttle with the conservative governor.

I believe the pstate is more for desktop computer than laptop no ?

Offline

#4 2013-09-09 18:25:11

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Re: Intel Disable turbo mode ?[SOLVED]

I rebooted with the precompiled kernel with pstate, did what you wrote, but cpupower shows still the max frequency at 2.9ghz and not 2.3ghz.

I alse tried wrmsr -pi 0x1a0 0x4000850089 but it says no such files or directory.

i rebooted, but still 2.9ghz and turbo mode enable in cpupower.

Are you sure it s bad to use old governor ? because my cpu with the old governor conservative never goes higher than 80 degrees, it s bit slower but I dont mind at all, i rather keep the cpu cool.

Is it because the old governors have more frequency steps, and it s bad for the newer cpu ?

Because I dont see anystep in cpupower frequency-infos when I use it under pstate:

analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 0.97 ms.
  hardware limits: 800 MHz - 2.90 GHz
  available cpufreq governors: performance, powersave
  current policy: frequency should be within 800 MHz and 2.90 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  boost state support:
    Supported: yes
    Active: yes
    25500 MHz max turbo 4 active cores
    25500 MHz max turbo 3 active cores
    25500 MHz max turbo 2 active cores
    25500 MHz max turbo 1 active cores

You can compare with my first post

Also, under pstate and after  i did what you said, my cpu goes 20 degrees higher and throttle sometimes. While I never throttle with the conservative governor.

I believe the pstate is more for desktop computer than laptop no ?

Offline

#5 2013-09-09 19:15:29

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Disable turbo mode ?[SOLVED]

The intel pstate drive is far more advanced and appropriate for new processors than the old method of acpi_cpufreq.  Also using the conservative governor is not really meant to be used with modern processors either, and actually ends up being slower and much more inefficient than even using ondemand.

But if you really want to disable it you can use intel_pstate=disable on the kernel command line.  Alternatively, you might want to try using intels thermal daemon, which uses a number of kernel features to better regulate thermal output.  It is available from the AUR as the thermald package.  It works great for me.

Offline

#6 2013-09-09 19:35:12

Signum
Member
Registered: 2013-05-19
Posts: 10

Re: Intel Disable turbo mode ?[SOLVED]

I alse tried wrmsr -pi 0x1a0 0x4000850089 but it says no such files or directory.

I've never use that command before, but seems to need an specific direction for your CPU model, and maybe the proble is that  0x1a0 0x4000850089 is not the right direction.

Are you sure it s bad to use old governor ?

I'm not saying it's bad, is just not efficient for your CPU, but you can still using it. (the algoritm seems too old for the newer arquitecture, or that's what they say) - See these links: http://www.phoronix.com/scan.php?page=n … px=MTM3NTI and https://plus.google.com/117091380454742 … vEekAsG2QT

Is it because the old governors have more frequency steps, and it s bad for the newer cpu ?

The newer pstate uses the real hardware limit.


So, the new pstate should work well for your CPU, in my case (i5-3210M and 3.10.11-1-ck-sandybridge) it works fine, but is not your case. I think you can try to use these places for limit your CPU:

/sys/devices/system/cpu/intel_pstate/max_perf_pct - 100 means no limit
/sys/devices/system/cpu/intel_pstate/min_perf_pct

The turbo mode is enabled automatically when the CPU or some core is runing at 100% (that's the theory at least), so, you can try to limit the max value at 99 or a little bit less and test again. (In fact, that's the easy way to disable the turbo in windows tongue)

I'm a little worried about your temps, they are a little bit highs, that's why your CPU is throttled sometimes, but that behavior is not normal at all, do you have a Nvidia? if yes, try to power off with bbswitch.


English is not my native language. So please, tell me if I am writing it wrong.

Offline

#7 2013-09-09 20:35:25

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Re: Intel Disable turbo mode ?[SOLVED]

No I have A single intel hd 3000 on 13" macbook pro.

My temps are 50 idle with the old acpi driver.

They are 60-65 with the pstate driver, the thing is on macos X with my processor version there is no turbo mode. It is the i5-2415M. I even looked at the spec on apple products for this processors particulary and in boost mode frequency they said NA, while other newer macbook pro have specs for the frequency of their turbo mode.

Maybe the driver pstate uses my i5-2415M with wrong parameters.

Anyway, I m not looking for performance but to avoid what often happened on macbook pro, the cpus burn (happens on macbook pro).

I think I should clean the inside of the Mac, But I still think it s due to the fact that this macbook pro cannot handle the heat that produce the cpus on frequencies higher than 2.3Ghz.

I have noticed that with the pstate driver, the simple use of xcompmgr makes the processors heating up while I move windows, it s because the driver set to fast the frequency to high while I only need 1ghz for a fluent desktop use.

Thats why the conservative mode is more efficient with the heat and the battery because the frequency step is set only on 80 percents cpu usage of the current cpu scale.

But my question was at the begining to know how to delay the "next frequency step". In order to gain on battery life and cooldown the heat even more.

I know it s possible but I dont really find docu about

I have read many post relating heat issue with the intel pstate driver, and the advise for laptops was to remove intel_pstate from the kernel code.

Last edited by maxarsys (2013-09-09 20:54:17)

Offline

#8 2013-09-12 05:22:37

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Re: Intel Disable turbo mode ?[SOLVED]

bump

I followed  your advise WonderWoofy and Signum to go for the intel_pstate, however I am having trouble to set for ever the max cpu freq and the no turbo mode.

Every time i reboot Its back to defaut.

I suspect the governors( I have powersave or performance), powersave is enabled by defaut.

I dont want to use a script to execute the command I need at every boot, I want to understand why it doesnt save my configuration.

I found a way to tune the ondemand governor on the wiki ( but i dont have the ondemand), I am about to compil the 3.11 kernel wich has maybe a bette intel_pstate driver, but I need to know if I have some stuff to tweak, like the userspace governor (wich I dont know how to activate with the intel_pstate)

i had a look a the wiki regarding about cpu frequency scaling and the new intel_pstate but the command they give doesnt save after the reboot.

I need your help to change that, and if you have some docs to tweak the powersave governor( from the new intel_pstate) let me know.

Last edited by maxarsys (2013-09-12 05:34:58)

Offline

#9 2013-09-12 05:40:00

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Disable turbo mode ?[SOLVED]

You are going to have to either write a udev rule to set it how you want it, or use tmpfiles.d (probably not ideal), or simply script it out and have it run on boot (pretty hacky).

Offline

#10 2013-09-12 15:12:57

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Re: Intel Disable turbo mode ?[SOLVED]

Ok so if I understood its recommended to use udev, I started to give a look at the huge documentation, but gush I wish that I didnt have to learn the whole udev to do such a thing.


All I need is my 2.3GHz intel 2415ֵֵM  with turbo mode on up to 2.9GHz to be never more than 2.2GHz without boost mode for ever.

Without making hacky script but just go with the udev functionnality

Do you have a suggestion ?

Last edited by maxarsys (2013-09-12 15:18:01)

Offline

#11 2013-09-12 16:11:11

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Disable turbo mode ?[SOLVED]

Oh you don't really have to learn all of udev.  Udev is a pretty powerful thing, and the additions of the systemd stuff make it even more flexible.  But just the super basic aspects of wirting udev rules can be found on the udev page in the link "Writing Udev Rules".  Here is a direct link to that page.  The tutorial is kind of old, but the information is still good with one exception… there is no longer a udevinfo command.  So if you simply replace "udevinfo" with "udevadm" the page is still valid.

Basically, you just need to do the attibute walk on the directory containing the file you wish to change.  Then pick a few attributes to put in your rule that will ensure that the rule will be unique to that specific file, and make the change.

Here is an example of what I used to use to set my backlight on boot (systemd-git has a neat new thing that resets your backlight to what it was on last boot so I don't need it anymore):

ACTION=="add", KERNEL=="acpi_video0", SUBSYSTEM=="backlight", DRIVERS=="i915", ATTR{brightness}="4"

So the action is self explanatory, but the rest of the stuff I was able to get from using udevadm info --attribute-walk --path /sys/class/backlight/acpi_video0.  Notice that the thing that is being changed (ATTR{brightness}) has only one '='.  Read that page I linked to above to really understand what is going on here.  It is a pretty short little page and you should be able to get through it pretty quickly.

Offline

#12 2013-09-15 00:33:15

Hydranix
Member
Registered: 2013-02-10
Posts: 49

Re: Intel Disable turbo mode ?[SOLVED]

Monitor your i3,i5,i7 cpu with i7z from the aur.

yes|pacman -Sy git jshon wget
cd /tmp
wget aur.archlinux.org/packages/pa/packer/packer.tar.gz
tar xfv packer.tar.gz
cd packer*
yes|makepkg -i
packer -S --noconfirm --noedit i7z
sudo i7z

Disable turbo in the bios. Got a mac? Buy a real laptop.

Offline

#13 2013-09-15 00:47:37

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,019
Website

Re: Intel Disable turbo mode ?[SOLVED]

Hydranix wrote:

Got a mac? Buy a real laptop.


This isn't helpful.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#14 2013-09-15 01:07:33

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Intel Disable turbo mode ?[SOLVED]

WonderWoofy wrote:

Alternatively, you might want to try using intels thermal daemon, which uses a number of kernel features to better regulate thermal output.  It is available from the AUR as the thermald package.  It works great for me.

Is there any documentation on this? I didn't find any mention of it in the wiki. (I notice AUR has 2 versions: thermald and thermald-git.)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#15 2013-09-15 02:20:30

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Disable turbo mode ?[SOLVED]

cfr wrote:

Is there any documentation on this? I didn't find any mention of it in the wiki. (I notice AUR has 2 versions: thermald and thermald-git.)

https://01.org/linux-thermal-daemon

I just use it out of the box, and it says that this should be fine.  But it uses several kernel features to help regulate thermal output.  You can fine tune it with the provided xml configuration file, but it is long and unwieldy.  So that and the fact that it seems to work just fine OOTB, I just leave it as is and let it do its thing.

There are two versions, and the git one is (last I checked) unmaintained.  It was posted and then orphaned immediately.  So I fixed up the PKGBUILD and posted it in the comments.  At that time I think that there was only the git version.  But now there is a stable version, so the maintainer of the regular thermald took my fixed up srcpackage and converted it to use the stable sources.  I actually use that version now, as there has been seemingly no work on it for some 3 months or so in the git repo.

Offline

#16 2013-09-15 02:24:56

cfr
Member
From: Cymru
Registered: 2011-11-27
Posts: 5,662

Re: Intel Disable turbo mode ?[SOLVED]

Thanks. Is there some reason this is in AUR and not in the official repos? That is, it sounds almost like the other half of the pstate stuff which is in the kernel so it seems odd that it is only in AUR. (I'm just wondering if it is considered unsafe or unreliable or something since this is a pretty essential function in a laptop.)

EDIT: The wiki now has something on this. I hope that is reasonable. (Just a link to the documentation you gave and to the AUR package.)

EDIT EDIT: Interestingly, it doesn't find CDEV_INTEL_PSTATE_DRIVER when I start it even though I'm using the intel pstate stuff:

CDEV_MSR_PSTATES_PARTIAL
CDEV_TURBO_ON_OFF
CDEV_POWER_CLAMP
CDEV_CPU_FREQ
CDEV_MSR_PSTATES
CDEV_T_STATES

Not sure about the turbo bit either. My processor is always listed as having turbo but it is always listed as not supported and not active by cpupower (and before that by cpufreq) so not at all clear how thermald could use that as a cooling device wink.

Last edited by cfr (2013-09-15 02:49:56)


How To Ask Questions The Smart Way | Help Vampires

Arch Linux | x86_64 | GPT | EFI boot | grub2 | systemd | LVM2 on LUKS
Lenovo x121e | Intel(R) Core(TM) i3-2367M CPU @ 1.40GHz GenuineIntel | Intel Centrino Wireless-N 1000 | US keyboard with Euro | 320G 7200 RPM Seagate HDD

Offline

#17 2013-09-15 03:18:00

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Disable turbo mode ?[SOLVED]

I think the idea is that the intel_pstate driver *should* work very well on its own.  But it will still rely heavily on the traditional cooling devices of the machine.  Typically this is a heat sink and fan combination.  So the fans will spin up as they normally would in order to keep the machine cool. 

But with the intel thermal daemon, it basically combines that whole list of things in order to try to control the thermal output via these kernel functions instead.  So it first regulates the cpu speed/cycles with the p-state driver.  So it is obviously going to be cooled by simply being idle. 

When the computer is under load, it will then use the other features listed in the docs in order to help it maintain a sane thermal level.  So in order, it would use the p-state control MSR, the t-state control msr, then the rapl, then powerclamp, until finally falling back onto the fans.

On my machine, I can compile a kernel with MAKEFLAGS="-j6" and it typically will not have to kick the fans on unless I start doing other things that are highly cpu dependent.  The machine does get warmer, but it still stay pretty sane.  It is far far far less hot than my old white Macbook used to get when it was under normal load.

So I don't think ther thermald is totally necessary, and is of much more signifigance if you are using some kind of fanless x86 setup.  But I find that in the case of a machine that sometimes sits on my lap, it does a good job at not causing discomfort.

Offline

#18 2013-09-15 10:47:29

maxarsys
Member
Registered: 2013-09-01
Posts: 61

Re: Intel Disable turbo mode ?[SOLVED]

Wow pretty amazing this thermald, no more throttling and powerclamp does a good job.I should of used it from the beginning smile. Thanks WonderWoofy. You finally solved my problem i really appreciate your help on this case.

Offline

#19 2013-09-15 15:54:14

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Intel Disable turbo mode ?[SOLVED]

maxarsys wrote:

Wow pretty amazing this thermald, no more throttling and powerclamp does a good job.I should of used it from the beginning smile. Thanks WonderWoofy. You finally solved my problem i really appreciate your help on this case.

I'm glad it has worked out for you.  I too enjoy the less fan noise.

Offline

Board footer

Powered by FluxBB