You are not logged in.

#1 2013-09-14 00:38:02

Spades
Member
Registered: 2013-05-07
Posts: 5

[SOLVED] Bumblebee with Nvidia 640m LE not initializing

I am on my laptop trying to get my Nvidia 640M LE gfx card working using bumblebee and bbswitch.  When i run optirun I get this error:

[  322.525910] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[  322.525962] [ERROR]Aborting because fallback start is disabled.

I've tried to track down what the issue is but i'm having no success so here is the output of some relevant files and commands.

nvidia driver version: 325.15

lspci

00:02.0 VGA compatible controller: Intel Corporation 3rd Gen Core processor Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GK107M [GeForce GT 640M LE] (rev ff)

dmesg

[   67.242529] bbswitch: enabling discrete graphics
[   67.462091] pci 0000:01:00.0: power state changed by ACPI to D0
[   67.529731] nvidia: module license 'NVIDIA' taints kernel.
[   67.529735] Disabling lock debugging due to kernel taint
[   67.535050] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=none
[   67.535264] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[   67.535270] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  325.15  Wed Jul 31 18:50:56 PDT 2013
[   68.585906] nvidia 0000:01:00.0: irq 49 for MSI/MSI-X
[   73.683891] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   73.683907] NVRM: os_pci_init_handle: invalid context!
[   73.683908] NVRM: os_pci_init_handle: invalid context!
[   73.683912] NVRM: GPU at 0000:01:00.0 has fallen off the bus.
[   73.683915] NVRM: os_pci_init_handle: invalid context!
[   73.683915] NVRM: os_pci_init_handle: invalid context!
[   73.701479] NVRM: RmInitAdapter failed! (0x25:0x28:1157)
[   73.701486] NVRM: rm_init_adapter(0) failed

Xorg.8.log

[    68.433] (II) Loading sub module "fb"
[    68.433] (II) LoadModule: "fb"
[    68.433] (II) Loading /usr/lib/xorg/modules/libfb.so
[    68.435] (II) Module fb: vendor="X.Org Foundation"
[    68.435]     compiled for 1.14.2, module version = 1.0.0
[    68.435]     ABI class: X.Org ANSI C Emulation, version 0.4
[    68.435] (WW) Unresolved symbol: fbGetGCPrivateKey
[    68.435] (II) Loading sub module "wfb"
[    68.435] (II) LoadModule: "wfb"
[    68.435] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    68.442] (II) Module wfb: vendor="X.Org Foundation"
[    68.442]     compiled for 1.14.2, module version = 1.0.0
[    68.442]     ABI class: X.Org ANSI C Emulation, version 0.4
[    68.442] (II) Loading sub module "shadow"
[    68.442] (II) LoadModule: "shadow"
[    68.442] (II) Loading /usr/lib/xorg/modules/libshadow.so
[    68.452] (II) Module shadow: vendor="X.Org Foundation"
[    68.452]     compiled for 1.14.2, module version = 1.1.0
[    68.452]     ABI class: X.Org ANSI C Emulation, version 0.4
[    68.452] (II) Loading sub module "ramdac"
[    68.452] (II) LoadModule: "ramdac"
[    68.452] (II) Module "ramdac" already built-in
[    68.457] (II) NVIDIA(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[    68.457] (==) NVIDIA(0): Depth 24, (==) framebuffer bpp 32
[    68.457] (==) NVIDIA(0): RGB weight 888
[    68.457] (==) NVIDIA(0): Default visual is TrueColor
[    68.457] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[    68.458] (**) NVIDIA(0): Option "NoLogo" "true"
[    68.458] (**) NVIDIA(0): Option "ProbeAllGpus" "false"
[    68.458] (**) NVIDIA(0): Option "UseEDID" "false"
[    68.458] (**) NVIDIA(0): Option "UseDisplayDevice" "0"
[    68.458] (**) NVIDIA(0): Enabling 2D acceleration
[    68.458] (**) NVIDIA(0): Ignoring EDIDs
[    73.603] (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.  Please
[    73.603] (EE) NVIDIA(0):     check your system's kernel log for additional error
[    73.603] (EE) NVIDIA(0):     messages and refer to Chapter 8: Common Problems in the
[    73.603] (EE) NVIDIA(0):     README for additional information.
[    73.603] (EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
[    73.603] (EE) NVIDIA(0): Failing initialization of X screen 0
[    73.603] (II) UnloadModule: "nvidia"
[    73.603] (II) UnloadSubModule: "shadow"
[    73.603] (II) UnloadSubModule: "wfb"
[    73.603] (II) UnloadSubModule: "fb"
[    73.603] (EE) Screen(s) found, but none have a usable configuration.
[    73.603] (EE)
Fatal server error:
[    73.603] (EE) no screens found(EE)
[    73.603] (EE)
Please consult the The X.Org Foundation support
     at http://wiki.x.org
for help.
[    73.603] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
[    73.603] (EE)
[    73.603] (EE) Server terminated with error (1). Closing log file.

bumblebee.nvidia.conf

Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "0"
EndSection

If I left anything out let me know.

Last edited by Spades (2013-09-18 19:35:50)

Offline

#2 2013-09-14 21:28:35

Spades
Member
Registered: 2013-05-07
Posts: 5

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

bump! This is incredibly frustrating, I can't figure it out!

Offline

#3 2013-09-16 12:21:01

qinohe
Member
From: A Dutch location..)
Registered: 2012-06-20
Posts: 650

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

Hi, don't bump, unless you add something useful, bumping is not not considered wise posting around here, and could even leave your post unanswered, I just wanted to say, for you, as it can help you with future questions.
.
Still, gonna try, your new, so welcome to the ArchLinux.

How did you setup the whole bumblebee circus? what commands did you use, software installed..
Looking at the log 'Failed to initialize the NVIDIA GPU at PCI:1:0:0.' , and your bumblebee.nvidia.conf could you try, change the for last line

Option "UseDisplayDevice" "0" 

  into 

Option "UseDisplayDevice" "none"

  ?
I don't know if this is really necessary, but you may want to log out and back in.


-I can give you a ladder, but you need to climb it yourself-

Offline

#4 2013-09-17 00:07:51

Spades
Member
Registered: 2013-05-07
Posts: 5

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

qinohe wrote:

Hi, don't bump, unless you add something useful, bumping is not not considered wise posting around here, and could even leave your post unanswered, I just wanted to say, for you, as it can help you with future questions.
.
Still, gonna try, your new, so welcome to the ArchLinux.

How did you setup the whole bumblebee circus? what commands did you use, software installed..
Looking at the log 'Failed to initialize the NVIDIA GPU at PCI:1:0:0.' , and your bumblebee.nvidia.conf could you try, change the for last line

Option "UseDisplayDevice" "0" 

  into 

Option "UseDisplayDevice" "none"

  ?
I don't know if this is really necessary, but you may want to log out and back in.


Hi, thanks for the tips.

I had previously tried setting that setting to "none" but it made no difference as far as I could tell.  As far as how I installed it, I just installed bumblebee and bbswitch from pacman, enabled bumblebeed and that was it.

Offline

#5 2013-09-17 07:46:07

qinohe
Member
From: A Dutch location..)
Registered: 2012-06-20
Posts: 650

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

I just installed bumblebee and bbswitch from pacman, enabled bumblebeed and that was it.

If that's the exact case, it's wrong.Install it again following the wiki, cause that is done different.
The way you tell it, you can't setup bumblebee on it's own, you need install,all drivers at once, and so on...


-I can give you a ladder, but you need to climb it yourself-

Offline

#6 2013-09-18 07:34:53

Spades
Member
Registered: 2013-05-07
Posts: 5

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

You need to install everything at once? That seems a bit odd to me. Do you know that, or are you just saying that because that is the way the wiki does it?

edit: that didn't change anything.

Last edited by Spades (2013-09-18 07:42:54)

Offline

#7 2013-09-18 10:33:12

beidl
Member
Registered: 2013-08-31
Posts: 6

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

Getting Bumblebee to run nicely on my Acer M5-481TG (Intel HD4000 + NVIDIA 640M LE) was bugging me as well.
I was wondering why Bumblebee worked for me with Ubuntus Mainline 3.11 kernel on 13.10 when it didn't work OOTB on Arch (also running the 3.11 kernel).
Pretty sure not everything what I did to make it work was neccessary, but still.

1) Upgrade to testing (selectively downloading the new linux, bbswitch and nvidia packages might work as well).

2) In /etc/mkinitcpio.conf I changed the MODULES var to:

MODULES="i915 bbswitch"

and did the usual

# mkinitcpio -p linux

3) In /etc/default/grub I added:

rcutree.rcu_idle_gp_delay=1

to GRUB_CMDLINE_LINUX_DEFAULT. My guess is that this one is crucial to get it running, as it was suggested by bumblebee devs.
And of course:

# grub-mkconfig -o /boot/grub/grub.cfg

4) In my /etc/bumblebee/bumblebee.conf under [optirun] I changed the bridge method to:

Bridge=virtualgl

and of course the usual things like setting the Driver under [bumblebeed] to nvidia.
Manually overriding the bridge method on demand via "optirun -b primus" still works of course.

5) In /etc/bumblebee/xorg.conf.nvidia i set the BusID of my NVIDIA card (lspci | grep VGA | grep NVIDIA):

BusID "PCI:01:00:0"

Aaaaand it's working nicely. smile

Last edited by beidl (2013-09-18 10:41:29)

Offline

#8 2013-09-18 19:35:27

Spades
Member
Registered: 2013-05-07
Posts: 5

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

That fixed it all up! I am forever in your debt, you made me so happy.  Cheers man!

Offline

#9 2013-09-19 09:50:35

beidl
Member
Registered: 2013-08-31
Posts: 6

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

Spades wrote:

That fixed it all up! I am forever in your debt, you made me so happy.  Cheers man!

You're welcome! big_smile

Offline

#10 2013-10-02 10:52:25

chemist69
Member
From: Hannover
Registered: 2013-10-02
Posts: 3

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

This also fixed it for me!
I have been googling forever already, it was driving me crazy!!!!

Many thanks!!


if you're not part of the solution - you're part of the precipitate.

Offline

#11 2013-11-06 09:57:13

dmaschine
Member
Registered: 2013-06-20
Posts: 24

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

Solved the problem with Ideapad Z500, too !^^
Thanks!

Offline

#12 2013-11-20 15:42:56

p2004a
Member
Registered: 2013-11-20
Posts: 1

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

It solved the problem with Y580 too! And I'm on Debian Jessie with kernel 3.11, not on Arch smile. Thanks!

Offline

#13 2014-05-19 08:10:08

Nikoomba
Member
Registered: 2014-05-19
Posts: 1

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

beidl wrote:

Getting Bumblebee to run nicely on my Acer M5-481TG (Intel HD4000 + NVIDIA 640M LE) was bugging me as well.
I was wondering why Bumblebee worked for me with Ubuntus Mainline 3.11 kernel on 13.10 when it didn't work OOTB on Arch (also running the 3.11 kernel).
Pretty sure not everything what I did to make it work was neccessary, but still.

1) Upgrade to testing (selectively downloading the new linux, bbswitch and nvidia packages might work as well).

2) In /etc/mkinitcpio.conf I changed the MODULES var to:

MODULES="i915 bbswitch"

and did the usual

# mkinitcpio -p linux

3) In /etc/default/grub I added:

rcutree.rcu_idle_gp_delay=1

to GRUB_CMDLINE_LINUX_DEFAULT. My guess is that this one is crucial to get it running, as it was suggested by bumblebee devs.
And of course:

# grub-mkconfig -o /boot/grub/grub.cfg

4) In my /etc/bumblebee/bumblebee.conf under [optirun] I changed the bridge method to:

Bridge=virtualgl

and of course the usual things like setting the Driver under [bumblebeed] to nvidia.
Manually overriding the bridge method on demand via "optirun -b primus" still works of course.

5) In /etc/bumblebee/xorg.conf.nvidia i set the BusID of my NVIDIA card (lspci | grep VGA | grep NVIDIA):

BusID "PCI:01:00:0"

Aaaaand it's working nicely. smile

Thank you ever so much, I've spent days trying to get this to work and this post solved all of my problems.
Have a great day!

Last edited by Nikoomba (2014-05-19 08:11:01)

Offline

#14 2015-03-24 09:50:49

splashy
Member
Registered: 2010-08-21
Posts: 128

Re: [SOLVED] Bumblebee with Nvidia 640m LE not initializing

Thanks!

Offline

Board footer

Powered by FluxBB