You are not logged in.

#1 2013-09-20 23:37:00

rjrjr
Member
Registered: 2010-03-22
Posts: 42

Pacstrap download issues

I'm doing a clean install on a Lenovo x120e. I used the wifi-menu utility to select my wifi network, and arch seems to connect fine. I know my home internet connection has no issues because I've been able to use it with a variety of other devices.

After setting up my partitions, I ran pacstrap to install the base system onto my hdd, or try to. pacstrap will download some small packages in spurts, but it will stall on larger files (such as the 'linux' package) and will tell me 'Operation too slow.' I've used the stock mirrorlist, checked the mirror status and deleted all the entries except for the top 10, and tried using only http servers to no avail.

Does anyone know how to resolve this issue? I'm at a loss. I simply cannot install the packages I need.

Offline

#2 2013-09-22 01:56:45

thiagowfx
Member
Registered: 2013-07-09
Posts: 532

Re: Pacstrap download issues

What do you mean by "checked the mirror status"? Have you ranked (sorted) the mirrors first? You said "top 10", but I don't know if this means top 10 mirrors (=you've already sorted them) or top 10 from the default mirrorlist order.

Offline

#3 2013-09-27 00:01:17

rjrjr
Member
Registered: 2010-03-22
Posts: 42

Re: Pacstrap download issues

Sorry, yes, I ranked the mirrors and then pared down my mirrorlist to just include the 10 highest ranked ones.

Thanks for the reply.

Offline

#4 2013-10-13 09:30:53

Daniman.teshome
Member
Registered: 2013-10-13
Posts: 10

Re: Pacstrap download issues

Try to select the mirrors to your place.

Offline

#5 2013-10-15 18:21:44

Amarildo
Member
Registered: 2013-09-21
Posts: 246
Website

Re: Pacstrap download issues

I just follow the Wiki:

1. # nano /etc/pacman.d/mirrorlist
2. 'Ctrl+W' (to search), type Brazil and then 'Alt+6' to cope the lines that are from Brazil.

I've had this 'operation too slow' problem and my connection is wired and directly connected to my PC. The problem was with the mirror, so try other mirrors on the top (explanation bellow).

My mirror list looks like this after I edit on the install process:

##
## Arch Linux repository mirrorlist
## Sorted by mirror score from mirror status page
## Generated on 2013-09-01
##

Server = http://archlinux.c3sl.ufpr.br/$repo/os/$arch
Server = http://www.las.ic.unicamp.br/pub/archlinux/$repo/os/$arch

## Score: 0.4, United States
Server = http://mirror.us.leaseweb.net/archlinux/$repo/os/$arch
## Score: 0.5, Netherlands
Server = http://mirror.nl.leaseweb.net/archlinux/$repo/os/$arch

I didn't post everything but you get the idea that the two servers are important where they are.

Server = http://archlinux.c3sl.ufpr.br/$repo/os/$arch
Server = http://www.las.ic.unicamp.br/pub/archli … o/os/$arch

Last edited by Amarildo (2013-10-15 18:22:58)


If it ain't broke, you haven't tweaked it enough...

Offline

Board footer

Powered by FluxBB