You are not logged in.

#1 2013-09-21 06:05:29

thepasto
Member
From: trash:///
Registered: 2009-03-16
Posts: 37

Alx driver issue after suspend

Hi guys,

This is the problem i get when i resume my laptop after a suspend. Dmesg shows several lines like that:

alx 0000:04:00.0: invalid PHY speed/duplex: 0xffff

So wired network is not working, and after some minutes gnome hangs too and i need to reboot my computer.

Any suggenstion? thanks

Offline

#2 2013-09-23 07:54:35

beanaroo
Member
Registered: 2013-03-05
Posts: 36

Re: Alx driver issue after suspend

I'm having the exact same problem.

alx 0000:02:00.0: invalid PHY speed/duplex: 0xffff

spams dmesg and renders the system unusable after two minutes.

Offline

#3 2013-09-23 14:04:06

gtolden
Member
Registered: 2013-07-20
Posts: 13

Re: Alx driver issue after suspend

same problem, to make things worse, one of my  4 cpu cores get up to 100% usage and the system will hang after a while.

systemctl stop NetworkManager 
 ip link set enp3s0 

before suspend seems to make things fine for me, but it is not a sensible choice sad

Is it a kernel bug?

Last edited by gtolden (2013-09-23 14:04:46)

Offline

#4 2013-09-23 18:05:04

thepasto
Member
From: trash:///
Registered: 2009-03-16
Posts: 37

Re: Alx driver issue after suspend

You can just rmmod alx before suspending. As i can remember the problem is always there since 3.10 kernel (alx merged into kernel tree)

Offline

#5 2013-09-24 14:14:44

gtolden
Member
Registered: 2013-07-20
Posts: 13

Re: Alx driver issue after suspend

Anyone who can help? I can't always remember to type the command before I close my lid...

Offline

#6 2013-09-27 04:28:21

nfreitas
Member
Registered: 2013-09-27
Posts: 1

Re: Alx driver issue after suspend

You could blacklist the alx module.

Offline

#7 2013-09-27 13:55:10

thepasto
Member
From: trash:///
Registered: 2009-03-16
Posts: 37

Re: Alx driver issue after suspend

I just found a better solution working for my case.


/etc/systemd/system/root-suspend.service

[Unit]
Description=Local system suspend actions
Before=sleep.target

[Service]
Type=simple
ExecStart=/usr/bin/rmmod alx

[Install]
WantedBy=suspend.target

/etc/systemd/system/root-resume.service

[Unit]
Description=Local system resume actions
After=suspend.target

[Service]
Type=simple
ExecStart=/usr/bin/modprobe alx

[Install]
WantedBy=suspend.target

and then just enable them:

sudo systemctl enable root-suspend
sudo systemctl enable root-resume

Offline

#8 2013-10-01 05:52:21

gtolden
Member
Registered: 2013-07-20
Posts: 13

Re: Alx driver issue after suspend

thepasto wrote:

I just found a better solution working for my case.


/etc/systemd/system/root-suspend.service

[Unit]
Description=Local system suspend actions
Before=sleep.target

[Service]
Type=simple
ExecStart=/usr/bin/rmmod alx

[Install]
WantedBy=suspend.target

/etc/systemd/system/root-resume.service

[Unit]
Description=Local system resume actions
After=suspend.target

[Service]
Type=simple
ExecStart=/usr/bin/modprobe alx

[Install]
WantedBy=suspend.target

and then just enable them:

sudo systemctl enable root-suspend
sudo systemctl enable root-resume

Many thanks:)

Offline

#9 2013-10-09 20:21:22

bericp1
Member
Registered: 2013-02-17
Posts: 17

Re: Alx driver issue after suspend

thepasto wrote:

I just found a better solution working for my case.


/etc/systemd/system/root-suspend.service

[Unit]
Description=Local system suspend actions
Before=sleep.target

[Service]
Type=simple
ExecStart=/usr/bin/rmmod alx

[Install]
WantedBy=suspend.target

/etc/systemd/system/root-resume.service

[Unit]
Description=Local system resume actions
After=suspend.target

[Service]
Type=simple
ExecStart=/usr/bin/modprobe alx

[Install]
WantedBy=suspend.target

and then just enable them:

sudo systemctl enable root-suspend
sudo systemctl enable root-resume

Thanks, this helped me out. I knew the workaround probably involved systemd but I've yet to dive into how it works.

Offline

#10 2013-10-13 03:29:48

tazee
Member
Registered: 2013-10-13
Posts: 26

Re: Alx driver issue after suspend

Thanks this helped me out too. The looping message and lagginess were very irritating and are now gone.

Offline

#11 2013-10-22 04:26:53

tazee
Member
Registered: 2013-10-13
Posts: 26

Re: Alx driver issue after suspend

thepasto : your solution works good when I put my computer to sleep (Suspend to RAM), but it does not work for hibernate (Suspend to disk). I also would like something similar to work for hibernate too. What modification should I make?

Offline

#12 2013-10-22 18:54:58

thepasto
Member
From: trash:///
Registered: 2009-03-16
Posts: 37

Re: Alx driver issue after suspend

I think you create two files with the same structure using hibernate.target instead of suspend.target.

[Unit]
Description=Local system suspend actions
Before=sleep.target

[Service]
Type=simple
ExecStart=/usr/bin/rmmod alx

[Install]
WantedBy=hibernate.target
[Unit]
Description=Local system resume actions
After=hibernate.target

[Service]
Type=simple
ExecStart=/usr/bin/modprobe alx

[Install]
WantedBy=hibernate.target

And enable them.. Maybe you can do everything with 2 files but i'm not so good with systemd stuff smile

Good luck and let me know!!

Offline

#13 2013-10-22 22:22:02

beanaroo
Member
Registered: 2013-03-05
Posts: 36

Re: Alx driver issue after suspend

@thepasto Thank you! Your solution is elegant and works perfectly.

Offline

#14 2013-10-23 01:44:56

tazee
Member
Registered: 2013-10-13
Posts: 26

Re: Alx driver issue after suspend

@thepasto Thank you! This does work well. I did end up with 4 files. Two files for suspend to Ram and 2 files for suspend to disk. And because of this I learned a little bit more about systemd.

Last edited by tazee (2013-10-23 01:47:41)

Offline

#15 2013-10-28 19:05:12

anachron8
Member
Registered: 2009-12-21
Posts: 8

Re: Alx driver issue after suspend

I modified thepasto's suggested fix into a single file solution. It seems to work OK -- please report back if it doesn't smile

[Unit]
Description=Local system sleep actions
Before=sleep.target
PartOf=sleep.target

[Service]
Type=oneshot
RemainAfterExit=yes

# Commands to run when suspending or hibernating
ExecStart=/usr/bin/modprobe -r alx


# Commands to run when resuming or waking up
ExecStop=/usr/bin/modprobe alx


[Install]
WantedBy=sleep.target

Offline

#16 2013-10-29 04:23:45

tazee
Member
Registered: 2013-10-13
Posts: 26

Re: Alx driver issue after suspend

anachron8 : will this work for both suspend to ram as well as suspend to disk?

Offline

#17 2013-11-01 05:48:34

aeqel
Member
Registered: 2013-03-10
Posts: 2

Re: Alx driver issue after suspend

Confirming anachron8's solution worked for both suspend to ram and suspend to disk on my F201E.

Offline

#18 2013-11-04 06:38:36

tazee
Member
Registered: 2013-10-13
Posts: 26

Re: Alx driver issue after suspend

Yes I tried it too. It works for both suspend to ram and suspend to disk. Thanks.

Offline

#19 2013-11-04 15:42:25

anachron8
Member
Registered: 2009-12-21
Posts: 8

Re: Alx driver issue after suspend

Sorry for not paying attention to this thread; I wasn't automatically subscribed when I posted.

It works for both suspend and hibernate because they both pull in sleep.target.

Offline

#20 2013-11-29 00:12:55

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: Alx driver issue after suspend

Someone should add this to the wiki. If noone does, I will in a day or two.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#21 2014-05-06 15:34:18

hahnjo
Member
Registered: 2014-05-06
Posts: 1

Re: Alx driver issue after suspend

Sorry to post in such an old topic...

It was indeed a kernel bug. I submitted a patch in November and it was included in 3.11.10, 3.12.2 and 3.13 (https://bugzilla.kernel.org/show_bug.cgi?id=62491)
I think you should remove the section from the wiki

Offline

#22 2014-05-15 01:40:36

tazee
Member
Registered: 2013-10-13
Posts: 26

Re: Alx driver issue after suspend

Hahnjo, thanks for your post as well as the kernel bug patch. I removed my  systemd  based workaround to test the new kernel and it works fine. I have removed the section from the wiki too.

Offline

Board footer

Powered by FluxBB