You are not logged in.

#1 2013-09-24 04:14:05

navidpaya
Member
Registered: 2013-09-24
Posts: 3

Problem with Wifi

Hi
I have a Lenovo T430s. Recently I use it at work. We have two WAPs which use the same SSID. The problem I have is that one in a while the wifi switches from one SSID to another. This is the log I get. Any idea what the problem is? This is what I see in the journalctl output:

Sep 24 11:58:06 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: associating -> associated
Sep 24 11:58:06 jigar kernel: wlp3s0: Limiting TX power to 17 (17 - 0) dBm as advertised by 2c:b0:5d:98:72:30
Sep 24 11:58:07 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: associated -> completed
Sep 24 11:58:07 jigar NetworkManager[398]: <info> (wlp3s0): roamed from BSSID (none) ((none)) to 2C:B0:5D:98:72:30 (RMGTech)
Sep 24 12:00:05 jigar kernel: wlp3s0: cannot understand ECSA IE operating class 0, disconnecting
Sep 24 12:00:05 jigar kernel: wlp3s0: AP 2c:b0:5d:98:72:30 switches to unsupported channel (0 MHz), disconnecting
Sep 24 12:00:05 jigar kernel: cfg80211: Calling CRDA for country: MY
Sep 24 12:00:05 jigar NetworkManager[398]: <info> (wlp3s0): roamed from BSSID 2C:B0:5D:98:72:30 (RMGTech) to (none) ((none))
Sep 24 12:00:05 jigar NetworkManager[398]: <warn> Connection disconnected (reason -4)
Sep 24 12:00:05 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: completed -> disconnected
Sep 24 12:00:05 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: disconnected -> scanning
Sep 24 12:00:09 jigar kernel: wlp3s0: authenticate with 2c:b0:5d:98:6b:90
Sep 24 12:00:09 jigar kernel: wlp3s0: send auth to 2c:b0:5d:98:6b:90 (try 1/3)
Sep 24 12:00:09 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: scanning -> authenticating
Sep 24 12:00:09 jigar kernel: wlp3s0: authenticated
Sep 24 12:00:09 jigar kernel: iwlwifi 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP
Sep 24 12:00:09 jigar kernel: iwlwifi 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP
Sep 24 12:00:09 jigar kernel: wlp3s0: associate with 2c:b0:5d:98:6b:90 (try 1/3)
Sep 24 12:00:09 jigar kernel: wlp3s0: RX AssocResp from 2c:b0:5d:98:6b:90 (capab=0x511 status=0 aid=4)
Sep 24 12:00:09 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: authenticating -> associating
Sep 24 12:00:09 jigar kernel: wlp3s0: associated
Sep 24 12:00:09 jigar NetworkManager[398]: <info> (wlp3s0): supplicant interface state: associating -> completed
Sep 24 12:00:09 jigar NetworkManager[398]: <info> (wlp3s0): roamed from BSSID (none) ((none)) to 2C:B0:5D:98:6B:90 (RMGTech)
Sep 24 12:00:09 jigar kernel: wlp3s0: Limiting TX power to 17 (17 - 0) dBm as advertised by 2c:b0:5d:98:6b:90

Offline

#2 2013-09-24 04:22:16

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: Problem with Wifi

Maybe you should see if a different network management daemon suffers from the same thing?  There are a number of options available.  On my machine I have netctl, connman-git, wicd, and NetworkManager.  I tend to use connman, as it is fast and I have found it works well.  But I have been on a netctl kick of late. 

If you want something with a nice gui, look into wicd.  The wicd service and gui are split into two packages.

Offline

#3 2013-09-24 05:56:56

navidpaya
Member
Registered: 2013-09-24
Posts: 3

Re: Problem with Wifi

Thanks for the advice. I installed connman but it was a nightmare to configure so I switched to wicd. So far, so good. Hopefully that took care of the problem.

Offline

#4 2013-11-21 02:28:19

h54
Member
Registered: 2011-11-22
Posts: 88

Re: Problem with Wifi

Have you resolved this issue?  My brother has the same card and the same issue.

Offline

#5 2013-11-21 12:37:49

navidpaya
Member
Registered: 2013-09-24
Posts: 3

Re: Problem with Wifi

Kind of. I just uninstalled Network Manager and am using WICD. It's quite nice and stable. It just lacks some features like VPN integration but I can live with that.

Offline

#6 2013-11-21 22:43:43

h54
Member
Registered: 2011-11-22
Posts: 88

Re: Problem with Wifi

Thanks, I will do that tonight.  He is a noob and using Mint but its probably applicable.

Offline

Board footer

Powered by FluxBB