You are not logged in.

#1 2013-09-25 13:15:55

vox23
Member
Registered: 2013-09-25
Posts: 9

[SOLVED] systemd: Failed to open private dbus connection

Below is a snapshot from journalctl -b:

...
systemd[1]: Starting user-1000.slice.
systemd[1]: Created slice user-1000.slice.
systemd[1]: Starting User Manager for 1000...
systemd[1]: Starting Session 1 of user me.
systemd[1]: Started Session 1 of user me.
systemd-logind[195]: New session 1 of user me.
systemd[261]: pam_unix(systemd-user:session): session opened for user me by (uid=0)
systemd[261]: Failed to open private dbus connection: Failed to connect to socet /run/usr/1000/dbususer_bus_socket: No such file or directory
systemd[261]: Mounted /sys/kernel/config.
systemd[261]: Stopped target Bluetooth.
systemd[261]: Stopped target Sound Card.
systemd[261] Starting Default.
systemd[261]: Reached target Default.
systemd[261]: Startup finished in 135ms.
systemd[1]: Started User Manager for 1000.
login[199]: LOGIN ON tty1 BY me
...

It's a fresh Arch Linux install and I didn't even had a time yet to tinker with systemd so it's unlikely that I've messed things up. I suspect that it might be the cause of the following problem:

$ systemctl status --user
Failed to issue method call: Process /bin/false exited with status 1

For reference, systemd version:

$ systemctl --version
systemd 207
+PAM -LIBWRAP -AUDIT -SELINUX -IMA -SYSVINIT +LIBCRYPTSETUP +GCRYPT +ACL +XZ

Any ideas how can I solve the private dbus connection problem?

Last edited by vox23 (2013-09-25 17:02:22)

Offline

#2 2013-09-25 14:04:48

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] systemd: Failed to open private dbus connection

do you actually experience any problems? Because this is normal.  The systemd user session expects the dbus session daemon to listen on /run/user/1000/dbus/user_bus_socket, but this isn't the case unless specifically configured. This will fix itself as soon as the systemd user service and dbus have learnt to play nice together out of the box.

If you see these messages at boot and just don't want to see them, I suggest you boot with "quiet" as a kernel parameter.

Last edited by 65kid (2013-09-25 14:06:36)

Offline

#3 2013-09-25 17:02:00

vox23
Member
Registered: 2013-09-25
Posts: 9

Re: [SOLVED] systemd: Failed to open private dbus connection

65kid wrote:

do you actually experience any problems?

I thought that it might be related to:

$ systemctl status --user
Failed to issue method call: Process /bin/false exited with status 1

however when I followed wiki and created:

$cat /etc/systemd/system/user@.service.d/environment.conf
[Service]
Environment=DISPLAY=:0
Environment=XDG_RUNTIME_DIR=/run/user/%I
Environment=SHELL=%s

then /bin/false error went away. I still have some problems with systemd managing my user session but unrelated to the above. Marking as solved.

Offline

#4 2013-11-19 22:30:35

firekage
Member
From: Eastern Europe, Poland
Registered: 2013-06-30
Posts: 493

Re: [SOLVED] systemd: Failed to open private dbus connection

Why you named folder, that you put environment.conf, by the name of user@.service.d, and not user.service.d? I would like to know this.

Offline

#5 2013-11-19 23:32:37

msthev
Member
Registered: 2012-04-05
Posts: 177

Re: [SOLVED] systemd: Failed to open private dbus connection

Because the unit is user@.service, not user.service.

Offline

Board footer

Powered by FluxBB