You are not logged in.

#1 2013-09-26 18:05:21

rafdre
Member
Registered: 2013-09-21
Posts: 31

X11 does not start as expected - problem with NVIDIA card

Hello,
I have installed Archlinux and now I want to add basic X11 system.
I have found WIKI page (https://wiki.archlinux.org/index.php/Xorg)
and I think I followed all steps (I will not describe all in order to make the story short).

My main issue is this:
When I start X using "startx" then after very long time I see on my display very strage screen. It looks like squares.
I have exactly the same issue when I for instance try to use Ubuntu Boot CD on this laptop (If I want to use I have to install it in text mode). The same screen. X11 is broken.
My card is: NVidia Geforce GTS 360M.

I see that X11 starts using config directory: "/etc/X11/xorg.conf.d"
In that directory I see following files:
10-evdev.conf
10-quirks.con
20-nouveau.conf
50-synaptics.conf

20-nouveau.conf
I have created it by my own in order to solved following:
After I type "startx" X11 starts and hangs for about 1 minute displaying message "Loading extension GLX".

I read that in such case I can create 20-nouveau.conf with following content:
Section "Device"
  Identifier "Nvidia-card"
  Driver "nouveau"
  Option "GLXVBlank" "true"
EndSection

this did not solve my issue ...i still see "Loading extension GLX" for very long time. I have not deleted the file.
(see this :https://bbs.archlinux.org/viewtopic.php?id=158882 )

I tried to generate configuration with the command: "Xorg -configure", but this does not work for files /etc/X11/xorg.conf.d. It generates file xorg.conf.new and ask me to run it with "X -config /root/xorg.conf.new".
Anyway - "Xorg -configure" ends with the line:
(EE) Server terminated with error (2). Closing log file.

Strange but "/var/log/Xorg.0.log" does not display any line with (EE) [error]. It does not display anything regardless if I configure X with "Xorg -configure" or use "startx".

When I try "X -config /root/xorg.conf.new" I do not see "Loading extension GLX" but see black screen with cursor. After about 1 minute I see exactly the same screen as when I use "startx".
when I try CTRL+ALT+F1 I see :

(II) AIGLX: Suspending AIGLX clients for VT switch
setversion 1.4 failed


Ok. As last:
what I usually do when I install Linux on that laptop: I download the latest NVIdia drivers for linux and install them. Unfortunately for the latest archlinux (3.11.1-1 ?) when i tried it I had exactly the same issue like the one described here:
https://bbs.archlinux.org/viewtopic.php?id=139057
I am not able to install the driver.
I think the NVidia standard installer cannot work fine with the latest kernel. They are probably always one step behind.

I decided to try configure system with nouveau, but even with this I have issue.

Can anybody suggest me what I can do ?

regards
Rafal

Offline

#2 2013-09-26 18:26:04

teckk
Member
Registered: 2013-02-21
Posts: 206

Re: X11 does not start as expected - problem with NVIDIA card

Offline

#3 2013-09-28 11:43:31

rafdre
Member
Registered: 2013-09-21
Posts: 31

Re: X11 does not start as expected - problem with NVIDIA card

regarding NVIDA - this is the latest step for me if Nouveau will not work properly.

At the moment I focus on Nouveau...and is still does not work. I read the WIKI and there are not that many steps to execute.
I read I have to remove vga= as a kernel parameter, so I checked menu.lst on my second linux (I have dueal boot) and removed vga=0x314
But still I have the same issue on ArchLinux

I have started linux using "drm.debug=14 log_buf_len=16M"
Afterwards I startx with "startx -- -logverbose 9 -verbose 9"
The same issue (long  "Loading extension GLX" and X which cannot be used at all)

When I execute "modinfo -p video" I see this:

brightness_switch_enabled: (bool)
allow_duplicates: (bool)
use_bios_initial_backlight :(bool)

nothing more.

Offline

#4 2013-10-06 07:03:31

rafdre
Member
Registered: 2013-09-21
Posts: 31

Re: X11 does not start as expected - problem with NVIDIA card

nobody has ideas what can be done here ?

Offline

#5 2013-10-06 16:15:34

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 692

Re: X11 does not start as expected - problem with NVIDIA card

rafdre wrote:

nobody has ideas what can be done here ?

You did not say which packages you have installed for your Nvidia card.  You should have both xf86-video-nouveau and nouveau-dri - do you have both installed?  What is the output of pacman -Ss nouveau ? Also what DE are you using?  KDE or something else?

Last edited by mcloaked (2013-10-06 16:19:55)


Mike C

Offline

#6 2013-10-06 16:19:43

graysky
Member
From: /run/user/1000
Registered: 2008-12-01
Posts: 8,450
Website

Re: X11 does not start as expected - problem with NVIDIA card

Remove your 20-nouveau.conf and install the nvidia package which should conflict with nouveau and it's kin.  Reboot for simplicity's sake.  What happens when you try to go graphical?  If it fails, what is in dmesg?  What is in /var/log/Xorg.log?  Try the legacy nvidia driver package, nvidia-304-xx and repeat.  Solve your problem?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

Board footer

Powered by FluxBB