You are not logged in.

#1 2013-09-27 23:22:14

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,528
Website

Strangeness in dmesg: perf samples too long

Anyone else seeing this under 3.11.x?  Searching for the specific message seems to give me more unanswered questions.

%dmesg
...
[ 3835.065463] perf samples too long (2502 > 2500), lowering kernel.perf_event_max_sample_rate to 50100
...

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs • 1.21 JIGOWATTS!

Offline

#2 2013-09-27 23:47:22

Kilzool
Member
From: Ireland
Registered: 2010-08-04
Posts: 232

Re: Strangeness in dmesg: perf samples too long

Yes.

I've noticed it after playing a game.  (Heroes of Newerth).
So maybe it happens during it?

I wonder if you keep a "/etc/sysctl.d/99-sysctl.conf" file?

Also do you see:  "Performance Events: Netburst events, Netburst P4/Xeon PMU driver." in the log?

And before I get jumped on, I am just ignoring it, not thinking it is a bug, just a status message.

Last edited by Kilzool (2013-09-27 23:48:40)

Offline

#3 2013-09-28 00:46:25

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,528
Website

Re: Strangeness in dmesg: perf samples too long

% cat /etc/sysctl.d/99-sysctl.conf
# Configuration file for runtime kernel parameters.
# See sysctl.conf(5) for more information.

# Contains, as a percentage of total system memory, the number of pages at which
# a process which is generating disk writes will start writing out dirty data.
## Arch default = 10.
vm.dirty_ratio = 3

# Contains, as a percentage of total system memory, the number of pages at which
# the background kernel flusher threads will start writing out dirty data.
## Arch default = 5.
vm.dirty_background_ratio = 2
                               
# Protection from the SYN flood attack.
net.ipv4.tcp_syncookies = 1

# Disable packet forwarding.
net.ipv4.ip_forward = 0
net.ipv6.conf.all.forwarding = 0

And

% dmesg | grep -i performance                                                                               :(
[    0.057876] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
[    0.235260] Performance Events: PEBS fmt1+, 16-deep LBR, IvyBridge events, full-width counters, Intel PMU driver.

CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs • 1.21 JIGOWATTS!

Offline

#4 2013-09-28 09:48:29

maggie
Member
Registered: 2011-02-12
Posts: 255

Re: Strangeness in dmesg: perf samples too long

I get it too

% dmesg | grep perf
[  203.392155] perf samples too long (2521 > 2500), lowering kernel.perf_event_max_sample_rate to 50100
[  514.999217] perf samples too long (5029 > 4990), lowering kernel.perf_event_max_sample_rate to 25200

Offline

#5 2013-09-28 11:08:07

Spider.007
Member
Registered: 2004-06-20
Posts: 1,164

Re: Strangeness in dmesg: perf samples too long

Here is the commit with some background information: http://lkml.org/lkml/2013/5/29/640. More background on NMI here: http://x86vmm.blogspot.nl/2005/10/linux … dware.html

It seems that the meta-information NMI's provide sometimes takes up too much CPU time; and the kernel throttles itself with an informational message as posted in this thread. The throttle is to prevent the kernel from taking up too much CPU while obtaining the nmi sample. You could tweak perf_cpu_time_max_percent but it seems the default is just fine

Offline

#6 2014-10-04 08:41:30

belasco
Member
Registered: 2014-10-04
Posts: 1

Re: Strangeness in dmesg: perf samples too long

hi, had those messages since last kernel upgrade, and got snd device plop and stop.
don't know exactly how to debug.

~  dmesg | grep perf
[    0.012690] ENERGY_PERF_BIAS: Set to 'normal', was 'performance'
ENERGY_PERF_BIAS: View and update with x86_energy_perf_policy(8)
[    0.034125] perf_event_intel: PEBS disabled due to CPU errata, please upgrade microcode
[ 3832.565987] perf samples too long (2507 > 2500), lowering kernel.perf_event_max_sample_rate to 50000

Offline

Board footer

Powered by FluxBB