You are not logged in.

#1 2013-09-30 06:33:23

fettouhi
Member
Registered: 2007-05-07
Posts: 658

[SOLVED] KDE SC 4.11.1 keeps forgetting audio settings

Since updating to KDE SC 4.11.1 it keeps forgetting my audio settings. At every login I get a message saying if I want it to keep my pulse audio server input/output or my analog audio or something else. I tried deleting phonondevicesrc in ~/.kde4/share/config/ but to no avail it keeps on doing it. Anybody got a solution or idea why KDE is doing this? Also veromix is always empty now with KDE 4.11.1 so I can't control my pulse audio settings at all.

EDIT: Issues went away with pulseaudio 5.0.

Last edited by fettouhi (2014-04-24 09:07:26)

Offline

#2 2013-09-30 09:10:06

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 140

Re: [SOLVED] KDE SC 4.11.1 keeps forgetting audio settings

hi, i had a similar problem and was really annoying because almost each time my cards and/or config (I use pulseaudio) changed, ex: audio 5.1 of my motherbord's card exchanged for HDMI output of my GPU hmm , so I tested (without investigate... tongue ) with pulseaudio-git from AUR and all works fine now. I have [testing] repo enabled.  Is not the "solution" but for me was an easy workaround. 

My audiocard is:

00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)

KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#3 2013-09-30 10:40:21

archie0
Member
Registered: 2012-02-26
Posts: 144

Re: [SOLVED] KDE SC 4.11.1 keeps forgetting audio settings

I've had the same problem on both Gnome and KDE with pulseaudio, the sound was muted a boot. Just get rid of pulse and use alsa only, with kdemultimedia-kmix.

So, try to fully remove pulse and the install alsa-utils.

Also, could you post your aplay -l output? Your HDMI audio might be default, like in my case; it needs a little tweak in order to get the sound working.

Last edited by archie0 (2013-09-30 10:41:30)

Offline

#4 2013-09-30 18:00:57

donniezazen
Member
From: Salt Lake City
Registered: 2011-06-24
Posts: 671
Website

Re: [SOLVED] KDE SC 4.11.1 keeps forgetting audio settings

Add load-module module-device-manager to /etc/pulse/default.pa

https://wiki.archlinux.org/index.php/Pu … es_and_Qt4

Offline

#5 2013-10-04 17:10:17

fettouhi
Member
Registered: 2007-05-07
Posts: 658

Re: [SOLVED] KDE SC 4.11.1 keeps forgetting audio settings

It is still a mess I tried uninstalling pulseaudio, e.g. pulseaudio, libpulse & pulseaudio-alsa but then I couldn't log into KDE anymore. I tried then to remove all config files in my home directory concerning pulseaudio and then I rebooted my machine but still KDE chooses a different output at every login. I have had NO issues with pulseaudio before until KDE 4.11.1. Now even though my analog output is the preferred audio device in KDE and all other audio devices are turned off it still is a hit and miss at log in. Right now every youtube video is muted when I launch firefox for some reason as well.

Offline

Board footer

Powered by FluxBB