You are not logged in.

#1 2013-09-30 22:24:25

idomeneo
Member
Registered: 2013-07-19
Posts: 25

Trouble getting transmission-daemon to start at boot

I have transmission-cli and transmission-remote-cli, and can't get the daemon to work from systemctl.

These are the settings I have:

/usr/lib/systemd/system/transmission.service includes
After=network.target

/etc/systemd/system/transmission.service.d/transmission.conf includes
[Service]
User=admin

But I'm getting network errors, and no access to the daemon:

~ $ sudo systemctl status -l transmission
transmission.service - Transmission BitTorrent Daemon
   Loaded: loaded (/usr/lib/systemd/system/transmission.service; enabled)
  Drop-In: /etc/systemd/system/transmission.service.d
           └─transmission.conf
   Active: active (running) since Mon 2013-09-30 16:53:47 CDT; 26s ago
Main PID: 342 (transmission-da)
   Status: "Idle."
   CGroup: /system.slice/transmission.service
           └─342 /usr/bin/transmission-daemon -f --log-error
Sep 30 16:53:47 localhost systemd[1]: Started Transmission BitTorrent Daemon.
Sep 30 16:53:47 localhost transmission-daemon[342]: sendto: Network is unreachable
Sep 30 16:53:48 localhost transmission-daemon[342]: [16:53:48.111] UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
Sep 30 16:53:48 localhost transmission-daemon[342]: [16:53:48.112] UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)
~ $ transmission-remote-cli
Cannot connect to localhost:9091: Connection refused
~ $ sudo transmission-remote-cli
Cannot connect to localhost:9091: Connection refused
~ $

By the time my computer has booted, my network (netctl-auto/wireless) is working properly, yet the daemon is unreachable.

Last edited by idomeneo (2013-10-01 02:12:33)

Offline

#2 2013-12-09 17:27:56

idomeneo
Member
Registered: 2013-07-19
Posts: 25

Re: Trouble getting transmission-daemon to start at boot

*bump*

I am having exactly the same problem.

The systemctl daemon did work when I set it up on a static LAN line.
But now, on my roaming laptop, I cannot access the daemon either with the web address, or with the CLI. All I get is:

Cannot connect to localhost:9091: Connection refused

According to systemctl:

~ $ sudo systemctl status -l transmission
transmission.service - Transmission BitTorrent Daemon
   Loaded: loaded (/usr/lib/systemd/system/transmission.service; enabled)
  Drop-In: /etc/systemd/system/transmission.service.d
           └─user.conf
   Active: active (running) since Mon 2013-12-09 10:54:48 CST; 1min 32s ago
 Main PID: 336 (transmission-da)
   Status: "Uploading 1.03 KBps, Downloading 0.72 KBps."
   CGroup: /system.slice/transmission.service
           └─336 /usr/bin/transmission-daemon -f --log-error

Dec 09 10:54:47 localhost systemd[1]: Starting Transmission BitTorrent Daemon...
Dec 09 10:54:48 localhost systemd[1]: Started Transmission BitTorrent Daemon.
Dec 09 10:54:48 localhost transmission-daemon[336]: sendto: Network is unreachable
Dec 09 10:54:49 localhost transmission-daemon[336]: [10:54:49.406] UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
Dec 09 10:54:49 localhost transmission-daemon[336]: [10:54:49.406] UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)

The "Network is unreachable" is presumably because netctl hadn't gotten a wifi node yet, but the daemon appears to be up and running. Moreover, like the OP, I've set the daemon to

After=network.target

But when my wifi comes on, I cannot access the daemon.
Everything in fact works fine when I manually execute "transmission-daemon", but that is not how a daemon is supposed to work!

There must be somebody on these forums with information about what is going on, and what this "daemon" is supposed to be doing - the ArchWiki article is "minimalist", and the Transmissionbt website is downright opaque...

Last edited by idomeneo (2013-12-09 17:48:20)

Offline

#3 2013-12-09 17:32:38

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: Trouble getting transmission-daemon to start at boot

Um, you are the OP...


Please use code tags when pasting to the boards: https://wiki.archlinux.org/index.php/Fo … s_and_Code


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#4 2013-12-09 17:46:07

idomeneo
Member
Registered: 2013-07-19
Posts: 25

Re: Trouble getting transmission-daemon to start at boot

Ha, I didn't even look! Well, more than 2 months of frustration later, this problem is still happening...
I would really like to know what is going on here.

Offline

#5 2013-12-09 18:58:49

sekret
Member
Registered: 2013-07-22
Posts: 231

Re: Trouble getting transmission-daemon to start at boot

*lol* SCNR

Offline

#6 2014-01-24 17:25:03

alyubomirov
Member
Registered: 2013-10-05
Posts: 2

Re: Trouble getting transmission-daemon to start at boot

Maybe this will help https://wiki.archlinux.org/index.php/Systemd.
I had similar problems with APF(firewall). It was not starting because of 'network.target.'
Some times I would see 'network.target' reached few seconds after my 'login:' appears.
Still solution will have to be try different settings in the service file and analyze with 'journalctl -b' after every boot.
And the

Dec 09 10:54:49 localhost transmission-daemon[336]: [10:54:49.406] UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
Dec 09 10:54:49 localhost transmission-daemon[336]: [10:54:49.406] UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)

is related to 'Enable uTP' in 'network' settings. If you disable it the error will disappear.
It is not a reason for the daemon not to start on boot.

Offline

#7 2014-06-16 17:02:19

k0ste
Member
From: Russia
Registered: 2013-12-16
Posts: 4
Website

Re: Trouble getting transmission-daemon to start at boot

Sep 30 16:53:48 localhost transmission-daemon[342]: [16:53:48.111] UDP Failed to set receive buffer: requested 4194304, got 327680 (tr-udp.c:78)
Sep 30 16:53:48 localhost transmission-daemon[342]: [16:53:48.112] UDP Failed to set send buffer: requested 1048576, got 327680 (tr-udp.c:89)

Try this:

[root@k0ste /]# cat /etc/sysctl.d/20-transmission.conf
net.core.wmem_max = 1048576
net.core.rmem_max = 4194304

Offline

Board footer

Powered by FluxBB