You are not logged in.

#1 2013-10-01 11:08:57

Registered: 2012-05-24
Posts: 13

[SOLVED] systemd 207, lvm2 and luks booting issue


i'm using an encrypted lvm (luks) on my notebook.

/boot on /dev/sda1
lvm on    /dev/sda2

since the systemd 207 upgrade i am unable to boot my system.

this error appears at startup:

A start job is running for dev-mapper-main\x2droot.device

so i'm guessing that systemd is unable to use the encrypted lvm2, since this error is aknowledged on the
after checking some threads i tried:

mkinitcpio -p linux

but there was no effect.

HOOKS="base systemd autodetect block keymap encrypt lvm2 filesystems fsck vbox

some people tried suggesting downgrading to systemd 204 but i dont have any pkg file and building with abs leads to the following error
while makepkg -s:

==> Starting prepare()...
patching file src/core/swap.c
Hunk #1 FAILED at 220.
1 out of 1 hunk FAILED -- saving rejects to file src/core/swap.c.rej
==> ERROR: A failure occured in prepare().

am i supposed to remove the patches from the build? i'm not really sure and more of a beginner in this area.

Can anyone help me solve either the build or the boot issue ?

i should mention that i am only able to access my system by using chroot from an arch boot stick.

Thank you so much.

Kind Regards

Last edited by ziv667 (2013-10-01 11:27:06)


#2 2013-10-01 11:15:41

Registered: 2009-05-06
Posts: 25,433

Re: [SOLVED] systemd 207, lvm2 and luks booting issue … mmon_hooks

systemd: This will install a basic systemd setup in your initramfs, and is meant to replace the 'base', 'usr', 'udev' and 'timestamp' hooks. Other hooks (like encryption) would need to be ported, and may not work as intended. As of systemd 207, this hook does not work as intended when combined with lvm2 and may break your boot. You also may wish to still include the 'base' hook (before this hook) to ensure that a rescue shell exists on your initramfs.

Have you tried keeping udev instead of replacing it with systemd hook?

Have you tried … ck_Machine ? It has systemd 204.

Last edited by karol (2013-10-01 11:16:57)


#3 2013-10-01 11:20:05

From: Athens, GReece
Registered: 2009-05-26
Posts: 215

Re: [SOLVED] systemd 207, lvm2 and luks booting issue

Mine is

HOOKS="base udev autodetect modconf block encrypt lvm2 resume filesystems keyboard fsck"

no need for systemd in hooks !

Unix System Engineer - Registered Linux User #420129


#4 2013-10-01 11:26:53

Registered: 2012-05-24
Posts: 13

Re: [SOLVED] systemd 207, lvm2 and luks booting issue

Thank you, replacing systemd with udev worked like a charm!

Best Board ever wink


#5 2013-10-08 06:29:57

From: Slovakia
Registered: 2011-10-25
Posts: 3

Re: [SOLVED] systemd 207, lvm2 and luks booting issue

Removing of systemd in "mkinitcpio.conf" and generating "initramfs" (mkinitcpio -p linux) worked for me as well.


Board footer

Powered by FluxBB