You are not logged in.

#1 2013-10-07 18:19:34

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Gnome 3.10 upgrade issue - cant login

Just upgraded to gnome 3.10 with pacman, I can't seem to login after a restart, I'm stuck at boot messages with "Started accounts service" as the last seen message.
I'm using gdm as my login manager, after a minute or so in this stage I get a graphical error message saying " Oh no! Some thing has gone wrong."
Switching to terminal (vt2) and checking status of gdm in systemctl is see this "failed to give slave programs access to the display. Trying to procced."

Changing to lightdm I was able to get a login screen (still no lower case letters lucky for me I got finger print login too) but no shell after login just gray error message like before "Oh no!" One

Offline

#2 2013-10-07 18:35:41

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

OK.... Changed to lxde and using lxdm still can't login (only using non graphic terminal) I don't think it is gnome related by something to do with language or something from the last update

Offline

#3 2013-10-07 18:49:25

mkdy
Member
Registered: 2013-10-07
Posts: 11

Re: Gnome 3.10 upgrade issue - cant login

Ba7a7chy,
the same problem. Btw I'm using cinnamon.

Offline

#4 2013-10-07 18:55:57

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

Do you use more then one language ? Also tried to change only US_utf8 so I don't think it is language anymore

Offline

#5 2013-10-07 18:58:25

mkdy
Member
Registered: 2013-10-07
Posts: 11

Re: Gnome 3.10 upgrade issue - cant login

using 2 languages.
Cannot login neither via slim, neither via startx.

Offline

#6 2013-10-07 19:03:28

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

Well, the reason you can't login and please verify by changing user and try to write on graphical area is that you only write with the non-english language

But, after deleting all but English I can login but shell still crashes

Offline

#7 2013-10-07 19:13:03

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

Big step, I managed to get to my desktop using lxde, gnome and gnome classic won't work

Offline

#8 2013-10-07 19:18:16

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,740

Re: Gnome 3.10 upgrade issue - cant login

Please do not cross post.  I closed your other thread.  In the future, please ask a moderator to move your thread using the report function.
https://bbs.archlinux.org/viewtopic.php?id=170951


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#9 2013-10-07 19:22:46

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

ewaller wrote:

Please do not cross post.  I closed your other thread.  In the future, please ask a moderator to move your thread using the report function.
https://bbs.archlinux.org/viewtopic.php?id=170951

Thanks You and sorry for the mess.

Offline

#10 2013-10-07 20:29:32

mkdy
Member
Registered: 2013-10-07
Posts: 11

Re: Gnome 3.10 upgrade issue - cant login

Well, I also started lxde succesfully at this time. Still don't know the problem of cinnamon...

Offline

#11 2013-10-08 06:05:54

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

The problem is (for me at lest) not with cinnamon, or gdm, or W/E the problem is with gnome, the shell just crashes

Offline

#12 2013-10-08 06:20:53

mkdy
Member
Registered: 2013-10-07
Posts: 11

Re: Gnome 3.10 upgrade issue - cant login

Since cinnamon depends on gnome, our problems seem to be the same.

Last edited by mkdy (2013-10-08 06:21:06)

Offline

#13 2013-10-08 09:21:59

xor-bzh
Member
Registered: 2013-10-08
Posts: 4

Re: Gnome 3.10 upgrade issue - cant login

My gdm, gnome-shell, evince are also broken since the gnome 3.10 update. It seems to me that the glib version is too old. Here is the output when I launch evince in an xfce environment (the same error comes from gdm or gnome-shell):
evince: symbol lookup error: /usr/lib/libgtk-3.so.0: undefined symbol: g_type_add_instance_private

and what makes me think the glib version is responsible:
yaourt -S gtk3
[...]
(1/1) reinstalling gtk3                            [######################] 100%
Cannot load module /usr/lib/gtk-3.0/3.0.0/immodules/im-ibus.so: GModule (/usr/lib/gtk-3.0/3.0.0/immodules/im-ibus.so) initialization check failed: GLib version too old (micro mismatch)
/usr/lib/gtk-3.0/3.0.0/immodules/im-ibus.so does not export GTK+ IM module API: GModule (/usr/lib/gtk-3.0/3.0.0/immodules/im-ibus.so) initialization check failed: GLib version too old (micro mismatch)
[...]

A temporary fix for me was to install xfce and lxdm and to run that instead of gnome-shell/gdm.
I guess an update of glib will fix it properly.

Offline

#14 2013-10-08 09:31:22

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

Well... this seems right but, using glib-git from AUR which is a newer version should fix it, and it doesn't ..... this is annoying

In your case I would try to install from the git itself: git://git.gnome.org/glib

Last edited by Ba7a7chy (2013-10-08 09:34:49)

Offline

#15 2013-10-08 10:04:16

xor-bzh
Member
Registered: 2013-10-08
Posts: 4

Re: Gnome 3.10 upgrade issue - cant login

ok, in my case I found the culprits: I replaced gfvs-git and glib2-git from [aur] by gvfs and glib2 and I'm now able to login normally (at the second attempt though, something about gdm not able to pass the display to the client the first time...)

Offline

#16 2013-10-08 10:35:28

Ba7a7chy
Member
Registered: 2013-05-04
Posts: 35

Re: Gnome 3.10 upgrade issue - cant login

I'm trying your solution, I'll upgrade and delete all git packages.

Offline

#17 2013-10-08 14:18:06

xor-bzh
Member
Registered: 2013-10-08
Posts: 4

Re: Gnome 3.10 upgrade issue - cant login

Everything is working properly for me now, I had to reinstall gdk-pixbuf2 to get some missing icons back (the svg rendering lib seemed broken before that).

Offline

#18 2013-10-08 22:05:09

christophg
Member
Registered: 2013-02-18
Posts: 5

Re: Gnome 3.10 upgrade issue - cant login

I was able to get it working with KDE, but I could not run any gtk-applications.
Then I discovered that I had glib2-git (from AUR) installed
I did

pacman -S glib2

and then I could log in again

Offline

#19 2013-10-12 21:51:42

s0lid7
Member
From: Hellas (Greece)
Registered: 2012-10-26
Posts: 44

Re: Gnome 3.10 upgrade issue - cant login

I tried slim and lxdm with no luck. I'm now with lxde+lxdm but still can't login in gnome. I tried "pacman -S gnome" "pacman -S glib2 gdk-pixbuf2 gvfs" and reinstalled all of them (had no git package) but still no luck. So, for me problem is not solved yet and i also had a weird message about language when i first loged in lxde.

I read somewhere that it is a known issue and a newer 3.10.0.1-1 version of gnome supposed to fix it but i have that version installed already hmm


Do a pacman -Syu to your brain regularly

Offline

#20 2013-10-22 11:37:49

supersymmetry
Member
Registered: 2012-11-02
Posts: 9

Re: Gnome 3.10 upgrade issue - cant login

Great, thanks! I also had a glib2-git in my installed packages. Couldn't run shutter nor guvcview under xmonad + kde + gtk desktop. Doing a

pacman -S glib2 gdk-pixbuf2 gvfs

fixed all troubles for me smile

Offline

Board footer

Powered by FluxBB