You are not logged in.

#1 2013-10-10 22:44:42

cortezthekiller
Member
Registered: 2013-08-14
Posts: 11

error building xombrero 1.6.3-1

Hi,

I'm trying to build xombrero 1.6.3.-1 from AUR:
https://aur.archlinux.org/packages/xombrero/

I'm getting the following error building the package:

$ makepkg -s
==> Making package: xombrero 1.6.3-1 (Fri Oct 11 09:51:42 CEST 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found xombrero-1.6.3.tgz
  -> Found LICENSE
==> Validating source files with md5sums...
    xombrero-1.6.3.tgz ... Passed
    LICENSE ... Passed
==> Extracting sources...
  -> Extracting xombrero-1.6.3.tgz with bsdtar
==> Removing existing pkg/ directory...
==> Starting build()...
~/builds/xombrero/src/build-gtk2/xombrero-1.6.3 ~/builds/xombrero/src
make: Entering directory `/home/rodrigo/builds/xombrero/src/build-gtk2/xombrero-1.6.3/linux'
perl ../js-merge-helper.pl ../hinting.js ../input-focus.js \
../autoscroll.js > javascript.h
nroff -c -Tascii -mandoc ../xombrero.1 | \
perl ../ascii2txt.pl | \
perl ../txt2tooltip.pl > tooltip.h
Generating ../about.o.depend
In file included from ../about.c:23:0:
../xombrero.h:296:25: error: missing binary operator before token "("
 #if WEBKIT_CHECK_VERSION(1, 5, 0)
                                              ^
../about.c:1983:23: error: missing binary operator before token "("
 #if GLIB_CHECK_VERSION(2, 32, 0)
                                          ^
cc -D_FORTIFY_SOURCE=2 -march=i686 -mtune=generic -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -I/usr/include/gtk-2.0 -O2 -Wall -ggdb3 -D_GNU_SOURCE -I. -I..   -o ../about.o -c ../about.c
In file included from /usr/include/gtk-2.0/gdk/gdk.h:32:0,
                 from /usr/include/gtk-2.0/gtk/gtk.h:32,
                 from ../xombrero.h:94,
                 from ../about.c:23:
/usr/include/gtk-2.0/gdk/gdkapplaunchcontext.h:30:21: fatal error: gio/gio.h: No such file or directory
 #include <gio/gio.h>
                                  ^
compilation terminated.
make: *** [../about.o] Error 1
make: Leaving directory `/home/rodrigo/builds/xombrero/src/build-gtk2/xombrero-1.6.3/linux'
==> ERROR: A failure occurred in build().
    Aborting...

I don't know what I'm missing. I was able to build xombrero last week in another PC with arch. My current system is upgraded:

Linux  3.11.4-1-ARCH #1 SMP PREEMPT Sat Oct 5 21:40:32 CEST 2013 i686 GNU/Linux

I though that installing thg gnutls library would solve the problem, but unfortunately the error persists after gnutls installation

$ pacman -Ss gnutls
extra/gnutls 3.2.4-1 [Installiert]
    A library which provides a secure layer over a reliable transport layer
extra/libtasn1 3.3-1 [Installiert]
    The ASN.1 library used in GNUTLS
community/python2-gnutls 1.2.4-2
    Python wrapper for the GNUTLS library

Thanks in advance

Last edited by cortezthekiller (2013-10-11 08:35:05)

Offline

#2 2013-10-10 23:03:00

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: error building xombrero 1.6.3-1

Have you tried the PKGBUILD from the comments?


Run

LC_ALL=C <command>

to get output in English.


Edit: Do you have glib2 installed?

Last edited by karol (2013-10-10 23:05:07)

Offline

#3 2013-10-11 09:11:17

cortezthekiller
Member
Registered: 2013-08-14
Posts: 11

Re: error building xombrero 1.6.3-1

I've edit the former post to write the error messages in English.
Yes, glib2 is installed, as well as the dependencies mentioned in the aur:
    desktop-file-utils
    libbsd
    webkitgtk3

It seems that the updated PKGBUILD in the comments is just aimed to create two sepparate packages for xombrero & xombrero3. I'll try it, but I don't think this will fix my problem. As a said, I was able to build xombrero in another Pc a few days ago.

Offline

#4 2013-10-11 10:23:11

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: error building xombrero 1.6.3-1

You can post the error or the link to this thread in the comments on https://aur.archlinux.org/packages/xombrero/ , maybe some other user will be able to help you.

Offline

#5 2013-10-11 12:10:23

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,243

Re: error building xombrero 1.6.3-1

that file comes with glib2 and is located here : usr/include/glib-2.0/gio/gio.h

If glib2 is present, the code probably searches in the wrong place.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB