You are not logged in.

#1 2013-10-18 10:11:41

Registered: 2013-10-18
Posts: 5

[SOLVED] Bluetooth controller is not showing up in bluetoothctl

Edit: Nevermind, i did not start the service, sry for the inconvinience! Note to myself: actually read the output you are copy pasting into forum posts -.-

I am trying to connect my bluetooth headphones to my ThinkpadX230, but i cant even select the bluetoothcontroller of my laptop since it is not listed in bluetoothctl.

hciconfig shows a bluetooth controller is up and running:

$ hciconfig
hci0:   Type: BR/EDR  Bus: USB
        BD Address: 08:3E:8E:E3:2A:5C  ACL MTU: 1021:8  SCO MTU: 64:1
        UP RUNNING 
        RX bytes:5212 acl:0 sco:0 events:111 errors:0
        TX bytes:1244 acl:0 sco:0 commands:91 errors:0

the bluetooth service is started:

$ systemctl | grep bluetooth
sys-devices-pci0000:00-0000:00:1a.0-usb3-3\x2d1-3\x2d1.4-3\x2d1.4:1.0-bluetooth-hci0.device loaded active plugged   /sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.4/3-1.4:1.0/bluetooth/hci0
sys-subsystem-bluetooth-devices-hci0.device                                                 loaded active plugged   /sys/subsystem/bluetooth/devices/hci0                                                                            loaded active active    Bluetooth

i am using bluez5 but got frustrated and also tried it with bluedevil(and therefore bluez4) which also didnt show the controller.

Did i forget something i need to do?
Can you give me a hint where i might find information why the controller is not listed?

Last edited by alex3772 (2013-10-18 10:52:05)


#2 2014-02-02 09:00:22

Registered: 2011-10-10
Posts: 110

Re: [SOLVED] Bluetooth controller is not showing up in bluetoothctl

I had the same problem. I reinstalled bluez and bluez-firmware, that did the trick.


Board footer

Powered by FluxBB