You are not logged in.

#1 2013-10-20 21:21:29

jb.1234abcd
Member
Registered: 2013-10-14
Posts: 15

[SOLVED] cdrecord fails to burn iso on cd-r disk

Package: community/cdrtools 3.01a18-1

# cdrecord -prcap
Cdrecord-ProDVD-ProBD-Clone 3.01a18 (i686-pc-linux-gnu) Copyright (C) 1995-2013 Joerg Schilling
Using libscg version 'schily-0.9'.
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities   : 
Vendor_info    : 'SONY    '
Identifikation : 'CD-RW  CRX835E  '
Revision       : 'KPK4'
Device seems to be: Generic mmc2 DVD-ROM.

Drive capabilities, per MMC-3 page 2A:

  Does read CD-R media
  Does write CD-R media
  Does read CD-RW media
  Does write CD-RW media
  Does read DVD-ROM media
  Does read DVD-R media
  Does not write DVD-R media
  Does not read DVD-RAM media
  Does not write DVD-RAM media
  Does support test writing

  Does read Mode 2 Form 1 blocks
  Does read Mode 2 Form 2 blocks
  Does read digital audio blocks
  Does restart non-streamed digital audio reads accurately
  Does support Buffer-Underrun-Free recording
  Does read multi-session CDs
  Does read fixed-packet CD media using Method 2
  Does not read CD bar code
  Does read R-W subcode information
  Does not return R-W subcode de-interleaved and error-corrected
  Does read raw P-W subcode data from lead in
  Does return CD media catalog number
  Does return CD ISRC information
  Does support C2 error pointers
  Does deliver composite A/V data

  Does play audio CDs
  Number of volume control levels: 255
  Does support individual volume control setting for each channel
  Does support independent mute setting for each channel
  Does not support digital output on port 1
  Does not support digital output on port 2

  Loading mechanism type: tray
  Does support ejection of CD via START/STOP command
  Does not lock media on power up via prevent jumper
  Does allow media to be locked in the drive via PREVENT/ALLOW command
  Is not currently in a media-locked state
  Does not support changing side of disk
  Does not have load-empty-slot-in-changer feature
  Does not support Individual Disk Present feature

  Maximum read  speed:  1411 kB/s (CD   8x, DVD  1x, BD  0x)
  Current read  speed:     0 kB/s (CD   0x, DVD  0x, BD  0x)
  Maximum write speed:  4234 kB/s (CD  24x, DVD  3x, BD  0x)
  Current write speed:   706 kB/s (CD   4x, DVD  0x, BD  0x)
  Rotational control selected: CLV/PCAV
  Buffer size in KB: 2048
  Copy management revision supported: 1
  Number of supported write speeds: 1
  Write speed # 0:  4234 kB/s CLV/PCAV (CD  24x, DVD  3x, BD  0x)

Current performance according to MMC get performance:

Maximum performance according to MMC get performance:

Supported profiles according to MMC-4 feature list:
Current: none
Profile: DVD-ROM 
Profile: CD-RW 
Profile: CD-R 
Profile: CD-ROM 

Supported features according to MMC-4 feature list:
Feature: 'Profile List' (current) (persistent)
Feature: 'Core' (current) (persistent)
Feature: 'Morphing' (current) (persistent)
Feature: 'Removable Medium' (current) (persistent)
Feature: 'Random Readable'  
Feature: 'Multi Read'  
Feature: 'CD Read'  
Feature: 'DVD Read'  
Feature: 'Incremental Streaming Writable'  
Feature: 'Formattable'  
Feature: 'Restricted Overwrite'  
Feature: 'CD-RW CAV Write'  
Feature: 'DVD+RW'  
Feature: 'DVD+R'  
Feature: 'CD Track at Once'  
Feature: 'CD Mastering'  
Feature: 'DVD+R/DL Read'  
Feature: 'Power Management' (current) (persistent)
Feature: 'CD Audio analog play' (current) 
Feature: 'Microcode Upgrade' (current) (persistent)
Feature: 'Time-out' (current) (persistent)
Feature: 'DVD-CSS'  
Feature: 'Real Time Streaming' (current) 
# cdrecord -v dev=/dev/cdrom Downloads/archlinux-2013.09.01-dual.iso
...
Forcespeed is OFF.
Starting to write CD/DVD/BD at speed 4 in real SAO mode for single session.
Last chance to quit, starting real write    0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
BURN-Free is OFF.
Performing OPC...
Sending CUE sheet...
Writing pregap for track 1 at -150
Starting new track at sector: 0
Track 01:    0 of  525 MB written.cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB:  2A 00 00 00 01 F0 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 03 00 00 00 00 0A 00 00 00 00 0C 00 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x0C Qual 0x00 (write error) Fru 0x0
Sense flags: Blk 0 (not valid) 
cmd finished after 6.379s timeout 200s

write track data: error after 1015808 bytes
cdrecord: A write error occured.
cdrecord: Please properly read the error message above.
Writing  time:  107.174s
Average write speed 147.2x.
Fixating...
Fixating time:    0.002s
cdrecord: fifo had 80 puts and 17 gets.
cdrecord: fifo was 0 times empty and 7 times full, min fill was 93%.
#

So, it dies. I tried it a couple of times, with different media.
What is interesting - there are 2 cdrecord processes while burning.
# fuser -v /dev/sr0
                     USER        PID ACCESS COMMAND
/dev/sr0:            root      10330 F.... cdrecord
                          root      10342 F.... cdrecord
$ ps auxww |grep cdrecord
root     10330  0.0  1.0   8468  8328 pts/3    DL+  23:01   0:00 cdrecord -v dev=/dev/cdrom Downloads/archlinux-2013.09.01-dual.iso
root     10342  0.0  0.6   8468  4668 pts/3    S+   23:02   0:00 cdrecord -v dev=/dev/cdrom Downloads/archlinux-2013.09.01-dual.iso

Note status of processes:
DL+    uninterruptible sleep (usually IO), etc
S+      interruptible sleep (waiting for an event to complete)

I googled and found a post by Jörg Schilling (cdrecord author), in response to above error lines,
that it is about some other app or process trying to acccess /dev/sr0 while cdrecord does too.
So I stopped udisks service
# systemctl stop udisk
that gave me this log entry approx around time I run cdrecord first time (it accessed /dev/sr0 and it could be
a suspect then, but not this time)
...
Oct 20 22:29:48 myhost udisks-daemon[166]: **** CHANGING /sys/devices/pci0000:00/0000:00:1f.1/ata1/host0/target0:0:1/0:0:1
:0/block/sr0
Oct 20 22:29:48 myhost udisks-daemon[166]: **** UPDATING /sys/devices/pci0000:00/0000:00:1f.1/ata1/host0/target0:0:1/0:0:1
:0/block/sr0
Oct 20 22:29:48 myhost udisks-daemon[166]: **** EMITTING CHANGED for /sys/devices/pci0000:00/0000:00:1f.1/ata1/host0/target0:0:1/0:0:1:0/block/sr0
Oct 20 22:29:48 myhost udisks-daemon[166]: **** CHANGED /sys/devices/pci0000:00/0000:00:1f.1/ata1/host0/target0:0:1/0:0:1:0/block/sr0
...

I also noticed that my xterm (from which I executed cdrecord) was locked up (could  not switch or open tabs).

I tried with XFCE's Xfburn, with the same result.
What is going on ?

Last edited by jb.1234abcd (2013-10-21 12:11:25)

Offline

#2 2013-10-20 21:22:49

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] cdrecord fails to burn iso on cd-r disk

Please use code tags for output.

Offline

#3 2013-10-21 12:13:12

jb.1234abcd
Member
Registered: 2013-10-14
Posts: 15

Re: [SOLVED] cdrecord fails to burn iso on cd-r disk

Solved.
It was trivial: I cleaned the drive twice with a  special kit.

Offline

Board footer

Powered by FluxBB