You are not logged in.

#1 2013-10-22 11:23:35

tobast
Member
Registered: 2013-10-22
Posts: 7

[Wireless - rt2800] module-related connection drops

Hello,

I was cutted from the Internet for a while (about the last 6 weeks), but my WiFi was working. When I had an Internet access again, I did all the updates (including kernel updates) and since my reboot (and then kernel reload), my wireless connection drops at quite random intervals of time. To restore it until the next drop, I've got to unload the module (rt2800pci), reload it, then kill wpa_supplicant to allow it to restart from scratch.
When consulting dmesg, it gives me the following output:

[ 2262.012259] wlo1: authenticate with (...)
[ 2262.017933] wlo1: send auth to (...) (try 1/3)
[ 2262.019375] wlo1: authenticated
[ 2267.064579] wlo1: deauthenticating from e8:be:81:09:4a:60 by local choice (reason=3)

[...]

[ 4363.985335] ieee80211 phy6: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[ 4364.118769] ieee80211 phy6: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[ 4364.252183] ieee80211 phy6: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[ 4364.385605] ieee80211 phy6: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush
[ 4364.422302] ieee80211 phy6: rt2x00queue_write_tx_frame: Error - Dropping frame due to full tx queue 0
[ 4365.609733] ieee80211 phy6: rt2x00queue_flush_queue: Warning - Queue 0 failed to flush
[ 4365.743157] ieee80211 phy6: rt2x00queue_flush_queue: Warning - Queue 2 failed to flush

The queue-related messages are nearly spamming my logs, and the "phy*" id (6 here) seems to be resetted each time I reload the module.

According to my researchs, it seems that this problem existed a while ago (2.6.something) and was fixed… Also, I haven't found any other answer than "update your kernel, it is now fixed", which obviously doesn't help me much in this context.

Please note that it cannot be hardware-related, since WiFi works perfectly on my dual boot with Windows 7.

Any idea how to fix that?

---
Kernel: 3.11.6-1-ARCH
Laptop: HP envy m6
WiFi module used: rt2800{pci,lib,mmio}
WiFi module version: 2.3.0
System up-to-date

Offline

#2 2013-10-22 12:41:24

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,237

Re: [Wireless - rt2800] module-related connection drops

[ 2267.064579] wlo1: deauthenticating from e8:be:81:09:4a:60 by local choice (reason=3)

This caught my attention , and a search for that lead me to this : http://blog.tessarakt.de/archiv/2013/05 … al-choice/

It's in german, but basically states after an update networkmanager was installed, and that made the ifup command fail.

You could have a similar conflict between the way you start wireless and the presence of networkmanager, wicd, netcfg, netctl etc.

some questions fro you :
How are you starting wireless ?

Which (if any) network chooser programs do you have installed ?

What WM/DE do you use ?

Does the problem also occur if you boot to console and don't use X at all ?


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2013-10-22 12:55:19

tobast
Member
Registered: 2013-10-22
Posts: 7

Re: [Wireless - rt2800] module-related connection drops

Hello,
Thank you for your answer, I would have had no chance to get this post since I don't speak german at all.

I'm indeed using NetworkManager, and I use Openbox as a standalone WM ; but I also have installed wicd (though it is stopped and disabled in systemd), and I suppose that netcfg is also installed, as with the default arch installer.
I've removed NetworkManager (I mean, the package itself) and started wicd, and it seems to be indeed working (even if I'm only testing it for minutes now).

Anyway, what you've said seems to be concording: I omitted to say that when I tried to enable WiFi directly with wpa_supplicant to get to the lowest level, it failed by "downing" the interface each time I tried, even if I did `ifconfig wlo1 up` just before trying to connect.

Thank you!

EDIT: The problem is not solved, but it gave me more informations: the connection is only dropping when I attempt to use my connection a bit heavily: it dropped when I tried to run rankmirrors.

I'll try to disable X and connect using only a TTY to check if the problem persists.

Still, one more information: the message you've focused on no longer appears when I only run wpa_supplicant directly. It seems to be related to the fact I did not killed wpa_supplicant after reloading the kernel module, and not directly related to the issue.

EDIT2: when booting directly to a TTY and enabling WiFi using directly wpa_supplicant, the result is the same: the connection drops after the first "heavy" WiFi card usage.

Last edited by tobast (2013-10-22 13:19:32)

Offline

#4 2013-10-23 19:09:22

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,237

Re: [Wireless - rt2800] module-related connection drops

Can you post the full dmesg (use a pastebin site) from a boot to tty, using wpa_supplicant and forcing the connection drop ?

Also, please check which kernelversion you were running before the upgrade.
Try downgrading to that version to check if the problem is the kernel module or another update.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#5 2013-10-23 19:40:40

tobast
Member
Registered: 2013-10-22
Posts: 7

Re: [Wireless - rt2800] module-related connection drops

Hello,

Here's the full dmesg: http://pastebin.com/ekMuJbRc

I'll try downgrading as soon as I'll have time to do it. How do you identify the version of the previous installed package?

Thanks again,
Tobast.

Offline

#6 2013-10-23 23:13:40

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,237

Re: [Wireless - rt2800] module-related connection drops

look in /var/log/pacman.log for lines like this :

2013-10-21 02:11] [PACMAN] upgraded linux (3.11.5-1 -> 3.11.6-1)

It does look like someone else already is working on this bug :
http://comments.gmane.org/gmane.linux.k … ral/113924

It's clear now that this is a kernel bug, best solution for now would be to downgrade to a working kernel.
You could also try the linux-lts kernel (3.10.x ).


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#7 2013-10-26 11:50:37

tobast
Member
Registered: 2013-10-22
Posts: 7

Re: [Wireless - rt2800] module-related connection drops

Hello,

Thanks again, I've downgraded to the previous kernel. The problem did not occured again. I'll wait until it's fixed to upgrade my kernel again.

Solved.

Offline

Board footer

Powered by FluxBB