You are not logged in.

#1 2013-10-28 15:41:45

ZeroLinux
Member
Registered: 2011-10-07
Posts: 133

After shutting down desktops often reboots

I have:
MoBo: GIGABYTE GA-Z87X-UD4H
CPU: Intel Core i7-4770K Haswell 3500Mhz
Arch in Dualboot with Win8.1
When I try to shutdown the computer in 90% reboots. It never happens under Win8.1 and if I turn down the computer from rEFInd menu. So the problem seems to be software related.
The same reboot happens when I do

systemctl poweroff
shutdown -h now

It also reboots sometimes when I shutting down the computer from archlinux-2013.10.01-dual.iso
There is none parameters passed to kernel.

Offline

#2 2013-10-28 16:20:31

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: After shutting down desktops often reboots

I had this issue some time ago, but I wasn never able to figure out what was causing it.  I imagine that it was the kernel, as I kind of remember it happening before and after my switch to systemd.  At some point in time, it just kind of fixed itself.  Unfortunately, an issue like that is incredibly hard to bedug for an end user, as there is no realy way to gather information about what is going on.

Do your journals at least indicate that the system is actually headed towards shutdown and not reboot?  With my past issue, it would actually look like it was going to shutdown, and in fact the restart from a shutdown differed slightly from the intentional reboot.

Boot with break=premount on the kernel command line and see if you can shutdown from there.  You will need to use shutdown -f.  But it seems like that might be a good test, as it is essentially booted from the same kernel.  If it works from there, it might be something higher level than the kernel.

Offline

#3 2013-10-28 16:39:40

ZeroLinux
Member
Registered: 2011-10-07
Posts: 133

Re: After shutting down desktops often reboots

Thanks. I'll try
Tha last what I can see on the screen is:

Not all DN devices detached, 1 left (I cannot understand what it could be)
Cannot finalize remaining file systems and devices, giving up.
Storage is finilized
[87.472234] mei_me 0000:00:16.0: stop
[87.473489] reboot: Power down

Last edited by ZeroLinux (2013-10-28 16:40:20)

Offline

#4 2013-10-28 18:08:34

qinohe
Member
From: Netherlands
Registered: 2012-06-20
Posts: 885

Re: After shutting down desktops often reboots

This mei_me ( Intel Management Engine Interface) for Mobile Intel Express Chipset, causes a lot of trouble.
You can blacklist the module, you could lose functionality that I'm not aware of.
If your laptop supports it you may be able to disable it in your BIOS.
I read people having success disabling it, though their all different issues.

Offline

#5 2013-10-28 18:42:07

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,413

Re: After shutting down desktops often reboots

ZeroLinux wrote:

Thanks. I'll try
Tha last what I can see on the screen is:

Not all DN devices detached, 1 left (I cannot understand what it could be)
Cannot finalize remaining file systems and devices, giving up.
Storage is finilized
[87.472234] mei_me 0000:00:16.0: stop
[87.473489] reboot: Power down

I think you should check the actual journal instead (journalctl).  Just make sure you are either in the systemd-journal group or run journalctl as root.  If you want just logs for the previous boot, you can use journalctl -b -1.  Just -b would give you the current boot, and -2 would give you two boots before, -3, three boots before, etc.

Offline

#6 2013-10-28 20:08:45

DarkSkyGhost
Member
From: Vilnius, Lithuania
Registered: 2011-04-18
Posts: 13

Re: After shutting down desktops often reboots

Same thing happens for me. Only I noticed that the system actually powers down, and then instantly turns on - a bit differently than after a simple reboot command. Never happens if shutdown is initiated from windows.

Arch + Win8
GA-MA78G-DS3H
Latest linux-ck


Whatever happens, happens.

Offline

#7 2013-10-29 06:34:26

ZeroLinux
Member
Registered: 2011-10-07
Posts: 133

Re: After shutting down desktops often reboots

DarkSkyGhost wrote:

Same thing happens for me. Only I noticed that the system actually powers down, and then instantly turns on - a bit differently than after a simple reboot command. Never happens if shutdown is initiated from windows.

Exactly the same desktop behavior happens to me. I added kernel parameter acpi=force. It starts to power on immediately after shutdown not so often.
Blacklisting mei_me didn't help.
As I mentioned when Win8.1 shuts down or I shutdown computer from rEFInd everything shutdowns OK, without power on in a second.
So linux during shutting down does it in a way, different from that  of Win8 and rEFInd. How to force linux to do in in the similar way?
BTW, when in BIOS I "disable" Wake-On-Lan feature even linux shutdows correctly then. But I need WOL.

Last edited by ZeroLinux (2013-10-29 09:09:25)

Offline

#8 2013-11-02 21:15:55

alphazo
Member
Registered: 2009-10-20
Posts: 163

Re: After shutting down desktops often reboots

Exact same issue here with GA-Z87N-Wifi and i7 4770s. It doesn't do it (shutdown + instant reboot) all the time though. I'm running Linux-LTS kernel but had the same issue with regular Linux kernel.

Last edited by alphazo (2013-11-02 22:05:01)

Offline

#9 2013-12-19 23:32:35

olyveira
Member
Registered: 2013-12-19
Posts: 2

Re: After shutting down desktops often reboots

alphazo wrote:

Exact same issue here with GA-Z87N-Wifi and i7 4770s. It doesn't do it (shutdown + instant reboot) all the time though. I'm running Linux-LTS kernel but had the same issue with regular Linux kernel.

I just solve the problem with my GA-Z87N-WIFI.

I have this board with a Nvidia (GTX 760) and installed openSUSE.

Happened, when performed the shutdown, the computer shut but after 2-3 seconds reboot.

My power supply was 450W. However, I got tired of going around the head until I read on page 23 of the GA-Z87N-WIFI manual which case we use the PCI-E was advisable to use a power supply of 500W or higher, as lower springs would destabilize (possible cause of the reboot).

Made to upgrade to a 650W power supply and reboots after shutdown, never happened.

Conclusion: new graphics cards are hungry for energy. Always check the power requirements of the printing and adjust energy sources.

Hope this helps.

Offline

#10 2013-12-21 15:43:15

alphazo
Member
Registered: 2009-10-20
Posts: 163

Re: After shutting down desktops often reboots

My PCI-E slot is empty since I use the HD4600 GPU found in my 4770S CPU which only has a 65W TDP. The only other peripheral I have is a small SSD. So I think that my Corsair CX430M (430W) should be able to handle the task. Apparently the problem goes away if you disable the Wake-up LAN feature on the Intel NIC.

Offline

#11 2013-12-27 15:52:43

olyveira
Member
Registered: 2013-12-19
Posts: 2

Re: After shutting down desktops often reboots

alphazo wrote:

My PCI-E slot is empty since I use the HD4600 GPU found in my 4770S CPU which only has a 65W TDP. The only other peripheral I have is a small SSD. So I think that my Corsair CX430M (430W) should be able to handle the task. Apparently the problem goes away if you disable the Wake-up LAN feature on the Intel NIC.

Thanks for the tip "alphazo". Was already despairing with the machine do not properly shutdown ...

By default, the Wake-up LAN is enabled in BIOS (Power Manegement). As I have a Synology NAS configured for my private network, the "trickster" is sending packets to the network and enables me to Linux machine after doing this shutdown.

I followed your recommendation (I disabled the Wake-up LAN) and everything works as expected.

Offline

#12 2014-02-06 22:56:51

alphazo
Member
Registered: 2009-10-20
Posts: 163

Re: After shutting down desktops often reboots

Don't bother flashing the new F5 bios for GA-Z87N-Wifi that has been released few days ago... it doesn't fix the problem ;(

Offline

#13 2014-06-23 11:48:08

quantumphaze
Member
From: Melbourne, Australia
Registered: 2008-11-14
Posts: 169

Re: After shutting down desktops often reboots

This happens to me too on an ASRock H87M Pro4 motherboard. None of the above sugestions have worked for me.

I found a relevant kernel bug here. Comments point to the xhci module not shutting down the hardware correctly being the cause.


▁▂▃▄▅▆▇█▉▊▋▌▍▎▏▏▎▍▌▋▊▉█▇▆▅▄▃▂▁

Offline

Board footer

Powered by FluxBB